Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

DHCP Scope for VLAN

SOLVED
Go to solution
Ezugo
Advisor

DHCP Scope for VLAN

Hi,

I have recently configured a VLAN (VLAN 2) on a HP 4208vl.
VLAN has interface IP 172.14.10.254/16
A wireless AP is plugged into VLAN 2

I have set up a scope on my DHCP 172.14.10.0-254/16

I have configured IP-Helper on VLAN 2 as DHCP is located on 10.14.10.4/16

when I connect using the wireless AP - I still recieve IP address from default DHCP Scope (I get 10.14.10.X)

What am I missing - Why do I not get an address frome the 172 scope?

Thanks,
41 REPLIES
cenk sasmaztin
Honored Contributor
Solution

Re: DHCP Scope for VLAN

which of your access point device

and please send me show run print your switch
cenk

Ezugo
Advisor

Re: DHCP Scope for VLAN

ProCurve Switch 4208vl# show run

Running configuration:

; J8773A Configuration Editor; Created on release #L.10.23

hostname "ProCurve Switch 4208vl"
module 1 type J8768A
module 3 type J8768A
module 4 type J8768A
module 5 type J8768A
module 2 type J9033A
ip default-gateway 10.14.40.254
ip routing
ip irdp
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged A1-A24,B1-B17,B21-B24,C1-C24,D1-D24,E1-E24
ip address dhcp-bootp
no untagged B18-B20
exit
vlan 2
name "VLAN_Wire"
ip address 172.14.10.254 255.255.0.0
ip helper-address 10.14.10.4
tagged A18,B17-B20
exit
vlan 10
name "management"
ip address 10.0.10.1 255.255.255.0
tagged B17
exit

The AP is a HP Procurve 420
cenk sasmaztin
Honored Contributor

Re: DHCP Scope for VLAN

your switch configuration is true
we can check access point

please send me
show system and show ssid index 1-2...
print on 420

cenk

Ezugo
Advisor

Re: DHCP Scope for VLAN

info attached
Ezugo
Advisor

Re: DHCP Scope for VLAN

...and thanks for your time Cenk.
cenk sasmaztin
Honored Contributor

Re: DHCP Scope for VLAN

your access point configuration vlan stata is disable
please enter this command on access point

420(config)#vlan enable static

and retest



cenk

Ezugo
Advisor

Re: DHCP Scope for VLAN

I am now unable to get an IP address from DHCP?
cenk sasmaztin
Honored Contributor

Re: DHCP Scope for VLAN

which port connect to switch your access point
cenk

cenk sasmaztin
Honored Contributor

Re: DHCP Scope for VLAN

and which port connect your dhcp server
cenk

Ezugo
Advisor

Re: DHCP Scope for VLAN

Port B17

I just set it to tagged on Default LAN - no difference.
Ezugo
Advisor

Re: DHCP Scope for VLAN

DHCP Server is on A1
cenk sasmaztin
Honored Contributor

Re: DHCP Scope for VLAN

we must come back switch config

ip helper command runing with routing
but your have not ip address default vlan
your dhcp server in default vlan

please change switch config

ip routing
ip irdp
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged A1-A24,B1-B17,B21-B24,C1-C24,D1-D24,E1-E24
ip address 10.14.10.254 255.255.0.0********
no untagged B18-B20
exit
vlan 2
name "VLAN_Wire"
ip address 172.14.10.254 255.255.0.0
ip helper-address 10.14.10.4
tagged A18,B17-B20
exit
vlan 10
name "management"
ip address 10.0.10.1 255.255.255.0
tagged B17
exit

and dhcp server default gateway address must have vlan 1 ip address(10.14.10.254)
cenk

Ezugo
Advisor

Re: DHCP Scope for VLAN

the DEFAULT_VLAN is my LAN - how will this affect PCs on the LAN?

The DHCP current IP is 10.14.10.4
cenk sasmaztin
Honored Contributor

Re: DHCP Scope for VLAN

does not affect any of the

give me a few minutes you'll be prepared for a new general configuration
cenk

Ezugo
Advisor

Re: DHCP Scope for VLAN

I've assigned default_vlan IP address 10.14.10.254

Default gateway for DHCP Scope 172.14.10.0-254/16 is now 10.14.10.254.

a laptop connecting via wireless network cannot get IP address from DHCP
cenk sasmaztin
Honored Contributor

Re: DHCP Scope for VLAN

---------------switch config----------------
ip default-gateway 10.14.40.254
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged A1-A24,B2-B24,C1-C24,D1-D24,E1-E24
ip address 10.14.10.254 255.255.0.0
no untagged B18-B20
exit
vlan 2
name "guest"
ip address 10.15.10.254 255.255.0.0
ip helper-address 10.14.10.4
untagged B1
tagged A1-A24,B2-B24,C1-C24,D1-D24,E1-E24
exit

----------------dhcp config-----------------
ip address 10.14.10.4 ***connect port A1
subnet mask 255.255.0.0
default gateway 10.14.10.254 !!!!!!

scobe 1 for lan
range 10.14.---255.255.0.0
default gateway 10.14.40.254


scobe 2 for guest
range 10.15.--- 255.255.0.0
default gateway 10.15.10.253

-----------------internet router--------------
already running one lan interface on router
10.14.40.254 this interface connect port A2

you must have create new isolated lan interface on internet (samely DMZ)
router second lan interface ip address must have 10.15.10.253 this interface connect B1

--------------access point--------

your access point config Keep as
only change ip address for example 10.14.10.200/16
and connect on any switch port
cenk

cenk sasmaztin
Honored Contributor

Re: DHCP Scope for VLAN

your switch don't support access control list
for this reason, such a configuration to make the necessary security and perfromans

you must have create second lan interface for guest wireless users on internet router for their internet connection

with this configuration one dhcp server serve all guest and lan user each other without mixing
cenk

cenk sasmaztin
Honored Contributor

Re: DHCP Scope for VLAN

please test and say me result

good evening
cenk

Ezugo
Advisor

Re: DHCP Scope for VLAN

Thanks Cenk,

i shall give this a go and see if I can get it working.
Ezugo
Advisor

Re: DHCP Scope for VLAN

Good morning,

right, changing the Default Gateway on the DHCP solves the problem of clients getting DHCP IP addresses - however causes authentication problems with OWA - I have ISA in DMZ authenticating OWA access.

is there a way round this?
Ezugo
Advisor

Re: DHCP Scope for VLAN

I can use the 2nd NIC card on the server?
cenk sasmaztin
Honored Contributor

Re: DHCP Scope for VLAN

please send me network layout
cenk

cenk sasmaztin
Honored Contributor

Re: DHCP Scope for VLAN

and current switch config
cenk

Ezugo
Advisor

Re: DHCP Scope for VLAN

my current network attached - I still need to set up lan interface 0/3 on the firewall

also need to connect second DHCP NIC to switch probably on port A2

module 2 type J9033A
ip default-gateway 10.14.40.254
ip routing
ip irdp
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged A1-A24,B1-B17,B21-B24,C1-C24,D1-D24,E1-E24
ip address 10.14.10.254 255.255.0.0
no untagged B18-B20
exit
vlan 2
name "Guest"
untagged B18
ip address 10.15.10.254 255.255.0.0
ip helper-address 10.14.10.4
tagged A1,A18,B17,B19-B20
exit
vlan 10
name "management"
ip address 10.0.10.1 255.255.255.0
tagged B17
exit

ProCurve Switch 4208vl#