Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

DHCP, VLAN, VOIP Phones

Matt Axton
Occasional Advisor

DHCP, VLAN, VOIP Phones

Hi,

I have a 3500 switch with a number of vlans on then (data100 and voice101) these are connected to edge switches with a default vlan, data100 and voice101 vlans on them.

The edge switches are configured as follows.
vlan 1
name "DEFAULT_VLAN"
untagged 49-50
ip address 10.8.0.3 255.255.255.192
no untagged 1-48
exit
vlan 100
name "Data"
untagged 1-48
tagged 49-50
exit
vlan 101
name "Voice"
tagged 1-50
voice
exit

The core is configured as such

vlan 1
name "DEFAULT_VLAN"
untagged 1-8,12,15-18,Trk1
ip address 10.8.0.1 255.255.255.192
no untagged 9-11,13-14,19-20
exit
vlan 14
name "Production"
untagged 9-10,19-20
ip address 10.8.1.254 255.255.255.0
tagged Trk1
exit
vlan 16
name "Avaya Phone"
untagged 13-14
ip helper-address 10.8.1.1
ip address 10.8.116.254 255.255.255.0
tagged Trk1
exit
vlan 100
name "Data"
ip helper-address 10.8.1.1
ip address 10.8.10.254 255.255.255.0
tagged 1-2,7,Trk1
exit
vlan 101
name "Voice"
ip helper-address 10.8.1.1
ip address 10.8.11.254 255.255.255.0
tagged 1-2,7,Trk1
voice
exit

The 3 edge switches are plugged from port 50 into ports 2, 3 & 7 on the core switch.

Devices plugged into edges 2 & 3 work fine, get IP addresses as do the VOIP phones, however, no devices get any ip addresses from the 3rd edge switch (all edges are configured the same)

The link between edges 1&2 are cat5 the 3rd is over a point-to-point bridge.

I have run wireshark on the DHCP server and see the DHCP discover packets coming from the devices plugged into the 3rd egde. I do not see and DHCP offer back out to the 3rd edge.

I have rebuilt the DHCP server but to no avail.

Any ideas

(Oh and sorry for the long winded version) :)
7 REPLIES
cenk sasmaztin
Honored Contributor

Re: DHCP, VLAN, VOIP Phones

The link between edges 1&2 are cat5 the 3rd is over a point-to-point bridge

whic port connect on switch point to point bridge device ?



I'm not see ip routing enable on core switch
you can use ip helper address command must be ip routing enable.
cenk

Matt Axton
Occasional Advisor

Re: DHCP, VLAN, VOIP Phones

Sorry - I can confirm that IP routing is enabled and port 7 in the point-to-point link.

Is it common practice for 3rd parties to block broadcasts from a bridge link?
Matt Axton
Occasional Advisor

Re: DHCP, VLAN, VOIP Phones

Hi,

Just got off the phone from the 3rd party supplier of the point-to-point link.

They have said that the DHCP broadcasts are making it across the link but the other end is not passing it from the WAN to LAN interfaces so fingers crossed its that.
cenk sasmaztin
Honored Contributor

Re: DHCP, VLAN, VOIP Phones

int 7 conncet point to point bridge device on core
vlan 1 untag member
vlan 101 tag member

very good config
but which port connect point to point bridge device on other edge switch

your edge switch config
point to point bridge device connect must be int 49 or 50

The edge switches are configured as follows.
vlan 1
name "DEFAULT_VLAN"
untagged 49-50
ip address 10.8.0.3 255.255.255.192
no untagged 1-48
exit
vlan 100
name "Data"
untagged 1-48
tagged 49-50
exit
vlan 101
name "Voice"
tagged 1-50
voice
exit

cenk

cenk sasmaztin
Honored Contributor

Re: DHCP, VLAN, VOIP Phones

whic vedor point to point bridge device
cenk

Matt Axton
Occasional Advisor

Re: DHCP, VLAN, VOIP Phones

Yup, Corerct...

Edge 1 - port 50 to core port 1
Edge 2 - port 50 to core port 2
Edge 3 - port 50 to core port 7

Am awaiting tech support from 3rd line to get back regarding dropping of the DHCP broadcasts... Gits :)
cenk sasmaztin
Honored Contributor

Re: DHCP, VLAN, VOIP Phones

hi Matt your procurve config true
as for me trouble point to point bridge

cann't cary dhcp packet this device

whic manufacturer this device
cenk