Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

DHCP across VLAN's.

SOLVED
Go to solution
Karl Collinson
Frequent Advisor

DHCP across VLAN's.

Morning\Afternoon\Evening all,

Almost finished with the Procurv config =0).

Just need one more pointer...
The Router on VLAN1 has Wi-Fi, i require VLAN1 relay all DHCP requests to VLAN3 as DHCP is disabled on the router.

So far tried: -
DHCP-Relay
Ip Helper-address DHCP.IPAddress.ON.VLAN3.

(Routing is enabled).

No joy so far?

Any help would be greatful!!

Thx,
Karl.
18 REPLIES
cenk sasmaztin
Honored Contributor
Solution

Re: DHCP across VLAN's.

hi karl

your require config on procurve ip helper address
this sh config print carefully in dhcp server address

good luck...

sh run

Running configuration:

; J4900B Configuration Editor; Created on release #H.10.38

hostname "ProCurve Switch 2626"
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-14,21-26
ip address 100.100.100.1 255.255.255.0
no untagged 15-20
exit
vlan 2
name "VLAN2"
untagged 15-20
ip address 100.100.101.1 255.255.255.0
ip helper-address 100.100.100.100
exit

ProCurve Switch 2626(config)#
cenk

Karl Collinson
Frequent Advisor

Re: DHCP across VLAN's.

Thx for your reply...

If done that, and still no DHCP on VLAN1??

Please see config..

--------
Running configuration:

; J8164A Configuration Editor; Created on release #H.10.45

hostname "ProCurve Switch 2626-PWR"
ip default-gateway 192.168.254.254
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 7-26
ip address 192.168.254.253 255.255.255.0
ip helper-address 10.0.3.2
no untagged 1-6
exit
vlan 2
name "VoIP"
untagged 1-3
ip address 10.0.2.1 255.255.255.0
qos priority 7
voice
exit
vlan 3
name "Data"
untagged 4-6
ip address 10.0.3.1 255.255.255.0
exit
ip route 0.0.0.0 0.0.0.0 192.168.254.254

------------

Thx,
Karl.
cenk sasmaztin
Honored Contributor

Re: DHCP across VLAN's.

hi karl

vlan 1
untagged 7-26
ip address 192.168.254.253 255.255.255.0
ip helper-address 10.0.3.2 (your dhcp server must be on vlan 3 and must be one dhcp scobe relay default gateway 192.168.254.253 ip range 192.168.254.10 to 192.168.254.250)


vlan 2 no any dhcp relay because seperate broadcast domain and no use ip helper
vlan 2
name "VoIP"
untagged 1-3
ip address 10.0.2.1 255.255.255.0
qos priority 7
voice
exit


vlan 3 on the dhcp server whit 10.0..3.2 ip address ,because dhcp scobe for vlan 1 ip range you create second scobe on dhcp server
for vlan 3 :default gateway 10.0.3.1 and ip range 10.0.3.10 to 10.0.3.250
vlan 3
name "Data"
untagged 4-6
ip address 10.0.3.1 255.255.255.0
exit
ip route 0.0.0.0 0.0.0.0 192.168.254.254

ip route command through static route your internet router
because you want vlan 2 and vlan 3 internet or wide area connection must be on write you internet router static route entry

router#ip route 10.0.2.0 255.255.255.0 10.0.2.1

router#ip route 10.0.3.0 255.255.255.0 10.0.3.1

router#ip route 192.168.254.0 255.255.255.0 192.168.254.253



ip route 0.0.0.0 0.0.0.0 192.168.254.254


hope understand me

good luck..




cenk

Karl Collinson
Frequent Advisor

Re: DHCP across VLAN's.

Thanks for that...!!!! Think im with you.

Already have the static entries on my router and internet is working =0)...

I have a Svr03 with two NICS and two dhcp Scopes.

A diff scope bound to each NIC.
One Scope for IP phones, Another for Data.
"All works fine, vlan2 clients pick up an 10.0.2 address and vlan3 clients pick up an 10.0.3 address"

It would appear i would be better assigning a untagged port to VLAN3 and plugging in a WAP to that port "I assume that would work"?

Thanks,
Karl.

cenk sasmaztin
Honored Contributor

Re: DHCP across VLAN's.

hi Karl

if you do attach your system access point device to me to create

vlan 2 untag and vlan 3 tag port
for example
(config)#vlan 2
(vlan-2)#tag 4
(vlan-2)#vlan 3
(vlan-3)#untag 4

interface 4 vlan 3 member also vlan 2 tag port(802.1q)

and attach this port procurve 420 access point you create on access point device
two ssid ssid:data,ssid:voip
and ssid voip tag vlan 2 ssid data untag vlan 3 in this way one access point two ssid and sperate vlan; for use data ssid notebook ,mobil work computer, for use voip ssid wifiphone device ;)
cenk

Karl Collinson
Frequent Advisor

Re: DHCP across VLAN's.

Afternoon "Thanks for all the help so far"..
=0)

Your adivce is only if i want to give Wifi Access to the VoIP Vlan, am i correct in saying that?

Thx,
Karl.
cenk sasmaztin
Honored Contributor

Re: DHCP across VLAN's.

hi karl
I advice same access point use two vlan

because whatever producer access point attach your system ;example you want use vlan 2 connect this access point vlan 2 untag port.


good luck..
cenk

Colonelk
Frequent Advisor

Re: DHCP across VLAN's.

Just so you know Karl, I was unsuccessful in getting DHCP working across vlan boundaries on the 2900 switch (linked to a Dlink 3028p)

In the end I installed the DHCP service on the VoIP phone server running linux to service all the phones on vlan 10 (my voice vlan)

I tried the ip helper-address command for each vlan but it didn't seem to work for vlan 10.

I would be really nice to have an official HP document with examples for how to get this working with popular DHCP servers (Win 2003 for example).

Regards

Tino
Colonelk
Frequent Advisor

Re: DHCP across VLAN's.

I need to clarify. My post above talks about a DHCP server with one NIC as a untagged member of Vlan 1 and tagged member of vlan 10.

2 scopes on the DHCP server.

Karl Collinson
Frequent Advisor

Re: DHCP across VLAN's.

Morning Tino,

I had 2 DHCP issues...

One issue was getting the Windows Server 03 DHCP service to issue 2x different IP's\Subnets to the 2x VLAN's i had the server connected to (Server had 2x NICS, each NIC was connected to one of the VLANS)
"That now works"...

The other issue....
I required the DHCP service to relay 2 VLAN1 from VLAN3 so the WiFi router could serice DHCP request... (Router was located in VLAN1)..

Couldnt get round that so easily, so i used a WAP and untagged the port to VLAN3 where the DATA DHCP Service was accessable.

Thx,
Karl.
Colonelk
Frequent Advisor

Re: DHCP across VLAN's.

Hi Karl,

I had thought of using 2 Nics (one in each vlan) in that server and may well choose to do that when I do the swap over to the new network. At least then I'll be able to manage DHCP from the one server.

Good luck in your rollout.

Tino
Joel Belizario
Trusted Contributor

Re: DHCP across VLAN's.

Tino,

Just to clarify your post - was DHCP was working in every VLAN except 10 or not at all?

Colonelk
Frequent Advisor

Re: DHCP across VLAN's.

Hi Joel.

Previously DHCP would work for vlan 1 (the dhcp server was an untagged member of vlan 1) but not for vlan 10. I then tried the ip helper-address function on the switch assigned to vlan 10, pointing to the dhcp server on vlan 1. The IP phones were NOT able to pick up a dhcp assigned address this way.

So yesterday I added another NIC to the DHCP server and made the port the new NIC was attached to an untagged member of vlan 10 (and gave it an Ip address on that subnet). Now phones are able to pick up an address from the correct DHCP scope.

Joel Belizario
Trusted Contributor

Re: DHCP across VLAN's.

Is DHCP the only network traffic that is not getting through from VLAN 1 to 10? Or have you found that IP routing does not work at all from VLAN 1?

Just wondering because if you have enabled the "management-vlan" feature on VLAN 1 then it becomes a non-routable VLAN.

cenk sasmaztin
Honored Contributor

Re: DHCP across VLAN's.

hi karl
you can in vlan1 ip routing

you make switch config after dhcp server config

for example
ip routing
name "DEFAULT_VLAN"
untagged 1-10,21-26
ip address 100.100.100.1 255.255.255.0
ip helper-address 100.100.100.80
no untagged 11-20
exit
vlan 10
name "VLAN10"
untagged 11-20
ip address 100.100.110.1 255.255.255.0
ip helper-address 100.100.100.80
exit

dhcp server in vlan 1
scobe1 name :vlan 1
range 100.100.100.10 100.100.100.200 255.255.255.0 default gateway 100.100.100.1
dns 100.100.100.80(my dhcp and dns server nic ip)
scobe2 name:vlan 10
range 100.100.110.10 100.100.110.200 255.255.255.0 default gateway 100.100.110.1
dns 100.100.100.80(my dhcp and dns server)

very easy....

good luck


cenk

Colonelk
Frequent Advisor

Re: DHCP across VLAN's.

Hi Joel

I didn't realise that no routing occurred on the management vlan. I've set up a data vlan now (vlan 20) and set the management-vlan to vlan 1 (default_vlan)

Joel Belizario
Trusted Contributor

Re: DHCP across VLAN's.

Not many people do - I have been caught by this myself.

So does DHCP work in this case now or are you sticking to the dual NICs?
Colonelk
Frequent Advisor

Re: DHCP across VLAN's.

I'll stick with the Dual NIC's for now.

When I implement this on the network properly I may try the DHCP helper again. If I do I'll update the thread.

Thanks

Tino