Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

DHCP across vlans not working

Jeff74
Occasional Advisor

DHCP across vlans not working

My clients in VLAN25 are having to reboot several times to obtain an IP address in Windows XP. My config is below from my Procurve 2910al

My DHCP servver is 172.16.45.10 and my procurve switch is plugging into a 3com layer 2 switch which is setup as vlan25 only.

Running configuration:

; J9147A Configuration Editor; Created on release #W.14.38

hostname "ProCurve 2910al-48G Switch"
module 1 type J9147A
trunk 1-2 Trk1 LACP
ip default-gateway 172.16.45.1
ip routing
vlan 1
name "DEFAULT_VLAN"
untagged 41-48
ip address 172.16.45.1 255.255.255.0
no untagged 3-40,Trk1
exit
vlan 25
name "lvl2"
untagged Trk1
ip helper-address 172.16.45.10
ip address 172.16.25.1 255.255.255.0
exit
vlan 15
name "lvl1"
untagged 3-40
ip helper-address 172.16.45.10
ip address 172.16.15.1 255.255.255.0
exit
ip route 0.0.0.0 0.0.0.0 172.16.45.254
snmp-server community "public" unrestricted
snmp-server contact "Jeff Powers Ext 237" location "Server Room Lvl 1"
spanning-tree Trk1 priority 4
no autorun
password manager
password operator


20 REPLIES
cenk sasmaztin
Honored Contributor

Re: DHCP across vlans not working

hi jeff
what is the your dhcp server default gateway address
cenk

Jeff74
Occasional Advisor

Re: DHCP across vlans not working

172.16.45.1

I have removed the trk1 which was LACP between the 2 switches for a 2 GB connection. It is now just a single link to see if that helps my situation.
Jeff74
Occasional Advisor

Re: DHCP across vlans not working

The removal of the LACP link has not helped my situation :(
AUS Adam
Advisor

Re: DHCP across vlans not working

Switch config looks sound, I would put wireshark on a PC and /or the DHCP server and trace it at a packet level.

Shadow13
Respected Contributor

Re: DHCP across vlans not working

is this the only switch or there are other switched with routing enabled on them ?
Jeff74
Occasional Advisor

Re: DHCP across vlans not working

We have only 2 switches and 2 floors.

Default VLAN for servers
VLAN lvl1
VLAN lvl2

Now everyone on lvl1 is plugged into the Procurve switch and all is well.

Everyone on lvl2 is plugged into the 3com Baseline switch and are having trouble getting DHCP addresses. The 3com 2948 Baseline is a layer2 switch with all ports set to VLAN25 lvl2.

I setup wireshark and ran it on both workstations on each level unfortunately I got the same result for both floors which is not good as the second floor is not working all the time. Have attached the wireshark output from the problem floor when releasing and renewing the IP address in cmd.

Thanks for your help so far but am getting deperate and running out of ideas.
Jeff74
Occasional Advisor

Re: DHCP across vlans not working

My DHCP server is Windows 2003 with 3 scopes now I assume I don't need a superscope for these VLANS to work as I thought this was for multiple subnets on the same wire.
Shadow13
Respected Contributor

Re: DHCP across vlans not working

No which port this 3com switch is plugged on the HP switch ?
cenk sasmaztin
Honored Contributor

Re: DHCP across vlans not working

your dhcp server ip address 172.16.45.10
must have connect vlan 1 untag port

(because 172.16.45.0 network have vlan 1)

but I see your dhcp server connect on vlan 25
it is not working

please test and say me result
your 3com switch uplink port connect hp switch port 42
and dhcp server default gateway address must have 172.16.45.1
cenk

Pieter 't Hart
Honored Contributor

Re: DHCP across vlans not working

procurve is not really my "thing", but when looking at :
>>>
vlan 1
name "DEFAULT_VLAN"
untagged 41-48
ip address 172.16.45.1 255.255.255.0
no untagged 3-40,Trk1
<<<
my remark would be :
"no untagged 3-40,Trk1" is not he same as "tagged 3-40,Trk1"
As Trk1 seems like your uplink to another switch, I would expect all vlans "tagged Trk1"
Pieter 't Hart
Honored Contributor

Re: DHCP across vlans not working

correction,
I overlooked some info.
You say the 3Com is "setup vlan25 only".
Do you mean the 3Com knows about vlan 25?
or do you mean the 3Com is setup default (all ports vlan-1) but connects to the procurve vlan-25?
Then you must set the PVID of Trk1 ports to 25.
Jeff74
Occasional Advisor

Re: DHCP across vlans not working

hostname "ProCurve 2910al-48G Switch"
module 1 type J9147A
ip default-gateway 172.16.45.1
ip routing
vlan 1
name "DEFAULT_VLAN"
untagged 41-48
ip address 172.16.45.1 255.255.255.0
no untagged 1-40
exit
vlan 25
name "lvl2"
untagged 1-2
ip helper-address 172.16.45.10
ip address 172.16.25.1 255.255.255.0
exit
vlan 15
name "lvl1"
untagged 3-40
ip helper-address 172.16.45.10
ip address 172.16.15.1 255.255.255.0
exit
ip route 0.0.0.0 0.0.0.0 172.16.45.254
snmp-server community "public" unrestricted
snmp-server contact "Jeff Powers Ext 237" location "Server Room Lvl 1"
no autorun
password manager
password operator


DHCP server is plugged into port 42 so untagged DEFAULT VLAN 1

DHCP server GW is 172.16.45.1

The uplink is plugged into Port 1 untagged VLAN 25 lvl2 the 3com switch is set to untagged VLAN 25 lvl2 all ports.

Thanks
AUS Adam
Advisor

Re: DHCP across vlans not working

Hi Jeff,

Looking at the out put from wireshark this is from a successful ipconfig release / renew.

I would get a capture from a failed attempt from the host and the server, the idea is to see where the packet flow fails.

Just a quick one you don't need a 'ip default-gateway' command if you are running 'ip routing'
Jeff74
Occasional Advisor

Re: DHCP across vlans not working

I think I have solved it by turning off spanning tree on the 3com switch which obviously I dont need on a single cable connection between the switches.

I figured this out with watching the packet sniffer and seeing all these spaning tree packets which seemed to be every other packet on the wire.

Will report back tomorrow if this is indeed a solution. Thanks for your help I was going crazy is sometimes hard being a one man band.

Oh I have also turned off the default gateway and all seems happy so things are being fine tuned.
cenk sasmaztin
Honored Contributor

Re: DHCP across vlans not working

please send me sh tech print
cenk

Sudain
Advisor

Re: DHCP across vlans not working

I wonder if keeping STP on wouldn't be a good idea for you. You never know when an end user will decide plugging a cable into two wall jacks is a good idea...

Though you want to make sure STP on the same version for both switches. I suggest RSTP or MST as STP may be too slow and causing your issues.
Jeff74
Occasional Advisor

Re: DHCP across vlans not working

I do not have spanning tree enabled on either the HP Procurve or 3com switch at present and all is well.

If I renable LACP on 2 ports between the switches for 2GB connectino do I need spanning tree if one of the links drops out?

Thanks
Jeff Carrell
Honored Contributor

Re: DHCP across vlans not working

Jeff74
May 17, 2010 00:33:28 GMT
If I renable LACP on 2 ports between the switches for 2GB connectino do I need spanning tree if one of the links drops out?
----

No. LACP makes the ports look like one, even for STP.

So, if one link of a LACP group drops and comes back, STP does not know anything occurred.

You see this as well when you create a LACP trunk group, the interfaces become a new interface type of "TRKx".

If you do a 'show span' you will see the interface TRKx at the bottom of the list.

hth...Jeff
Shadow13
Respected Contributor

Re: DHCP across vlans not working

i think the issue was with the below:

ip default-gateway 172.16.45.1
ip route 0.0.0.0 0.0.0.0 172.16.45.254

each command was pointing to another place, but i think both commands has the same result but pointing to diff. location.

Jeff mentioned that he removed the defualt gateway, that's why it works now.

Not sure if what i mentioned makes sence :D
Jeff74
Occasional Advisor

Re: DHCP across vlans not working

I know what you are saying but removing the spanning tree was done before the routing issue was resolved. Either way I am happy and will put the LACP back on between the switches as this seemed to work well before.

I still feel inclined to leave spanning tree off both switches as the whole network is 2 switches and 60 users so nothing to complicated.

Thanks for all the replies. Much appreciated.