Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

DHCP doesn´t work through VLAN

SOLVED
Go to solution
Sosin
Occasional Contributor

DHCP doesn´t work through VLAN

We have some hp switches which are in different location. In our central location we have dhcp server. I try to receive dhcp ip adress from our central server. But it doesn´t work. I can not see dhcp discovery request from our location.
Location is 192.168.12.0/24. DHCP server 192.168.100.15.

Any idea. I think it should work with ip helper adress. Our locations are through WAN cisco router connected. Everything is working fine but not dhcp.

interface 48
disable
exit
ip default-gateway 192.168.12.254
ip routing
vlan 1
name "DEFAULT_VLAN"
untagged 1-48,50
ip address 192.168.12.254 255.255.255.0
ip helper-address 192.168.100.15
no untagged 49
exit
vlan 129
name "TransitTel"
untagged 49
ip address 192.168.135.22 255.255.255.248
exit
ip route 0.0.0.0 0.0.0.0 192.168.135.17
javascript:postMessageSubmit('submit');
Thank you and best regards,
8 REPLIES
Tore Valberg
Trusted Contributor

Re: DHCP doesn´t work through VLAN

Hi Sosin

How is your DHCP scope configured? Have you configured a scope with 192.168.12.254 as Default gateway for the clients in the scope router option?

How is your topology and what switch and software revision are you running?
las_2
Occasional Advisor
Solution

Re: DHCP doesn´t work through VLAN

1. Passthrough of DHCP protocol should be enabled on all network interfaces, connecting LANs, including Cisco router.

2.DHCP server should be accessible from hp switch (check by ping) and have DHCP scope for 192.168.12.0 network, else requests for address will be refused.

3.Check dhcp relay status on Procurve switches
(sh dhcp-relay ). This is enabled by default, but if disabled for some reason (you may see in config 'no dhcp-relay' command) turn it on by issueing #dhcp-relay command. Note that, only non-default 'no dhcp relay' shown in config.

I have similar config and it works.
las_2
Occasional Advisor

Re: DHCP doesn´t work through VLAN

And there should be a route somewhere

from 135.0 network to 100.0
or
from 12.0 to 100.00
(over VLANs on another switch or connected by router)

else your DHCP server would not be accessible.
Sosin
Occasional Contributor

Re: DHCP doesn´t work through VLAN

Thank you for your replies.
Yes I configured a scope with 192.168.12.254 as Default gateway. Switch hp 5304 version H.08.53. Topology: switch hp 2650(version h.08.53) -- cisco router -- WAN -- cisco router -- HP 5304 (version E.10.37) -- DHCP server 2008.
1. How can I check if paththrough is enabled on all interfaces? How can I check it also on the cisco router?
2.Routing is correct. I can ping, traceroute, nslookup, file access through WAN and etc.
3. sh dhcp-relay doesn´t work. Not recognized command. Is it a problem? I checked this command on our second switch with a higher version and it worked.
Thank you for attention.
Shadow13
Respected Contributor

Re: DHCP doesn´t work through VLAN

Can you ping the DHCP server on the other side from the 2650 switch ? and also from the server can you ping the switch IP address 192.168.12.254 ?

also i would recommend removing the command
ip default-gateway 192.168.12.254

since you have default static route configure then no need for this.

to double check also test the DHCP on the other side where the server is, connect a device and see if it gets an IP from that range.
Sosin
Occasional Contributor

Re: DHCP doesn´t work through VLAN

It works from both of side (ping, traceroute, routing). Also DHCP Server itself is working fine if I use LAN and not go through WAN.
I checked with wireshark. I can see DHCP discover on the side of client but I can see anything on the side of DHCP Server.
It looks that broadcast (in our case unicast) don´t go through WAN or maybe through swithc on the side of client. (192.168.12.254). As I wrote above, everything other working fine (client working through WAN on our citrix Server)
Sosin
Occasional Contributor

Re: DHCP doesn´t work through VLAN

I would like to say thank you all of you.
Because we have still the old Version H.08.53, I need realy additional to "ip helper" add "dhcp-relay" command. After that it worked fine.
Solution from "las" was correct.
If read the documentation of H.08.53 and confirm that dhcp-relay is necassary. It looks that I dont´t need "dhcp-relay" up Version H.08.98.
But independ of this I will update also in our other location to the Version H.10.83.
Have everybody a nice day and thank you
Sosin
Occasional Contributor

Re: DHCP doesn´t work through VLAN

See solution above