Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

DHCP on a multisubnetted Vlan 5406zl FW K.11.63

Ed Davis_2
Occasional Advisor

DHCP on a multisubnetted Vlan 5406zl FW K.11.63

We recently installed a 5406zl fw k.11.63(in place of a HP9308) with single vlans on over 50 ports. All is fine except we have one area due to cabling issues where we have to have 2 subnets on 1 vlan. One subnet is a 10.10.51.1/24 which needs dhcp address's and the other subnet is 10.0.75.1/24 which all device's are static IP's.We have dhcp helper on this vlan. The problem is the 10.0.75.1 is always relaying dhcp request's (which is not defined on our dhcp server) instead of the 10.10.51.1. Didn't there use to be a way of saying this is the primary subnet and the other is a secondary? When we take out the 10.0.75.1 network, we get the 10.10.51.x dhcp's fine. It appears that the switch is picking this network as the primary just because it is a lower address. When I built the vlan, I put the 10.10.51.1 network first, then added the 10.0.75 network second thing that would make a difference, but it doesn't. I was just hoping there was a way to do this without tagging vlans thru this one area as things are pretty spead out and will be a bit of a hassle. The 9308 handled this same situation fine as we could describe seperate VE interfaces for each network, one with dhcp helper and the other not. Any sugestions or what am I doing wrong?
If I was doing any better, I'd be puking blood!