Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

DHCP on new layer-3 switch not working

SOLVED
Go to solution
Switches_1
Occasional Advisor

DHCP on new layer-3 switch not working

We changed out our 2810 for a 2610 layer-3, to make use of the routing capabilities.

My network as a DHCP server with 2 scopes;
scope 1 192.168.20.100-200 (default vlan)
192.168.20.1 (gateway of firewall)
192.168.20.2 DNS

scope 2 192.168.21.100-200 (VLAN-21)
192.168.21.254 gateway to 2610 switch)
192.168.20.2 DNS

Is the gateway correct for vlan-21.?
The default vlan works fine.

On the switch 2610, port 9 is connected to the DHCP server
port 12 is connected to a laptop.

When I run DHCP FIND and the sw. port is set to vlan-21, i get nothing. If I set the port to default vlan, then I get a good ip.

This is the switch config;

Running configuration:
; J9085A Configuration Editor; Created on release #R.11.25
hostname "ProCurve Switch 2610-24"
snmp-server contact ""
snmp-server location "Server Room"
ip default-gateway 192.168.20.1
ip routing
snmp-server community "public" Unrestricted
snmp-server host 192.168.20.29 "public"
snmp-server host 192.168.20.9 "public"
vlan 1
name "DEFAULT_VLAN"
untagged 1-11,13-28
ip address 192.168.20.40 255.255.255.0
no untagged 12
exit
vlan 21
name "Engineering"
untagged 12
ip address 192.168.21.254 255.255.255.0
ip helper-address 192.168.21.3
tagged 1,9
exit

fault-finder bad-driver sensitivity high
fault-finder bad-transceiver sensitivity high
fault-finder bad-cable sensitivity high
fault-finder too-long-cable sensitivity high
fault-finder over-bandwidth sensitivity high
fault-finder broadcast-storm sensitivity high
fault-finder loss-of-link sensitivity high
fault-finder duplex-mismatch-HDx sensitivity high
fault-finder duplex-mismatch-FDx sensitivity high
password manager

ProCurve Switch 2610-24# sh dhcp-relay
DHCP Relay Agent : Enabled
Option 82 : Disabled
Response validation : Disabled
Option 82 handle policy : append
Remote ID : mac


Client Requests Server Responses

Valid Dropped Valid Dropped
---------- ---------- ---------- ----------
0 0 0 0

5 REPLIES
Patrick Terlisten
Honored Contributor

Re: DHCP on new layer-3 switch not working

Hello,

the ip-helper address in VLAN 21 must be set to the DHCP server. You current set ip-helper address is set to a host in the VLAN 21. That makes no sense. Your DHCP is connected to port 9 which belongs to VLAN 1. So you DHCP should have an ip-address in the scope 192.168.20.0/24. So you ip-helper should set to the DHCP server ip in the VLAN 1.

Best regards,
Patrick
Best regards,
Patrick
Switches_1
Occasional Advisor

Re: DHCP on new layer-3 switch not working

Patrik,

Thanks, I believe I found the problem, but not sure how to implement the resolve.

The goal is to use the layer-3 support of the switch, so the switch will handle all routing requests.

At this time, I have a Juniper SSG-320 as my firewall/router which all the DHCP scopes point to as the gateway. Also the switch has a default gateway of the same SSG-320. that is 192.168.20.1

If I am to make the switch the router, and have ip routing enabled, I am confused what ip to point the DHCP scopes to. Here is my idea;

switch-1
default vlan 192.168.20.40
default gateway ????????
vlan-21 192.168.21.254
default gateway 192.168.21.3 <- DHCP server scope

On the DHCP server
scope-1
default IP 192.168.20.3
default gateway 192.168.20.40 <-- switch-1

scope-2
default IP 192.168.21.3
default gateway 192.168.21.254 <- switch vlan-21

The reason the setup was not working was my SSG-320 Juniper router/firewall would need me to create sub interfaces for the vlans.
Since I want only traffic for the internet to go out the SSG-320, and the switch to do all the routing, does this seem correct.?
Patrick Terlisten
Honored Contributor

Re: DHCP on new layer-3 switch not working

Hi,

you can only have on default gateway on the router. The default gateway served by DHCP muss be the switch vlan interface for the served ip subnet. Because you DHCP is residing in 192.168.20.0/24 you need to setup an ip-helper address pointing to 192.168.20.1 in the VLAN 21.

You have

VLAN 1
ip interface 192.168.20.40

VLAN 21
ip interface 192.168.21.254

On you DHCP you must configure for the scope

192.168.20.0/24
default gateway 192.168.20.40

192.168.21.0/24
default gateway 192.168.21.254

On the switch set a routing entry (via ip route) to 192.168.20.1

0.0.0.0 0.0.0.0 192.168.20.1

Best regards,
Patrick
Best regards,
Patrick
Switches_1
Occasional Advisor

Re: DHCP on new layer-3 switch not working

Patrick,

Alle ist klar.

Thanks, will test this week.
Patrick Terlisten
Honored Contributor
Solution

Re: DHCP on new layer-3 switch not working

Hello,

don't forget to assign points to helpful answeres.

HPpy testing. :)

Best regards,
Patrick
Best regards,
Patrick