Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

DHCP over vlans

Ryan1979
Advisor

DHCP over vlans

The basic problem is I can not get DHCP to assign addresses over vlans on HP switches (but i can on cisco).

Overview

We have a cisco 3750 gig switch at the core setup in a stack. This is doing our routing and has
all the necessary vlans on it. In this case I am trying to get vlan 18 to work. vlan 18 is setup on the
3750 and has a default gaterway of 10.12.18.254/24. The DHCP server is on vlan 1 and address is 10.12.0.252/21.
(This used to be a flat network hence the large segment). For the .18 scope the Router address (under advanced)
is set to 10.12.18.254/24.

We have 9 other vlans with ciscs2950 on the edge and they work fine, i just get the HP to. If i use a cisco on subnet 18
it works fine aswell.

The configs are as attached for the cisco3750 and the HP2650.

Questions:
1. How do i get it to work?
2. Do i need a ip helper on the HP edge 3650 (I thought i only needed this on the router)?
3. I would assume i do not need dhcp-relay enabled on the HP edge 2650?
4. Any other hints please.

CONFIG FOR 2650

; J4899B Configuration Editor; Created on release #H.10.29

hostname "FC 2650"
time timezone 600
sntp server 10.12.0.182
timesync sntp
sntp unicast
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-4,49-50
ip address 10.12.0.142 255.255.248.0
no untagged 5-48
exit
vlan 18
name "FC"
untagged 5-48
ip helper-address 10.12.0.252
tagged 49-50
exit
no dhcp-relay
password manager


CONFIG GIGABIT CISCO 3750

gigatx#show run
Building configuration...

Current configuration : 3912 bytes
!
! Last configuration change at 16:20:52 UTC Thu May 20 1993 by admin
! NVRAM config last updated at 11:11:39 UTC Sat Jul 31 1993 by admin
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log datetime
no service password-encryption
service sequence-numbers
!
hostname gigatx
!
enable secret 5 $1$J6Xh$x1OTnYrFz/ALPEvO07fqx.
enable password techit
!
username mccit privilege 15 secret 5 $1$yxps$UNA7qac2K2aAx0i6BUAI91
no aaa new-model
clock timezone UTC 10
switch 1 provision ws-c3750g-24t
switch 2 provision ws-c3750g-12s
ip subnet-zero
ip routing
ip domain-name mcc.mccmky.qld.edu.au
ip name-server 10.12.7.180
ip name-server 10.12.7.178
!
cluster enable mccmky 0
cluster member 1 mac-address 000f.2373.b740
cluster member 2 mac-address 000c.8500.d0c0
cluster member 3 mac-address 000c.cedc.4640
cluster member 4 mac-address 000d.288c.b940
cluster member 5 mac-address 000d.2894.5940
cluster member 6 mac-address 000f.2373.b700
cluster member 7 mac-address 0012.8023.2000
cluster member 8 mac-address 0012.8023.1700
cluster member 9 mac-address 0013.c4cc.0a80
cluster member 10 mac-address 0015.f97c.29c0
cluster member 11 mac-address 0015.c6b0.3e40
cluster member 12 mac-address 0015.c6bb.7880
cluster member 13 mac-address 0013.60cb.e100
!
!
!
no file verify auto
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
interface GigabitEthernet1/0/1
--More-- !
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
speed 1000
duplex full
spanning-tree portfast trunk
!
interface GigabitEthernet1/0/21
description PIX Inside Interface
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
description PIX DMZ Interface
switchport access vlan 2
!
interface GigabitEthernet1/0/24
description LONG
switchport access vlan 2
!
--More-- interface GigabitEthernet2/0/1
!
interface GigabitEthernet2/0/2
!
interface GigabitEthernet2/0/3
!
interface GigabitEthernet2/0/4
!
interface GigabitEthernet2/0/5
!
interface GigabitEthernet2/0/6
!
interface GigabitEthernet2/0/7
!
interface GigabitEthernet2/0/8
!
interface GigabitEthernet2/0/9
!
interface GigabitEthernet2/0/10
!
interface GigabitEthernet2/0/11
!
interface GigabitEthernet2/0/12
!
interface Vlan1
ip address 10.12.7.253 255.255.248.0 secondary
ip address 10.12.7.229 255.255.248.0
!
interface Vlan10
ip address 10.12.10.254 255.255.255.0
ip helper-address 10.12.7.252
!
interface Vlan11
ip address 10.12.11.254 255.255.255.0
ip helper-address 10.12.7.252
!
interface Vlan12
ip address 10.12.12.254 255.255.255.0
ip helper-address 10.12.7.252
!
interface Vlan13
ip address 10.12.13.254 255.255.255.0
ip helper-address 10.12.7.252
!
interface Vlan14
ip address 10.12.14.254 255.255.255.0
ip helper-address 10.12.7.252
!
interface Vlan15
ip address 10.12.15.254 255.255.255.0
ip helper-address 10.12.7.252
!
interface Vlan16
ip address 10.12.16.254 255.255.255.0
ip helper-address 10.12.7.252
--More-- !
interface Vlan17
ip address 10.12.17.254 255.255.255.0
ip helper-address 10.12.7.252
!
ip default-gateway 10.12.7.254
ip classless
ip route 0.0.0.0 0.0.0.0 10.12.7.254
ip http server
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
line vty 0 4
exec-timeout 0 0
password techit
login
line vty 5 15
password techit
login
!
!
end
5 REPLIES
Mohieddin Kharnoub
Honored Contributor

Re: DHCP over vlans

Hi

Based on the config you posted, i think you missed Vlan18 on the Cisco 3750, or you forgot to create it.

Second thing, you need to configure a default gateway for your 2600 switch to your Router's IP address (Vlan1 IP).

After that, connect a PC on Vlan18 on the 2600 switch and try to ping the core switch (vlan1-vlan18) and the DHCP server .... etc.

I assume that IP Routing is done on the 3650 switch, so IP helper-address in needed for sure since your DHCP server on a different Vlan.

Please check your DHCP scope for Vlan18 and for testing, just configure a PC with all the parameters you did in this scope Statically and try to test this PC's communication on the network.

Good Luck !!!
Science for Everyone
Ryan1979
Advisor

Re: DHCP over vlans

Thanks for the response

The posting was wrong, there is a vlan for 18 already and a default gateway.

When i create a static IP i cant connect to anything still however I am assured by a very senior HP tech it is a cisco problem, not a HP one. So back to the drawing board.

Thanks anyway.

Mohieddin Kharnoub
Honored Contributor

Re: DHCP over vlans

Hi Ryan

I would like to ask you if you can draw a small drawing shows how are your switches connected, with port numbers.

Thanks
Science for Everyone
Jonathan Axford
Trusted Contributor

Re: DHCP over vlans

Hi, Is it something to do with the VLAN tagging setup?

I also don't think you will need the IP-Helper command on the HP device as it is not performing any inter-valn routing, so broadcasts(DHCP) will not be dropped.

To what interface on the cisco does the hp device attach?

A drawing would be handy.... :-)
Where there is a will there is a way...
Ryan1979
Advisor

Re: DHCP over vlans

Is was a cisco trunking issue where is was no running on 802.1q.

Thanks for all those who commented.