Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

DHCP relay on 2900 not forwarding broadcasts.

Gareth Walters
Occasional Contributor

DHCP relay on 2900 not forwarding broadcasts.

G'day all,

I have a 3 VLAN setup and the dhcp relay agent set in the helper address for the only VLAN DHCP clients are on.


DHCP Relay Agent : Enabled
Option 82 : Disabled
Response validation : Disabled
Option 82 handle policy : append
Remote ID : mac


Client Requests Server Responses

Valid Dropped Valid Dropped
---------- ---------- ---------- ----------
8611 0 1504 0

I have changes almost every setting but I cannot seem to ge tit to work.
Is ther esomething else that should be in place here for it to work?

Is there any debugging I can do to determine what is going wrong?

4 REPLIES
cenk sasmaztin
Honored Contributor

Re: DHCP relay on 2900 not forwarding broadcasts.

hi Gareth
please send me your switch show run print
cenk

Gareth Walters
Occasional Contributor

Re: DHCP relay on 2900 not forwarding broadcasts.

Here is the whole config

module 1 type J86yyA
module 2 type J86xxA
module 3 type J90XXA
interface 13
name "downlinkwks1"
flow-control
exit
interface 14
name "downlinkwks1"
flow-control
exit
interface 15
name "downlinkwks2"
flow-control
lacp Passive
exit
interface 16
name "downlinkwks2"
flow-control
lacp Passive
exit
interface 17
name "downlinkwks3"
flow-control
lacp Passive
exit
interface 18
name "downlinkwks3"
flow-control
lacp Passive
exit
interface 19
name "downlinkwks4"
flow-control
lacp Passive
exit
interface 20
name "downlinkwks4"
flow-control
lacp Passive
exit
interface A2
name "serverswitch1"
flow-control
exit
interface A3
name "serverswitch2"
flow-control
exit
trunk A2-A3 Trk1 Trunk
trunk 13-14 Trk10 Trunk
ip default-gateway 10.25.62.1
ip routing
snmp-server community "2kaus"
snmp-server host 10.25.50.48 "public"
vlan 1
name "mgmt_vlan"
untagged 25-48
ip address 10.25.62.254 255.255.255.0
flow-control
lacp Passive
exit
interface A2
name "serverswitch1"
flow-control
exit
interface A3
name "serverswitch2"
flow-control
exit
trunk A2-A3 Trk1 Trunk
trunk 13-14 Trk10 Trunk
ip default-gateway 10.25.62.1
ip routing
snmp-server community "2kaus"
snmp-server host 10.25.50.48 "public"
vlan 1
name "mgmt_vlan"
untagged 25-48
ip address 10.25.62.254 255.255.255.0
no untagged 1-12,15-24,A1,A4,Trk1,Trk10
exit
vlan 2
name "server_vlan"
untagged 1-12,Trk1
ip address 10.25.48.254 255.255.255.0
exit
vlan 3
name "wks_vlan"
untagged 15-24,A1,A4,Trk10
ip helper-address 10.25.48.100
ip address 10.25.51.254 255.255.254.0
exit
no stack
sntp server priority 1 10.25.48.100
no ip ssh
ip route 0.0.0.0 0.0.0.0 10.25.62.1
ip route 10.1.0.0 255.255.240.0 10.25.62.63
ip route 10.1.16.0 255.255.240.0 10.25.62.63
ip route 10.4.48.0 255.255.240.0 10.25.62.63
ip route 10.5.48.0 255.255.240.0 10.25.62.63
ip route 10.6.48.0 255.255.240.0 10.25.62.63
ip route 10.10.0.0 255.255.0.0 10.25.62.63
ip route 10.13.0.0 255.255.240.0 10.25.62.63
ip route 10.24.48.0 255.255.240.0 10.25.62.63
ip route 10.25.63.0 255.255.255.0 10.25.62.63
ip route 10.28.0.0 255.255.240.0 10.25.62.63
ip route 10.30.48.0 255.255.240.0 10.25.62.63
ip route 10.31.48.0 255.255.240.0 10.25.62.63
ip route 10.100.0.0 255.255.0.0 10.25.62.63
ip route 10.253.0.0 255.255.255.0 10.25.62.63
router rip
exit
spanning-tree Trk1 priority 4
spanning-tree Trk10 priority 4
vlan 1
ip rip 10.25.62.254
exit
vlan 2
ip rip 10.25.48.254
exit
vlan 3
ip rip 10.25.51.254
exit
primary-vlan 2
cenk sasmaztin
Honored Contributor

Re: DHCP relay on 2900 not forwarding broadcasts.

you dhcp server reside must ve vlan 2 1-12 ports and this server default gateway vlan 2 ip address [10.25.48.254]

and create for vlan 3 dhcp scobe ,scobe name vlan3, vlan 3 scobe address range in vlan3 network address and default gateway vlan 3 ip address [10.25.51.254]

and option 82 enable

option 82 must be disable only same reside broadcast domain user and dhcp server but you user and dhcp server different broadcast domain.therefore you make enable option 82

cenk

cenk sasmaztin
Honored Contributor

Re: DHCP relay on 2900 not forwarding broadcasts.

all dhcp server not make broadcast

client send to network dhcp-discover packed with broadcast

dhcp server send to client dhcp-offer packet with unicast

cenk
cenk