Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

DHCP request on Procurve 5412zl through VLAN

TCCmurph
Occasional Advisor

DHCP request on Procurve 5412zl through VLAN

We have a HP Procurve 5412zl as our core switch.

core ip: 192.168.10.79
gateway 192.168.10.1 (firewall)
IP routing enabled
DHCP relay enabled

we have 2x DHCP servers on the default vlan which has the VLAN scopes setup.
DHCP 192.168.10.3, 192.168.10.4

VLAN2 - 192.168.20.0/23
gateway 192.168.20.1

VLAN3 - 192.168.30.0/23
gateway 192.168.30.1

on the core we have setup a port (F1) and set the port as untagged on VLAN2, no on default vlan.

the core has vlan2 setup with ip helper as 192.168.10.3 and 192.168.10.4

now, on that port F1, we have a switch attached with IP 192.168.10.28, Gateway of 192.168.10.79

i have a PC trying to get a DHCP address, which isnt working, it errors out.

if i setup the PC to have a manual IP address
192.168.20.50
gateway 192.168.20.1

then i can ping the gateway and the core switch IP.

cannot ping anything else... which i am thinking is what i should find.

so, our routing is done in the core, DHCP is a 2003 server.

firewall is 192.168.10.1
DHCP's 192.168.10.3, 192.168.10.4
CORE 192.168.10.79
VLAN2 192.168.20.0/23
VLAN3 192.168.30.0/23
5 REPLIES
TCCmurph
Occasional Advisor

Re: DHCP request on Procurve 5412zl through VLAN

; J8698A Configuration Editor; Created on release #K.13.63

hostname "ProCurve Switch 5412zl"
snmp-server contact ""
module 1 type J8702A
module 2 type J8705A
module 3 type J8702A
module 4 type J8705A
module 5 type J8702A
module 6 type J8705A
module 7 type J8702A
module 8 type J8705A
module 9 type J8702A
module 10 type J8705A
exit 1 type J8702A
module 12 type J8702A
interface F20
speed-duplex auto-1000
exit
interface A12
no power-over-ethernet
exit
interface A19
speed-duplex auto-1000
exit
interface B7
speed-duplex auto-1000
exit
interface I18
no power-over-ethernet
exit
ip default-gateway 192.168.10.1
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged A13-A24,B1-B24,C1-C24,D1-D24,E1-E24,F2-F24,G1-G24,H1-H24,I1-I24,J1-J
24,K1-K24,L1-L24
ip address 192.168.10.79 255.255.254.0
tagged F1
vlan 2
name "Vlan2_infra_scope_a"
untagged F1
ip helper-address 192.168.10.3
ip helper-address 192.168.10.4
ip address 192.168.20.1 255.255.254.0
exit
fault-finder bad-driver sensitivity high
fault-finder bad-transceiver sensitivity high
fault-finder bad-cable sensitivity high
fault-finder too-long-cable sensitivity high
fault-finder over-bandwidth sensitivity high
fault-finder broadcast-storm sensitivity high
fault-finder loss-of-link sensitivity high
fault-finder duplex-mismatch-HDx sensitivity high
fault-finder duplex-mismatch-FDx sensitivity high
no dhcp-relay hop-count-increment
ip route 0.0.0.0 0.0.0.0 192.168.10.1
EckerA
Respected Contributor

Re: DHCP request on Procurve 5412zl through VLAN

hi,
what's the default gateway of your dhcp server? it should be 192.168.10.79.
hth
Alex
TCCmurph
Occasional Advisor

Re: DHCP request on Procurve 5412zl through VLAN

Hi ALex,

we set the gateway on the DHCP to 79, and things didnt work.

i could ping the DHCP if i gave the PC a static IP, but no address assigned under DHCP.

i am thinking that we still need the ip helper addresses on the VLAN set to the DHCP's.
Jeff Carrell
Honored Contributor

Re: DHCP request on Procurve 5412zl through VLAN

hmmm...a couple of other questions:

1) how is the port on the downstream switch configured (untag vLAN 1, untag vlan2, tag vlan2, etc?) maybe procide its 'sh run'?

2) has the DHCP server been "activated", meaning if you bring up the DHCP manager, is the scope "active" for network 20?

3) if you gave your PC a static IP for network 20, it shold be able to ping anything in network 20 and network 10 - as long as network 10 devices defgw is 192.168.10.79

4) what ver of code is running on the 5412?

5) what happens is you connect the PC directly to port F1, does it get a DHCP addr?

Configuring basic DHCP services is generally not this hard...its fairly basic and from a high-level view, it looks like you have everything configured correctly.

hth...Jeff
TCCmurph
Occasional Advisor

Re: DHCP request on Procurve 5412zl through VLAN

we have things working now,
we tested the system last night, and got things working.

what our issue was is that the DHCP had gateways still of 10.1, we pointed them to 10.79 and we could ping and get DHCP address in the right scope etc.

we had to enable the ip helper-address o nthe vlan2

we also set F1 to be untagged on default vlan and tagged on vlan2

we will be provisioning in the next day or so, after Documentation and planning has been written up.