Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Default Gateway Not accessible

Bashir Abdul Rahman
Occasional Advisor

Default Gateway Not accessible

Dear All,
Your help in my scenario is hihgly appriciated..
my scenario:
Company wannted to have three vlans 1. client 2. server 3. voip and offcourse one for mgmt (default_vlan) we don't want to use cisco router for InterVlan connection, since switch is L3 we wannted to use all routing in switch itself, Cisco lan interface must be used as default gateway to connect outside branch network...out internet access is via ISA With multihome... so our gateway is data router..

IP Phones and pc will be using one port from edge switch.. and we wannted to set qos priority .


kindly if someone can help me with following..
1. three vlan must see each other
2. all the vlan data must go through default-gateway
3. what configuration is required in client switch
Switch Model: 5406zl
Edge switch : HP

here is my configuration, were i am not sucess
Please advise...
"premium license is allready loaded"
"ip 192.168.161.200 is cisco router lan interface"

Running configuration:

; J8697A Configuration Editor; Created on release #K.12.62

hostname "core1"
snmp-server contact "2222222"
snmp-server location "xxxxxx"
module 1 type J8702A
module 2 type J8702A
module 3 type J8706A
ip default-gateway 192.168.161.200
snmp-server community "public" Unrestricted
ip routing
vlan 1
name "DEFAULT_VLAN"
untagged A1-A4,C1-C2
ip address 192.168.161.1 255.255.255.0
no untagged A5-A24,B1-B24,C3-C24
ip igmp
exit
vlan 112
name "client"
untagged A5-A24,C3-C9
ip address 192.168.112.1 255.255.252.0
tagged A1-A4,C1-C2
exit
vlan 108
name "server"
untagged B1-B24,C10-C24
ip address 192.168.108.1 255.255.252.0
tagged A1-A4,C1-C2
exit
vlan 116
name "voip"
ip address 192.168.116.1 255.255.252.0
tagged A1-A4,C1-C2
voice
qos priority 6
exit
ip route 0.0.0.0 0.0.0.0 192.168.161.200
core1(config)#

10 REPLIES
Bashir Abdul Rahman
Occasional Advisor

Re: Default Gateway Not accessible

sorry guys there is some thing is missing..in voice vlan
here is the all config again


Running configuration:

; J8697A Configuration Editor; Created on release #K.12.62

hostname "core1"
snmp-server contact "2222222"
snmp-server location "xxxxxx"
module 1 type J8702A
module 2 type J8702A
module 3 type J8706A
ip default-gateway 192.168.161.200
snmp-server community "public" Unrestricted
ip routing
vlan 1
name "DEFAULT_VLAN"
untagged A1-A4,C1-C2
ip address 192.168.161.1 255.255.255.0
no untagged A5-A24,B1-B24,C3-C24
ip igmp
exit
vlan 112
name "client"
untagged A5-A24,C3-C9
ip address 192.168.112.1 255.255.252.0
tagged A1-A4,C1-C2
exit
vlan 108
name "server"
untagged B1-B24,C10-C24
ip address 192.168.108.1 255.255.252.0
tagged A1-A4,C1-C2
exit
vlan 116
name "voip"
ip address 192.168.116.1 255.255.252.0
tagged C1-C2
tagged A1-A24,C3-C9
voice
qos priority 6
exit
ip route 0.0.0.0 0.0.0.0 192.168.161.200
core1(config)#
EckerA
Respected Contributor

Re: Default Gateway Not accessible

hi,
on which port is the router connected? can you ping the router from the switch?
for the clients, servers and ip-phones the setting for their default gateway need to be the switch ip in their vlan.
for example for servers the default gateway need to be 192.168.108.1
hth
alex
Bashir Abdul Rahman
Occasional Advisor

Re: Default Gateway Not accessible

Thanks

- In VLAN 1 A1-A4 ethernet , A1 is connected to router
- Module C is fiber, C3-C9 uplink for switches and C10-C24 for server

i want to use :
- following as example of client ip setup
192.168.108.1 as server gateway
192.168.112.1 as client gateway
192.168.116.1 as voip gateway

- mask for all 3 vlan is 22bit 255.255.252.0
mask used with default vlan is 24bit 255.255.255.0

- my clients are in static ip addres, later i will have DHCP from windows server for clients

- phone and pcs are connected in one port

- all the uplink to edge switch is to fiber port in edge switch.

- my present setup is using cico router for intervlan with subinterface and 802.1q encapsulation...
and at present i have only 30 IP simens phones so they are connected with client vlan... so now we face problems with voice and to avoid router as single point of failer even for local users...
- beside this i have one more 5406zl switch ... will be implemnting as redudancy using VRRP...




Pieter 't Hart
Honored Contributor

Re: Default Gateway Not accessible

you use:
>>>
vlan 1
ip address 192.168.161.1 255.255.255.0
vlan 112
ip address 192.168.112.1 255.255.252.0
<<<
and :
>>>
vlan 1
ip igmp
<<<
igmp stems from the "classfull" routing time and from that time 192.168.112.0 is a /24 (class-C) subnet.
and now you are supernetting with /22 ??

this may be the cause of your problem.
try adding "ip classless" to your switch config.
Bashir Abdul Rahman
Occasional Advisor

Re: Default Gateway Not accessible

hi,
could you please advise me how i can put voice and data vlan in edge switch using one port for both and how uplink should be configured..

Pieter 't Hart
Honored Contributor

Re: Default Gateway Not accessible

>>>
- how i can put voice and data vlan in edge switch using one port for both
- how uplink should be configured
(C3-C9 uplink for switches on 5406)
<<<

all ports need to be "tagged" for all vlans passed to the edge-switches.
also on the edge switches they need to be tagged for all vlans.

so on the 5406 :
vlan 112
name "client"
untagged A5-A24
ip address 192.168.112.1 255.255.252.0
tagged A1-A4,C1-C2,C3-C9
exit
vlan 116
name "voip"
ip address 192.168.116.1 255.255.252.0
tagged A1-A4,C1-C2,C3-C9
voice
qos priority 6
exit

on the edge switches it would be like (port 24 asumed uplink port you didn't mention the model):
vlan 112
name "client"
untagged 1-23
tagged 24
exit
vlan 116
name "voip"
tagged 1-23,24
voice
qos priority 6
exit
Bashir Abdul Rahman
Occasional Advisor

Re: Default Gateway Not accessible

thank you ...again
But unfortunetly it did not work with me...
my only problem

no node in any vlans are able to ping router...i can ping from switch and any node from any vlan are able to ping.. except router..

and i don't know i did not find "ip classless" in hp core switch (5406zl) where as i see same comand in my router...

here i would like post... router config

hostname abc
!
boot-start-marker
boot-end-marker
!
logging buffered 5000 debugging
enable secret 5 $1xxxxx
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
no aaa new-model
ip subnet-zero
ip cef
!
!
no ftp-server write-enable
!
!
interface FastEthernet0/0
description "WAN Link"
ip address 172.x.x.2 255.255.255.252
speed auto
full-duplex
!
interface FastEthernet0/1
description $ETH-LAN$
ip address 192.168.161.100 255.255.252.0
duplex auto
speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.x.x.1
ip route 192.168.0.0 255.255.0.0 172.x.x.1
ip route 192.168.96.0 255.255.224.0 FastEthernet0/1
ip http server
!
!
control-plane
!
line con 0
line aux 0
line vty 0 4
password 7 xxxxxxxx
login
!
end

and HP switch config i have is...

ip default-gateway 192.168.161.100
ip routing
snmp-server community "public" Unrestricted

vlan 1
name "DEFAULT_VLAN"
untagged A1-A4,C1-C2
ip address 192.168.161.1 255.255.255.0
no untagged A5-A24,B1-B24,C3-C24
ip igmp
exit
vlan 112
name "client"
untagged A5-A24,C3-C9
ip address 192.168.112.1 255.255.252.0
tagged A1-A4,C1-C2
exit
vlan 108
name "server"
untagged B1-B24,C10-C24
ip address 192.168.108.1 255.255.252.0
tagged A1-A4,C1-C2
exit
vlan 116
name "voice"
qos priority 6
ip address 192.168.116.1 255.255.252.0
tagged A1-A4,C1-C9
voice
exit
ip route 0.0.0.0 0.0.0.0 192.168.161.100

" router is connected to A1"

your help is higly appriciated....


cenk sasmaztin
Honored Contributor

Re: Default Gateway Not accessible

hi Bashir

please change static route entry your router

ip classless
ip route 0.0.0.0 0.0.0.0 172.x.x.1
ip route 192.168.0.0 255.255.0.0 192.168.161.1 !!!!!!!!!!!!!!!!
ip route 192.168.96.0 255.255.224.0 FastEthernet0/1
ip http server

your switch config is true only wrong commad static route on router

switch all ip all subnet packet go to router
but your router 192.168.0.0 network packet go to wrong site

and all client default gateway address must have vlan ip address
for example
vlan 112 member pc ip config.
ip address 192.168.112. 10
subnet mask 255.255.252.0
default gateway address 192.168.112.1

please change static route on your router and say me result
cenk

cenk sasmaztin
Honored Contributor

Re: Default Gateway Not accessible

ip classless
ip route 0.0.0.0 0.0.0.0 172.x.x.1
ip route 192.168.0.0 255.255.0.0 172.x.x.1
ip route 192.168.96.0 255.255.224.0 FastEthernet0/1
ip http server
!


very wrong ip route entry

please test erase all routing entry on router you write only one entry

ip route 192.168.0.0 255.255.0.0 192.168.161.100

now you have to see all pc and server ping to internet router but not connect other site all vlan unable ping other site router

everything is okey don't panic :)

now you can write other routing command
for other site connection

for example other site network address 10.0.10.0

you must be write ip route entry on router

ip route 10.0.0.0 255.0.0.0 172.x.x.1

in this way have 10.0.0.0 destination 10.0.0.0 network packet go to wan interface
have 192.168.0.0 network packet go to lan interface (to switch )
cenk

Pieter 't Hart
Honored Contributor

Re: Default Gateway Not accessible

Hi Bashir,
=== ip route 192.168.0.0 255.255.0.0 172.x.x.1 ===
I think you have 192.168.0.0 subnets not only at your local LAN, but also remote (at the other end of the router)?
and you try to "summarize" routes to 192.168.108.0,192.168.112.0 and 192.168.116.0
into a single statement :
=== ip route 192.168.96.0 255.255.224.0 FastEthernet0/1 ===
allthough it is sent out on the vlan where the switch could pick it up, packets are not directed to the switches address and so the switch will not route this to the correct vlan!.
This statement would have worked in a "multinet" environment [multiple subnets on same (v)lan].

I suggest changeing :
=== ip route 192.168.96.0 255.255.224.0 FastEthernet0/1 ===
to :
=== ip route 192.168.96.0 255.255.224.0 192.168.161.1

then the switch must process the packets and forward to the right vlan/subnet.