Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Disable TFTP on ProCurve Switches

John_796
Occasional Advisor

Disable TFTP on ProCurve Switches

I'm trying to disable TFTP on some of my switches. I have a 2650, 2626, 2524 that are giving me problems I believe it's becasue the firmware is older and therefore when I run the command "no tftp client/server" I get invalid input: tftp

what is the command to disable TFTP on older firmware? I'm obviously going to update my firmware but it has to be scheduled since the network would be down and I need to get this disabled asap.

Thanks for the help
4 REPLIES
Shadow13
Respected Contributor

Re: Disable TFTP on ProCurve Switches

type #tftp ?

it will give you the opitons available, then issue the NO after that :D to disbale it

Re: Disable TFTP on ProCurve Switches

Hi John,
The command is:
# no tftp server
# no tftp client

for sure. May be you are not in config status?
#config

Good luck,
Pablo.-
John_796
Occasional Advisor

Re: Disable TFTP on ProCurve Switches

I tried both of your suggestions.

If I type in tftp? I still get "invalid input: #tftp"

If I type in No TFTP client or server I get "invalid input: tftp". I am in the config section - after I logged in I type 'config' and it now shows me as My switch name #

I did the same thing on my switches with newer firmware and it works just fine. These few switches I have are the older firmware and apparently these commands aren't in there. So I'm trying to find another way to disable it until I can upgrade the firmware.

Richard Brodie_1
Honored Contributor

Re: Disable TFTP on ProCurve Switches

The 2524 in particular is tight on flash memory/RAM. When features are missing, it's quite likely they are going to stay that way.