Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

External routeur linux VLAN with hp 4204vl

liquideshark
Advisor

External routeur linux VLAN with hp 4204vl

Happy Friday :)

I have followed this tutoriel http://www.go2linux.org/vlan-with-debian to configure an external router for my switch; i configure 2 vlans interface on it. And on my 4204vl i tagged my vlan to B1.
and connect my router to it.
Iam i missing something on the configuration on my switch to make this happen ?

Thank you !
6 REPLIES
cenk sasmaztin
Honored Contributor

Re: External routeur linux VLAN with hp 4204vl

please send me sh run print procurve switch
cenk

liquideshark
Advisor

Re: External routeur linux VLAN with hp 4204vl

Hi cenk and thank you for your reply
this is my L3 sh run configuration:
========================================
Running configuration:

; J8770A Configuration Editor; Created on release #L.10.23

hostname "ProCurve Switch 4204vl"
max-vlans 25
module 1 type J8768A
module 2 type J9033A
interface A23
lacp Passive
exit
interface B2
lacp Passive
exit
ip default-gateway 172.16.1.253
snmp-server community "public" Unrestricted
vlan 1
name "services"
untagged A2-A20,A23,B9-B17,B19-B24
ip address 172.16.1.1 255.255.255.0
no untagged A1,A21-A22,A24,B1-B8,B18
exit
vlan 3
name "internet"
untagged B1-B8
ip address 172.16.3.1 255.255.255.0
ip helper-address 172.16.1.254
tagged B9
exit
vlan 99
name "test"
untagged A21-A22,A24
ip address 172.16.99.1 255.255.255.0
ip helper-address 172.16.1.254
tagged B9
exit
ip route 0.0.0.0 0.0.0.0 172.16.3.254
dhcp-snooping
dhcp-snooping authorized-server 172.16.1.254
dhcp-snooping vlan 1-121
interface B16
dhcp-snooping trust
exit
password manager
password operator
=========================================

Like i said my linux router is plugged to the switch at B9 and nothing is hapenning

see my linux router interfaces configuration on attached files.

Thanks again
cenk sasmaztin
Honored Contributor

Re: External routeur linux VLAN with hp 4204vl

fristly what for use external router on 4200

1-for routing between vlan
or
2-routing between vlan and --local network and other site (internet or WAN )connection
******************************************************************************************************
1-if use routing betwen vlan;4200 switch able with ip routing command

but you want make with external router this configuration(routing between vlan )

see my example config

switch config

vlan 1
name "services"
untagged A2-A20,A23,B9-B17,B19-B24
ip address 172.16.1.1 255.255.255.0
no untagged A1,A21-A22,A24,B1-B8,B18
exit
vlan 3
name "internet"
untagged B1-B8
tagged B9
exit
vlan 99
name "test"
untagged A21-A22,A24
tagged B9
exit

no need ip address vlan interface have only vlan 1 ip address for switch managemet
and connect external router on switch port B9

external router have one eth interface you must be create 3 sub interface for vlan 1
for vlan 3 and for vlan 99 and assign ip address each sub interface.Each sub interface must be
know vlan id (very importand )


for exampel any router config

interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/0.1
encapsulation dot1Q 1 native******(1vlan id)
ip address 172.16.1.1 255.255.255.0
!
interface FastEthernet0/0.2
encapsulation dot1Q 3 ************(3vlan id)
ip address 172.16.3.1 255.255.255.0
!
interface FastEthernet0/0.3
encapsulation dot1Q 99**********(99 vlan id)
ip address 172.16.99.1 255.255.255.0

and connect this router B9 port on switch
each vlan member client default gateway address must be sub interface address
for example

vlan 99 member pc ip address config
ip address 172.16.99.10
subnet mask 255.255.255.0
default gateway address 172.16.99.1
***********************************************************************************************************
2--routing between vlan and --local network and other site (internet or WAN )connection

4200 switch already able routing between vlan with ip route command
if you want connect all vlan other site connection must be use external router
this router have two interface for wan and for lan
lan interface server local network wan interface server internet or other side connection device
therefor both interface must be different physical interface

please see my example config

switch config ***********

ip routing
snmp-server community "public" Unrestricted
vlan 1
name "services"
untagged A2-A20,A23,B9-B17,B19-B24
ip address 172.16.1.1 255.255.255.0
no untagged A1,A21-A22,A24,B1-B8,B18
exit
vlan 3
name "internet"
untagged B1-B8
ip address 172.16.3.1 255.255.255.0
ip helper-address 172.16.1.254
exit
vlan 99
name "test"
untagged A21-A22,A24
ip address 172.16.99.1 255.255.255.0
ip helper-address 172.16.1.254
exit
ip route 0.0.0.0 0.0.0.0 172.16.3.254


ip routing enable and one static route to external router 0.0.0.0 0.0.0.0 172.16.3.254
3.254 external router lan ip address and external router connect vlan 3 untag port for example B1


external router config**************

interface FastEthernet0/0 (router lan interface ) connect vlan 3 untag port
ip address 172.16.3.254 255.255.255.0

interface FastEthernet0/1(router wan interface ) connect other site connection device
ip address xxx.xxx.xxx.xxx 255.255.255.248

and attach static router command on external router for local vlan's internet or other site connection

ip route 172.16.0.0 255.255.0.0 172.16.3.1

all vlan member pc default gateway address must be vlan ip address

may it be easy
cenk

liquideshark
Advisor

Re: External routeur linux VLAN with hp 4204vl

Hi Cent,

first of all iam using a zebra routing on debian.
My (linux zebra)router have 2 interfaces vlan 3 and vlan 99(http://forums11.itrc.hp.com/service/forums/getattachment.do?attachmentId=327641&ext=.JPG).
and I want to be able to do this:
http://bitmindframes.info/wp-content/uploads/2008/06/vlanroast.png

do the port B9 on my switch need complement configuration for my router to communicate with the 2 vlan on thee swithc ?
Pieter 't Hart
Honored Contributor

Re: External routeur linux VLAN with hp 4204vl

hi there,
from your attachment eth0 and eth0.3 have an ip-adress in the same subnet (172.16.3.10/24 and 172.16.3.20/24)
so the router probablyd oes not answer on the right interface (vlan)
liquideshark
Advisor

Re: External routeur linux VLAN with hp 4204vl

Hello and thank again for all your help; i did check out my routing table on the linux router everything seems normal to me check the attached file