Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Forward UDP 67 and 68

Yan Henrichon
Frequent Advisor

Forward UDP 67 and 68

Hi. One of our customer use Acronis to image his pc. To boot from PXE, UDP ports 67 to 69 needs to be opened or fowarded.

When I'm in the same vlan as the pxe server, the pc boots correctly.

When I put the pc in another vlan, I can't get the IP address and the boot image.

In the config of the vlan, I added the line to permit port 69:
ip forward-protocol udp 172.16.10.50 tftp

But when I want to forward ports 67 and 68, the switch shows: Invalid port.

Also, I "sniffed" to be sure that PXE needs those ports and effectively, it does.

How can I permit those ports to be forwarded?

Thank You.
8 REPLIES
Yan Henrichon
Frequent Advisor

Re: Forward UDP 67 and 68

I forgot to mention that I use either 2650 and 3500 swithes both to the last firmware release.

Thank you.
Yan Henrichon
Frequent Advisor

Re: Forward UDP 67 and 68

After more troubleshooting, I found that I do not receive the DHCP IP address when booting from PXE.

But when I boot into windows, I receive the right address.
Matt Hobbs
Honored Contributor

Re: Forward UDP 67 and 68

Try adding an ip helper-address statement which points to the Acronis server. I have a customer that this worked for on Altiris.
Pieter 't Hart
Honored Contributor

Re: Forward UDP 67 and 68

ports 67 and 68 probably have to be configured with a dhcp-relay/dhcp-helper command, not just forward.

did you create a new vlan for this ?
test if routing is working between those vlans using static adresses.
if not config first.

if routing allready works then Matts' suggestion will help.

Yan Henrichon
Frequent Advisor

Re: Forward UDP 67 and 68

See config of the switch in attached file.

Matt: the ip helper is already configured.
Peter: the route is working. When booted into windows, I can ping all addresses I want. But I don't understand how to onfigure ports 67 and 68 with a dhcp-relay/dhcp-helper.

When I posted this thread, I had only one server acting as DHCP and PXE (Acronis) server. For the purpose of my test, I scinded the services: DHCP has 172.16.10.50 and PXE have 172.16.10.60. Again, when the PXE client is in the same vlan as the servers, no problem. As soon as I move it to the other vlan, nothing.

Any advice will be greatly appreciated.
Pieter 't Hart
Honored Contributor

Re: Forward UDP 67 and 68

the ip-helper on vlan1 is not neccessary (same vlan/subnet as dhcp-server)

you need to set the default gateway of the dhcp-server to that of vlan1 (172.16.10.254)
or some other router that knows the path to 10.45.0.0.

you must configure in your dhcp-options the address of vlan2 as default gateway for scope 10.45.0.0
Yan Henrichon
Frequent Advisor

Re: Forward UDP 67 and 68

Peter, Thank you for your reply.

All the gateways are correct. Gateway infos are correct in DHCP.

I added the ip-helper in VLAN 1 just in case. I know that it doesn't make sense, but...

I've just chat with a ProCurve Guru and he already had a similar issue. Here is his answer:

"They stated it was the PXE software that was the problem, they were able to get this to work with an older version and was told by the software vendor that it was a known issue that they were working on."

I'll let you know.
Yan Henrichon
Frequent Advisor

Re: Forward UDP 67 and 68

Acronis was using multicast and the Premium License had to be installed to enable Multicast Routing.