Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

GRE tunnel between 2 pro curve routers

SOLVED
Go to solution
Luisi
Occasional Advisor

GRE tunnel between 2 pro curve routers

Hi guys,

I've been trying to create a GRE tunnel between 2 procurve routers and get multicast across the tunnel.

Has anyone accomplished that before?

I'm attaching both router configs in the same file.

Many thanks.
Regards.
6 REPLIES
Olaf Borowski
Respected Contributor

Re: GRE tunnel between 2 pro curve routers

So what is your problem? GRE tunnel not coming up?
I think you have a simple routing problem. How does the first router know how to connect to the loopback interface of the other? Can you ping 2.2.2.2? I don't think so. Obviously, you have something inbetween the 7203 and 7102 (not same subnet). You have 10.0.0.1 and 10.10.10.10. I am pretty sure that the device(s) in the middle don't know about your loopback interfaces. Either teach them where to find the loopbacks (via static routing) or point the tunnel destination to the 10.0.0.1 and 10.10.10.10 interface. On the 7203, ping 10.10.10.10 to verify that the tunnel-endpoint is reachable. On 7102 verify that 10.0.0.1 is reachable before you change the tunnel destination.

Give that a try...

Olaf

Luisi
Occasional Advisor

Re: GRE tunnel between 2 pro curve routers

Thanks Olaf for your answer.

OK, I'm gonna start for the very beginning and then try to refine.

I've got 2 procurve routers (7102dl and 7203dl) connected to each other (isolated, not part of any network).

7102 eth 0/1 - 11.11.11.11/24
ip route 0.0.0.0 0.0.0.0 11.11.11.11

7203 eth 0/1 - 11.11.12.12/24
ip route 0.0.0.0 0.0.0.0 11.11.12.12

I can ping from both sides.

I want to create a GRE tunnel between both of them:

- On 7102,

interface tunnel 1
description Tunnel 1
ip address 192.168.10.2 255.255.255.252
ip pim sparse-mode
tunnel mode gre
tunnel source 11.11.12.12
tunnel destination 11.11.11.11
mtu 1436
bandwidth 100000
no shutdown


- On 7203,

interface tunnel 1
description Tunnel 1
ip address 192.168.10.2 255.255.255.252
ip pim sparse-mode
tunnel mode gre
tunnel source 11.11.11.11
tunnel destination 11.11.12.12
mtu 1436
bandwidth 100000
no shutdown


The tunnel is shown as UP on both sides but I don't see any packets going through it.
How can I troubleshoot that?

The ideal situation is multicasting from eth 0/2 on 7203 router receiving that multicast on eth 0/2 on 7102 router.

Any help would be appreciate it.

Many thanks!





Pieter 't Hart
Honored Contributor
Solution

Re: GRE tunnel between 2 pro curve routers

>>>
7102 eth 0/1 - 11.11.11.11/24
ip route 0.0.0.0 0.0.0.0 11.11.11.11

7203 eth 0/1 - 11.11.12.12/24
ip route 0.0.0.0 0.0.0.0 11.11.12.12
<<<
this isn't right...
at least not at normal routing level
11.11.11.11/24 is in a different subnet than 11.11.12.12/24 so they shouldn't communicate.
you normally use something like 11.11.11.11/24 and 11.11.11.12/24 for communication between the two routers!
>>>
i can ping from both sides
<<<
yes that's because you force any traffic to be sent out a specific interface (not to send it to another router) by setting up the default gateway for this device to itself!
>>>7102 eth 0/1 - 11.11.11.11/24
ip route 0.0.0.0 0.0.0.0 11.11.11.11
<<<
it should be pointing to 11.11.11.12or something (the other device)

ping is a broadcast sent out the interface and therefore received by the other router.
but tcp is not, so at tcp-level you should have no connection.

hth
Pieter
Olaf Borowski
Respected Contributor

Re: GRE tunnel between 2 pro curve routers

Luisi,

You are using the same IP address on both sides of the tunnel. That's wrong! See the attached drawing. This should work.

Good luck,

Olaf
Luisi
Occasional Advisor

Re: GRE tunnel between 2 pro curve routers

Thanks Olaf, that diagram gave some light.

I've finally the GRE tunnel up and running and I can send packets through it.

Now what I want to accomplish is to send video stream through the GRE tunnel and play it from the other side of the tunnel.

I'd probably open a new thread for that with a diagram and the configs as I don't want to mix up things.

I really appreciate your help guys.

Regards.
Luisi
Occasional Advisor

Re: GRE tunnel between 2 pro curve routers

Closing thread