Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

General Network Error

gbo89
Occasional Visitor

General Network Error

I have connected a DL 380 G5 to a Cisco 2950 and I have the following error "[DBNETLIB][connectionRead]. General Network error.check you network documentation"

This is what I got on the switch on the two ports that the server is connected too:

interface FastEthernet0/1
switchport trunk allowed vlan 1
switchport mode access
spanning-tree portfast
interface FastEthernet0/2
switchport trunk allowed vlan 1
switchport mode access
spanning-tree portfast

I have this error in all the PC that connect to this server

Thanks
2 REPLIES
Pieter 't Hart
Honored Contributor

Re: General Network Error

>>>
switchport trunk allowed vlan 1
switchport mode access
<<<
these statements are basically contradictory but the first statement will be "overruled" by the second (so remove it).

the port is either trunk or access port
- switchport mode access
- switchport access vlan
- spanning-tree portfast
or trunk
- switchport mode trunk
- switchport native vlan
- switchport trunk allowed vlan1
(portfast is never active when a port is in trunking mode)

but...:
as you mention the error as ""[DBNETLIB][connectionRead]" i think this is an application error, not a normal network connectivity error.
can you access the server by other means?
for instance
- can you "ping" the server?
- can you access file shares on the server
- can you RDP or telnet to the server?
- can you otherwise manage the server remotely?
- con you do above from this server to hosts oustside the server?

for further troubleshooting supply more info about OS and application.
gbo89
Occasional Visitor

Re: General Network Error

Thanks Pieter, I have two server both with windows 2003 Enterprise SP2 and all the patch that are available out there

I have installed Macola Progression in one and in the other SQL 2000

- can you "ping" the server? yes
- can you access file shares on the server yes
- can you RDP or telnet to the server?yes
- can you otherwise manage the server remotely? yes
- con you do above from this server to hosts oustside the server? yes

I check Microsoft SQL and Macola knowledge base and both say that this is a network error, it could be a NIC, Switch or cable

I really need you help, let me know if you need more info

thanks, and sorry my english