Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

HP 2810 and Cisco Router 6509

Pedro_73
Occasional Contributor

HP 2810 and Cisco Router 6509

Hello,

I have a few 2810 configure to trunk with a Cisco 6509 router. The router has two VLANs configure. One vlan for managing the switches and another vlan for the workstations ips.

VLAN 100 manage the switches
VLAN 401 manage the workstations ips

On the HP, it only allows me to untagged one vlan. I need to be able to allow the workstations to talk back to the router using vlan 401.

How can I configure the HP 2810 to allow this two goals?

Thanks
4 REPLIES
cenk sasmaztin
Honored Contributor

Re: HP 2810 and Cisco Router 6509

hi Pedro

this example config for you

cisco router**********************
interface FastEthernet0/0.1
encapsulation dot1Q 1 native
ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address 192.168.2.1 255.255.255.0
!
interface FastEthernet0/0.3
encapsulation dot1Q 3
ip address 192.168.3.1 255.255.255.0
!
interface FastEthernet0/0.4
encapsulation dot1Q 4
ip address 192.168.4.1 255.255.255.0

we make 4 sperate sub interface on router lan interface this interface connect procurve switch


procurve switch config*************

vlan 1
name "DEFAULT_VLAN"
untagged 1-9,21-24
ip address 192.168.1.2 255.255.255.0
no untagged 10-20
exit
vlan 2
name "VLAN2"
untagged 10-12
tagged 24
no ip address
exit
vlan 3
name "VLAN3"
untagged 13-15
tagged 24
no ip address
exit
vlan 4
name "VLAN4"
untagged 16-20
tagged 24
no ip address
exit

vlan 1 ip address only switch managemet
vlan's untag port must have connect vlan member pc interface 24 must have connect router ethernet port

also very important your pc ip configuration
for example
vlan 2 member pc
ip address 192.168.2.10
subnet mask 255.255.255.0
default gateway address 192.168.2.1 !!!!!

so your main routing device must have cisco router procurve switch running only L2 operation with vlan all vlan reach internet or other vlan have to go router with 802.1q
cenk

Pedro_73
Occasional Contributor

Re: HP 2810 and Cisco Router 6509

Thanks for your help. This is a head start.

the hp 2810 has a fiber as an uplink. Therefore, I have been using VLAN 100 for managing network switches.

VLAN 100 172.X.X.X 255.X.X.X
VLAN 401 146.X.X.X 255.X.X.X

However, when I do this, HP wants to have various ports untagged.

I need to have the 48 ports use for another VLAN 401.

How Can I setup the switches for both type of VLANs.

Thanks
Pieter 't Hart
Honored Contributor

Re: HP 2810 and Cisco Router 6509

>>>
I have been using VLAN 100 for managing network switches.
VLAN 100 172.X.X.X 255.X.X.X
<<<

you plan to use a lot (255x255x255) of switches to manage in a single subnet.

the other subnet 146.x.x.x seems to me a public range you better not use on your private network
Pedro_73
Occasional Contributor

Re: HP 2810 and Cisco Router 6509

But,

Do you think is possible to have the two vlans working on the same switch, one for managing the switch and the second one for the clients.

I guess, I'm so used to work with cisco switches. In cisco, you can have a vlan for your workstations or hosts, and another vlan for managing the switche itself.

thanks