Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

HP 2848 routing with VLANs

SOLVED
Go to solution
Craig Reed-san
Occasional Visitor

HP 2848 routing with VLANs

Hi there,

I'm having the following issue:

I have two seprate subnets, 192.168.0.0/24 and 192.168.10.0/24 that I want to route through my 2848 to get to the internet, and also be able to communicate with one antother. This switch is connected directly to our firewall, and I have used VLAN and IP routing to configure it. Everything can ping everything else, but I cannot get to the internet from any of the nodes.

I have 3 VLANs configured. 192.168.0.1/24 untagged, 192.168.10.1/24 untagged, and 192.168.50.1/24 untagged. The third VLAN is only connected to the firewall. I can ping up to the inside interface of the firewall, but not the outside. The default gateway on the switch is configured to be the inside interface on the firewall. When I connect to my "flat" network, without VLANs, all 192.168.0.0/24 nodes can access the internet.

It is also fair to note that when I attempt to switch over to the VLAN config, I change the firewall's internal IP from 192.168.0.1/24 to 192.168.50.2/24 so that the switch (IP 192.168.0.1/24) becomes the default gateway for all nodes. There is no IP conflict, as I don't have the switch connected unless I've changed the firewall IP.

Any help would be most appreciated! Thanks!
3 REPLIES
cenk sasmaztin
Honored Contributor
Solution

Re: HP 2848 routing with VLANs

hi

please test

my switch config and internet router/firewall config

-------config switch-----------------
hostname "sw"
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-9,14-26
ip address 192.168.0.1 255.255.255.0
no untagged 10-13
exit
vlan 2
name "VLAN2"
untagged 10-12
ip address 192.168.10.1 255.255.255.0
exit
vlan 3
name "VLAN3"
untagged 13
ip address 192.168.50.1 255.255.255.0
exit
ip route 0.0.0.0 0.0.0.0 192.168.50.2

192.168.50.2 internet firewall ip address
and connect firewall device int 13 (vlan 3 untag port)


--------------firewall ip route config------
firewall local interface address must be
192.168.50.2

and you must be assing ip route entry on firewall
192.168.0.0 255.255.0.0 192.168.50.1

-----------pc config--------------------
vlan 1 member pc default gateway address must be
192.168.0.1
vlan 2 member pc default gateway address must be
192.168.10.1

good luck



cenk

Craig Reed-san
Occasional Visitor

Re: HP 2848 routing with VLANs

Hi Cenk,

Thank you very much, I actually got it just before you posted, and the key was the static IP route. I read in another thread that for layer 2 you have to do default gateway, but with IP routing you must have a static default route. But your config is also spot on, so I gave you full points. Thanks!
cenk sasmaztin
Honored Contributor

Re: HP 2848 routing with VLANs

you are welcome ;)
cenk