Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

HP 4104 VLAN question

SOLVED
Go to solution
DPower
Occasional Advisor

HP 4104 VLAN question

Running an HP 4104GL with HP G.07.104

I'm trying to configure a VLAN on this switch and not having much luck. I've successfully created the VLAN and added 1 (C20) port. The switch IP is 10.1.1.250/24. The VLAN IP is 10.1.3.254/24. I cannot ping the VLAN IP, but I can ping the switch. If I plug a device into C20 I can ping the VLAN, but not the switch. I've enable IP routing as well. If I issue "show ip route" I do not see the 10.1.3.x network listed. It will not take a static route either. Any ideas how I can get the switch to recognize that it is supporting 2 networks?

4 REPLIES
Matt Hobbs
Honored Contributor

Re: HP 4104 VLAN question

Make sure that port C20 is up (has a link), otherwise the VLAN will still be considered as down.
DPower
Occasional Advisor

Re: HP 4104 VLAN question

Progress! I did attach a small 5 port switch to C20 and VLAN 300 did show up when I issued a "Show IP Route". However I am unable to ping through the switch. If I plug my laptop on the 10.1.3.x network I can ping only 10.1.3.x devices. I cannot ping the switch 10.1.1.248. I do have IP Routing enabled. If I telnet to the switch I can ping both networks. I'd think if IP ROUTING is enabled it would route! It's all very frustrating.

Here's a copy of my config...

HP ProCurve Switch 4104GL# sh conf

Startup configuration:

; J4887A Configuration Editor; Created on release #G.07.104

hostname "HP ProCurve Switch 4104GL"
snmp-server contact "DPower"
snmp-server location "3rd Floor Closet"
no cdp run
module 4 type J4864A
module 1 type J4908A
module 2 type J4908A
module 3 type J4908A
interface D3
disable
exit
interface A1
no lacp
exit
interface A2
no lacp
exit
interface A3

exit
interface C20
no lacp
exit
interface C21
no lacp
exit
interface C22
no lacp
exit
ip default-gateway 10.1.1.254
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged A1-A22,B1-B22,C1-C19,C21-C22,D1-D3
ip address 10.1.1.248 255.255.255.0
ip helper-address 10.1.1.231
no untagged C20
exit
vlan 300
name "VLAN300"
untagged C20
ip address 10.1.3.254 255.255.255.0
ip helper-address 10.1.1.231
exit
ip route 0.0.0.0 0.0.0.0 10.1.1.254
management-vlan 1
spanning-tree

HP ProCurve Switch 4104GL#
Matt Hobbs
Honored Contributor
Solution

Re: HP 4104 VLAN question

Ahhh... I see the problem. You have the management-vlan feature enabled. This prevents routing on that VLAN.

Solution:
4104(config)# no management-vlan 1
DPower
Occasional Advisor

Re: HP 4104 VLAN question

You're the mack daddy! That did the trick!