Email Subscription Notifications Suspended Temporarily
We are in the process of making navigation in the Servers and Operating Systems forums simpler and more direct. While doing this, we have to temporarily suspend email notifications for subscriptions. If you are subscribed to one or more discussion boards or blogs in the community, please check them daily to see new content. Notifications will be turned back on in a few days. We apologize for any inconvenience this may cause. Thanks, Warren_Admin
Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

HP 4204 Into a Cisco Router supporting voice

nero_64
Occasional Contributor

HP 4204 Into a Cisco Router supporting voice

Hi,

I have setup a cisco router with a HP switch. I want to plug a cisco ip phone off the HP switch and get an ip address of the voice vlan. Then plug a PC off the phone and get an ip off the data vlan.

My problem is I get an ip address on the phone and it downloads the config from the TFTP server but I can't get the data vlan ip on the PC attached to the phone. The IP address I get is from the voice vlan.

***********************
HP Switch
***********************
hostname "ProCurve Switch 4204vl"
module 1 type J8768A
module 2 type J9033A
interface A1
speed-duplex 100-full
exit
ip default-gateway 10.3.10.1
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged B21-B24
no ip address
tagged A1
no untagged A2-A24,B1-B20
exit
vlan 3
name "DATA-VLAN"
untagged B17-B20
ip address 10.3.10.2 255.255.255.0
tagged A1
exit
vlan 4
name "VOICE-VLAN"
untagged A2-A24,B1-B16
no ip address
tagged A1
exit
********************************
Cisco Router
********************************
!
ip dhcp pool CLIENT
network 10.3.10.0 255.255.255.0
default-router 10.3.10.1
dns-server 10.10.0.7
lease 3
!
ip dhcp pool VOICE
network 10.3.11.0 255.255.255.0
default-router 10.3.11.1
dns-server 10.10.0.6
option 150 ip 10.10.0.5
lease 3
!
!
interface FastEthernet1
description Trunk to HP 4204 Switch
switchport mode trunk
duplex full
speed 100
no snmp trap link-status
!
!
interface Vlan4
description VOICE VLAN
ip address 10.3.11.1 255.255.255.0
!
interface Vlan3
description DATA VLAN
ip address 10.3.10.1 255.255.255.0
ip access-group 150 in
service-policy input EtherIn
!
****************************************

The cisco router is plugged into A1 on the HP switch.

Some advice would be great.

Thanks,
2 REPLIES
cenk sasmaztin
Honored Contributor

Re: HP 4204 Into a Cisco Router supporting voice

hi
please test my config

HP Switch
***********************
hostname "ProCurve Switch 4204vl"
module 1 type J8768A
module 2 type J9033A
interface A1
speed-duplex 100-full
exit
ip default-gateway 10.3.10.1
snmp-server community "public" Unrestricted

vlan 1
name "data vlan "
untagged A1-A24,B21-B24
no untaggad B24
no ip address
exit

vlan 2
name "VOICE-VLAN"
tagged A1-A24,B1-B16
no ip address

vlan 3
name "managemet"
untagged B24 (this port only network management with 10.0.10.2/24 ip pc)
ip address 10.0.10.1/24
exit
********************************
Cisco Router
********************************

Router#sh run
Building configuration...

Current configuration : 902 bytes
!
version 12.2
no service password-encryption
!
hostname Router
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
description vlan1
encapsulation dot1Q 1 native
ip address 10.3.10.1 255.255.255.0
!
interface FastEthernet0/0.2
description vlan2
encapsulation dot1Q 2
ip address 10.3.11.1 255.255.255.0
!

!
ip dhcp pool vlan1
network 10.3.10.0 255.255.255.0
default-router 10.3.10.1
dns-server 10.10.0.7
ip dhcp pool vlan2
network 10.3.11.0 255.255.255.0
default-router 10.3.11.1
dns-server 10.10.0.7
****************************************

please config your ip phone vlan id manuel
vlan id 2



cenk
cenk

cenk sasmaztin
Honored Contributor

Re: HP 4204 Into a Cisco Router supporting voice

in this way you can connect each port ip phone or pc or ip phone under pc

pc nic default vlan 1 member there fore connect any untag port any pc on switch get ip address on int 0/0.1 10.3.10.0 scobe

ip phone change vlan member you can must be assign manuel vlan id 2 on ip phone in this way attach you make tagged in ip phone frame vlan id info and any ip phone connect any tagged port get ip address on int 0.0.2 10.3.11.0 scobe

ip phone under pc connection

ip phone nic must be tag 2 info but pc not include tag info there fore must be same port tag vlan 2 and untag vlan 1 (ip phone pc and lan port working same hub)

plese look my config all port vlan 1 untag and all port vlan 2 tag

cenk


cenk