Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

HP 5406 Switch ip routing problem

depraa
Occasional Visitor

HP 5406 Switch ip routing problem

Dear all,

 

I have many 4 Vlans created on the core SW (5406) 2 of them on the edge SW and 2 on other for example:

on core vlan 1,vlan2,vlan3,vlan4

edge sw1 vlan1,vlan2

edge sw2 vlan3,vlan4

 

and connected the switches by tagged ports ... I want to enable vlan routing on the core to allow the vlans to see each other ..

I were try the command ip routing  and i have no result 

 

how can i do this and what is the commands.

Thanks

3 REPLIES
EckerA
Respected Contributor

Re: HP 5406 Switch ip routing problem

Hi

 

here a example config:

 

sw1:

 

vlan1

untag a2..<---ports which are part of vlan 1

ip address 192.168.0.1/24

exit

vlan2

untag a10...<----ports which are part of vlan 2

ip address 192.168.1.1/24

exit

vlan3

tag a1 <-- uplink to sw2

ip address 192.168.2.1/24

exit

vlan 4

tag a1 <--uplink to sw2

ip address 192.168.3.1/24

exit

 

ip routing

ip route 0.0.0.0 0.0.0.0 172.10.10.1

 

sw2:

 

vlan 3

tag a1

exit

vlan 4

tag a1

exit

 

 

that should be it..

the sw1 needs to know of the subnets you want him to route. so create those subnets as well an sw1, they don't need to have any untagged ports on sw1 just tag the uplink to sw2 to them. The default gateway of the clients should be the ip of sw1.

 

 

hth..

alex

depraa
Occasional Visitor

Re: HP 5406 Switch ip routing problem

this is the show run (on core switch ):

 


Running configuration:

; J8697A Configuration Editor; Created on release #K.15.06.0017
; Ver #02:10.0d:1f

hostname "J10C5"
time timezone 3
module 1 type J9637A
module 2 type J9550A
interface A13
speed-duplex auto-1000
exit
interface A14
speed-duplex auto-1000
exit
interface A15
speed-duplex auto-1000
exit
interface A16
speed-duplex auto-1000
exit
interface A17
speed-duplex auto-1000
exit
interface A18
speed-duplex auto-1000
exit
interface A19
speed-duplex auto-1000
exit
interface A20
speed-duplex auto-1000
exit
interface A21
speed-duplex auto-1000
exit
trunk A13 Trk1 Trunk
trunk A14 Trk2 Trunk
trunk A15 Trk3 Trunk
trunk A16 Trk4 Trunk
trunk A17 Trk5 Trunk
trunk A18 Trk6 Trunk
trunk A19 Trk7 Trunk
trunk A20 Trk8 Trunk
trunk A21 Trk9 Trunk
ip routing
vlan 1
name "Management"
untagged A1-A12,A22-A24,B1-B22,B24,Trk1-Trk9
ip address 10.11.1.250 255.255.255.0
no untagged B23
exit
vlan 12
name "DataSec"
ip address 10.11.12.250 255.255.255.0
ip proxy-arp
exit
vlan 102
name "Voice"
untagged B23
ip address 10.11.102.250 255.255.255.0
tagged B24
exit
vlan 11
name "WirelessHot"
ip address 10.11.11.250 255.255.255.0
exit
vlan 51
name "DataHot"
ip address 10.11.51.250 255.255.255.0
exit
vlan 15
name "DataHQ"
ip address 10.11.15.250 255.255.255.0
exit
vlan 55
name "WirelessHQ"
ip address 10.11.55.250 255.255.255.0
exit
vlan 200
name "VIP"
ip address 10.11.200.250 255.255.255.0
exit
vlan 13
name "DataPak"
ip address 10.11.13.250 255.255.255.0
exit
vlan 14
name "DataFac"
ip address 10.11.14.250 255.255.255.0
exit
vlan 5
name "Server"
ip address 10.11.5.250 255.255.255.0
exit
interface A1
flow-control
exit
interface A13
flow-control
exit
interface A14
flow-control
exit
interface A15
flow-control
exit
interface A16
flow-control
exit
interface A17
flow-control
exit
interface A18
flow-control
exit
interface A19
flow-control
exit
interface A20
flow-control
exit
interface A21
flow-control
exit
interface A22
flow-control
exit
interface A23
flow-control
exit
interface A24
flow-control
exit
snmp-server community "public" unrestricted
snmp-server location "HQ"
spanning-tree
spanning-tree Trk1 priority 4
spanning-tree Trk2 priority 4
spanning-tree Trk3 priority 4
spanning-tree Trk4 priority 4
spanning-tree Trk5 priority 4
spanning-tree Trk6 priority 4
spanning-tree Trk7 priority 4
spanning-tree Trk8 priority 4
spanning-tree Trk9 priority 4
spanning-tree instance 1 vlan 1-4000
spanning-tree instance 1 priority 0
spanning-tree instance 1 Trk1 priority 4
spanning-tree instance 1 Trk2 priority 4
spanning-tree instance 1 Trk3 priority 4
spanning-tree instance 1 Trk4 priority 4
spanning-tree instance 1 Trk5 priority 4
spanning-tree instance 1 Trk6 priority 4
spanning-tree instance 1 Trk7 priority 4
spanning-tree instance 1 Trk8 priority 4
spanning-tree instance 1 Trk9 priority 4
spanning-tree priority 0
no autorun
no dhcp config-file-update
no dhcp image-file-update

depraa
Occasional Visitor

Re: HP 5406 Switch ip routing problem

i have 11 vlans on the core
and i have 5 edge switches ,any one of them have at minimum 4 vlans (Data,voice,server,management)
but from switch to switch the vlans name is different for example :sw1 have vlans (dataSec,voice,Server,management)
sw2 have vlans (datafac,voice,server,management)
note that the data vlan is different by name and by ID

finally i want to rout on the core between all of them

thanks alot