Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

HP-PROCURVE and CISCO QOS

Teguh Febrianto Setiawa
Occasional Visitor

HP-PROCURVE and CISCO QOS

Hi All,

I tried to connect HP Procurve 2626 with Cisco devices (Cat 2950).

As Cat 2950 I did configure to use CoS (priority 6) at the port using command :

#mls QOS cos 6

At the uplink port I configured with dot1q trunk to connect this to 2626 switch.

At the downlink port of 2626 switch (connected to Cat 2950) I configured dot1q and port priority 6 with bellow command :

#qos priority 6.

This device also map configuration from CoS to DSCP :

Bellow is complete config of 2626 switch :



hostname "KUNINGAN-ACCESS01-LT1-2626"
snmp-server contact "YOWAN"
snmp-server location "MATRAMAN"
max-vlans 30
mirror-port 2
qos dscp-map 100010 priority 6
interface 1
no lacp
exit
interface 2
no lacp
exit
interface 3
no lacp
exit
interface 4
no lacp
exit
interface 5
no lacp
exit
interface 6
no lacp
exit
interface 7
no lacp
exit
interface 8
no lacp
exit
interface 9
no lacp
exit
interface 10
no lacp
exit
interface 11
no lacp
exit
interface 12
no lacp
exit
interface 13
no lacp
exit
interface 14
no lacp
exit
interface 15
no lacp
exit
interface 16
no lacp
exit
interface 17
no lacp
exit
interface 18
no lacp
exit
interface 19
no lacp
exit
interface 20
no lacp
exit
interface 21
no lacp
exit
interface 22
no lacp
exit
interface 23
disable
no lacp
exit
interface 24
disable
no lacp
exit
ip default-gateway 10.146.63.1
snmp-server community "danamon" Unrestricted
snmp-server host 170.21.3.181 "danamon" Critical
snmp-server enable traps authentication
vlan 1
name "DEFAULT_VLAN"
untagged 24
ip address 170.21.3.182 255.255.255.0
ip helper-address 10.145.44.250
tagged 1,25-26
no untagged 2-23
exit
vlan 2
name "VLAN2"
no ip address
tagged 1,25-26
exit
vlan 3
name "VLAN3"
no ip address
tagged 1,25-26
exit
vlan 4
name "VLAN4"
untagged 2-23
no ip address
qos priority 6
tagged 1,25-26
exit
vlan 5
name "VLAN5"
no ip address
tagged 1,25-26
exit
vlan 6
name "VLAN6"
no ip address
tagged 1,25-26
exit
vlan 7
name "VLAN7"
no ip address
tagged 1,25-26
exit
vlan 8
name "VLAN8"
no ip address
tagged 1,25-26
exit
vlan 9
name "VLAN9"
no ip address
tagged 1,25-26
exit
vlan 15
name "VLAN15"
no ip address
tagged 1,25-26
exit
vlan 51
name "VLAN51"
no ip address
tagged 1,25-26
exit
vlan 52
name "VLAN52"
no ip address
tagged 1,25-26
exit
vlan 53
name "VLAN53"
no ip address
tagged 1,25-26
exit
vlan 54
name "VLAN54"
no ip address
tagged 1,25-26
exit
vlan 401
name "VLAN401"
no ip address
tagged 1,25-26
exit
vlan 402
name "VLAN402"
no ip address
tagged 1,25-26
exit
vlan 405
name "VLAN405"
no ip address
tagged 1,25-26
exit
vlan 407
name "VLAN407"
no ip address
tagged 1,25-26
exit
vlan 408
name "VLAN408"
no ip address
tagged 1,25-26
exit
vlan 100
name "VLAN100"
no ip address
tagged 1,25-26
exit
interface 25-26
monitor
exit
qos type-of-service diff-services
aaa authentication console login tacacs local
aaa authentication console enable tacacs local
aaa authentication telnet login tacacs local
aaa authentication telnet enable tacacs local
tacacs-server key cisco
tacacs-server host 10.192.8.222
port-security 2 learn-mode limited-continuous action send-disable
port-security 3 learn-mode limited-continuous action send-disable
port-security 4 learn-mode limited-continuous action send-disable
port-security 5 learn-mode limited-continuous action send-disable
port-security 6 learn-mode limited-continuous action send-disable
port-security 7 learn-mode limited-continuous action send-disable
port-security 8 learn-mode limited-continuous action send-disable
port-security 9 learn-mode limited-continuous action send-disable
port-security 10 learn-mode limited-continuous action send-disable
port-security 11 learn-mode limited-continuous action send-disable
port-security 12 learn-mode limited-continuous action send-disable
port-security 13 learn-mode limited-continuous action send-disable
port-security 14 learn-mode limited-continuous action send-disable
port-security 15 learn-mode limited-continuous action send-disable
port-security 16 learn-mode limited-continuous action send-disable
port-security 17 learn-mode limited-continuous action send-disable
port-security 18 learn-mode limited-continuous action send-disable
port-security 19 learn-mode limited-continuous action send-disable
port-security 20 learn-mode limited-continuous action send-disable
port-security 21 learn-mode limited-continuous action send-disable
port-security 22 learn-mode limited-continuous action send-disable
port-security 23 learn-mode limited-continuous action send-disable
port-security 24 learn-mode limited-continuous action send-disable
management-vlan 1
banner motd "UNAUTHORIZED ACCESS TO THIS NETWORK DEVICE IS PROHIBITED."
spanning-tree
password manager


I want to ask, will this configuration work ?
What is the best practice of QOS between cisco and Procurve?



Thank and rgds,

Iwan
2 REPLIES
Jonathan Axford
Trusted Contributor

Re: HP-PROCURVE and CISCO QOS

Am i right in thinking that both switches will just use the COS value over the trunk, so as long as the right QoS priorities are configured in the right VLANs, the dot1q trunk should carry the valure over no problems.

I have not set up QoS between a Cisco and an HP device before but i can't see any reason why it would not work...

Have you actually tried the setup?

Where there is a will there is a way...
Sergej Gurenko
Trusted Contributor

Re: HP-PROCURVE and CISCO QOS

Hi,

You can try port mirroring (SPAN) for QoS troubleshooting. You can use any freeware packet sniffer like Packetyzer or Ethereal. Do not forget to tune you PC to capture VLAN tags also (http://wiki.ethereal.com/CaptureSetup/VLAN). Make sure you mirroring configuration do not remove VLAN tags.

You will see CoS bits in VLAN header.