Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

HP ProCurve 2910Al-24G: problem with Vlans

SOLVED
Go to solution
Ximera
Occasional Contributor

HP ProCurve 2910Al-24G: problem with Vlans

Hello
I need to migrate from my old Cisco 3550 to HP ProCurve 2910Al. On Cisco I have many Vlans and there's one port which forward traffic of all Vlans to the next hop - my firewall.
On Cisco it looks very simple:

interface FastEthernet0/24
no switchport
ip address 192.168.22.18 255.255.255.240
<...>
!
ip routing
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.22.17

On 2910Al I cannot set IP address on the interface, only on Vlan.
So I switched on ip routing, set default route and IP on default Vlan:

interface 24
name "To_firewall"
exit
vlan 1
name "DEFAULT_VLAN"
untagged 1,3,12,14,24
ip address 192.168.22.18 255.255.255.240
no untagged 2,4-11,13,15-23
exit
vlan 3
name "ServerNet_192.168.23.0"
untagged 9,11,15-23
ip address 192.168.23.1 255.255.255.0
exit
<...>
ip routing
ip route 0.0.0.0 0.0.0.0 192.168.22.17


But it doesn't work. I can ping 192.168.22.18 from any host connected to 2910Al but ping 192.168.22.17 is always failed.

When I ping 192.168.22.17 I see the count of received packets is growing.
E.g. from host 192.168.23.2 I can ping 192.168.23.1 (Vlan IP), 192.168.22.18 (default Vlan IP) and I cannot ping 192.168.22.17. I've tried to include tagged 24 port into Vlan 3 but it doesn't help. How should I configure my Vlans?
Thanks in advance for ur answers.
5 REPLIES
chomezski
Advisor

Re: HP ProCurve 2910Al-24G: problem with Vlans

try remove your static default route and replace it with:

ip default-gateway 192.168.22.17
Ximera
Occasional Contributor

Re: HP ProCurve 2910Al-24G: problem with Vlans

Tnx for ur reply, but I've tried this already. 2910 ask me to remove "ip routing" before using "ip default-gateway".
The result stays the same: 192.168.22.17 don't answer ping requests.
serpel
Trusted Contributor
Solution

Re: HP ProCurve 2910Al-24G: problem with Vlans

Have you tried to ping the FW from the switch(192.168.22.18)?
If this works try to ping from the FW to 192.168.23.1
Basically routing is working with your config, as your test with pinging the 192.168.22.18 shows, it might be that there are some routes needed at your FW, something like:
ip route 192.168.23.0/24 192.168.22.18
The switch config seems to be alright.

by the way, the command ip default-gateway doesn't do anything if ip routing is enabled. so adding the default route, as you did, is the right way to go.


hth
alex
Ximera
Occasional Contributor

Re: HP ProCurve 2910Al-24G: problem with Vlans

Seems I'm really stupid :) Yes, u'r right, wrong routes on test firewall is the reason of my problem. After ur message I checked routes and found out that the gateway for all subnets was 0.0.0.0, not 192.168.22.18 (I don't know why). Thank u very much :)
HP ProCurve 2910Al-24G:
Occasional Visitor

Re: HP ProCurve 2910Al-24G: problem with Vlans


Get bargain prices on older versions of software and save up to 90% off the original suggested price. Free shipping and if unsatisfied the company will pay the return. Click here for more details - http://www.tkqlhce.com/click-4109014-10846988