Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

HP ProCurveSR7102dl & Unable to Ping VLANS

SOLVED
Go to solution
TJ Antonio Hernandez
Occasional Visitor

HP ProCurveSR7102dl & Unable to Ping VLANS

Hello, I am trying to setup VLANS on our HP ProCurve Secure Router 7102dl. The router has two interfaces. 0/1 & 0/2. I have the ports setup as follows.


-----------------------------------------------
interface eth 0/1
ip address 192.168.10.254 255.255.255.0
no shutdown
!
!
interface eth 0/2
description Phone VLAN 70
encapsulation 802.1q
no shutdown
!
interface eth 0/2.70
vlan-id 70
no shutdown
ip address 192.168.2.254 255.255.255.0
ip helper-address 192.168.10.254
-----------------------------------------------

The HP ProCurve's interface 0/2 is connected to a ZyXEL switch that has all ports set to VLAN 70 "tagged" & "Fixed".

The problem I am having with this configuration is I am unable to ping, or manage the switch with my PC connected to Int Eth 0/2

Any Ideas why I'm unable to do so?
10 REPLIES
aojea
Frequent Advisor
Solution

Re: HP ProCurveSR7102dl & Unable to Ping VLANS

I think that your PC is connected to the Zyxel switch, isn't it?.

Then, you must configure the port of the Zyxel Switch where you have connected your PC as untagged.

TJ Antonio Hernandez
Occasional Visitor

Re: HP ProCurveSR7102dl & Unable to Ping VLANS

Thank you for the reply...

Yes, my PC is connected to the ZyXEL switch on Port 8. The HP ProCurce router is connected to port 1. The ZyXEL switch now contains the following configuration but I am still unable to ping the ...

---------------------------------------------

User name: **********

Password: *********
Copyright (c) 1994 - 2007 ZyXEL Communications Corp.
ES-2108# show running-config
Building configuration...

Current configuration:

vlan 1
name 1
normal ""
fixed 1-8
forbidden ""
untagged 1-8
ip address default-management 192.168.2.1 255.255.255.0
ip address default-gateway 192.168.2.254
exit
vlan 70
name "Phone VLAN 70"
normal ""
fixed 1-8
forbidden ""
untagged 8
exit
interface port-channel 1
vlan-trunking
qos priority 6
exit
interface port-channel 2
vlan-trunking
qos priority 6
exit
interface port-channel 3
vlan-trunking
qos priority 6
exit
interface port-channel 4
vlan-trunking
qos priority 6
exit
interface port-channel 5
vlan-trunking
qos priority 6
exit
interface port-channel 6
vlan-trunking
qos priority 6
exit
interface port-channel 7
vlan-trunking
qos priority 6
exit
interface port-channel 8
vlan-trunking
qos priority 6
exit
ES-2108#

---------------------------------------------









ZyXEL has some odd explanations for thier VLANS terminology. See below for an explanation...
---------------------------------------------
Tagged = Select TX Tagging if you want the port to tag all outgoing frames transmitted with this VLAN Group ID.
---------------------------------------------







Also they have the following settings for VLANS as well....

---------------------------------------------
Normal for the port to dynamically join this VLAN group using GVRP. This is the default selection.

Fixed for the port to be a permanent member of this VLAN group.

Forbidden if you want to prohibit the port from joining this VLAN group.

---------------------------------------------

I've tried a combination of
.) port 8 tagged and fixed
.) port 8 untagged and fixed
.) port 8 tagged and fixed
.) port 8 untagged and normal


Any other ideas? I think maybe tagged means that outbound traffic on the actual port is tagging vlan data.

Your thoughts / suggestions are greatly appreciated.

Best Regards,
Antonio Hernandez
aojea
Frequent Advisor

Re: HP ProCurveSR7102dl & Unable to Ping VLANS

I don't know anything about Zyxel switches, but could you delete vlan 1 in zyxel switch?

You need to configure:

Port 1 : tagged and vlan 70
Port 8 : untagged and vlan 70
Tijl van der Steeg
Valued Contributor

Re: HP ProCurveSR7102dl & Unable to Ping VLANS

what's the use of using multiple VLAN's on the zyxel anyway, as all ports are members of both?
aojea
Frequent Advisor

Re: HP ProCurveSR7102dl & Unable to Ping VLANS

The difference is the frame format. Untagged frames are different from tagged frames.

This link explain it: http://en.wikipedia.org/wiki/IEEE_802.1Q
Tijl van der Steeg
Valued Contributor

Re: HP ProCurveSR7102dl & Unable to Ping VLANS

"tagged" VLAN's add an extra 4 bytes. Hosts usually do not understand that extra part, so it is dropping it
TJ Antonio Hernandez
Occasional Visitor

Re: HP ProCurveSR7102dl & Unable to Ping VLANS

I guess I should paint the whole picture here to clearly explain what I am trying to accomplish...

Network & Device Info:

We have 2 IP subnets.
192.168.10.x /24 (Used on VLAN1 main network)
192.168.2.x /24(Used on VLAN70 phone network)

We are using the HP ProcureSR7102dl which has 2 interfaces.
Interface Eth 0/1 = is sitting on the .10 network.

Interface Eth 0/2 = is sitting on the .2 network.


Overview:

We have a Mitel PBX that supports IP Phones. The IP phones and PBX are VLAN capable. The back of the phones have 2 jacks, one is used to plug into the wall, the other can be used to plug your PC into.

The Phones perform the following when booting...

The phone will initialize on the default vlan "1", and request an IP from our DHCP server, in this case our Domain Controller sitting on the .10 network. The DHCP offer contains a "scope option" that we configured in DHCP scope settings. The scope option basically tells the phone to reboot using VLAN 70, and obtain an IP specifically from our Mitel PBX which sits on the .2 network. The phone should then request an IP address from the Mitel, download firmware and register sucsessfully on VLAN 70.

I am attaching a visio diagram of our topology for better clarification.


TJ Antonio Hernandez
Occasional Visitor

Re: HP ProCurveSR7102dl & Unable to Ping VLANS

The problem is when the phones recieve the DHCP offer "ACK" from the Mitel PBX, it does not contain VLAN 70 on the packet. The phones connects, but is not on VLAN 70.

Here are my configs for the ZyXEL switch that sits on the .10 network, the HP Router that interconnects the two networks, and the ZyXEL switch that sits on the .2 network.


Below is the ZyXEL config on the .10 network.
---------------------------------------------

User name: **********

Password: *********
Copyright (c) 1994 - 2008 ZyXEL Communications Corp.
ES-3124PWR# show run
Building configuration...

Current configuration:

vlan 1
name 1
normal ""
fixed 1-28
forbidden ""
untagged 1-28
ip address inband-default 192.168.10.201 255.255.255.0
exit
vlan 70
name "Phone VLAN 70"
normal ""
fixed 1-28
forbidden ""
untagged 1-26,28
exit
interface port-channel 1
vlan-trunking
exit
interface port-channel 2
vlan-trunking
exit
interface port-channel 3
vlan-trunking
exit
interface port-channel 4
vlan-trunking
exit
interface port-channel 5
vlan-trunking
exit
interface port-channel 6
vlan-trunking
exit
interface port-channel 7
vlan-trunking
exit
interface port-channel 8
vlan-trunking
exit
interface port-channel 9
vlan-trunking
exit
interface port-channel 10
vlan-trunking
exit
interface port-channel 11
vlan-trunking
exit
interface port-channel 12
vlan-trunking
exit
interface port-channel 13
vlan-trunking
exit
interface port-channel 14
vlan-trunking
exit
interface port-channel 15
vlan-trunking
exit
interface port-channel 16
vlan-trunking
exit
interface port-channel 17
vlan-trunking
exit
interface port-channel 18
vlan-trunking
exit
interface port-channel 19
vlan-trunking
exit
interface port-channel 20
vlan-trunking
exit
interface port-channel 21
vlan-trunking
exit
interface port-channel 22
vlan-trunking
exit
interface port-channel 23
vlan-trunking
exit
interface port-channel 24
vlan-trunking
exit
interface port-channel 25
vlan-trunking
exit
interface port-channel 26
vlan-trunking
exit
interface port-channel 27
vlan-trunking
exit
interface port-channel 28
vlan-trunking
exit
ip address 192.168.0.1 255.255.255.0
ES-3124PWR#


---------------------------------------------

Below is the HP Config.

User Access Login

Password:
ProCurveSR7102dl>enable
Password:
ProCurveSR7102dl#show run
Building configuration...
!
!
! ProCurve Secure Router 7102dl SROS version J08.03
! Boot ROM version J06.06
! Platform: ProCurve Secure Router 7102dl, part number J8752A
! Serial number CN741TR046
! Flash: 33554432 bytes DRAM: 134217727 bytes
! Date/Time: Fri Oct 02 2009, 11:32:33 MST
!
!
hostname "ProCurveSR7102dl"
enable password ***********
!
clock timezone -7-Mountain-Time
clock no-auto-correct-DST
!
ip subnet-zero
ip classless
ip routing
!
event-history on
no logging forwarding
no logging email
logging email priority-level info
!
no service password-encryption
!
username "**********" password "**********"
!
!
no ip firewall alg msn
no ip firewall alg h323
!
!
!
!
!
!
no autosynch-mode
no safe-mode
!
!
!
!
!
!
!
!
!
!
!
!
interface eth 0/1
description DATA VLAN 10
ip address 192.168.10.254 255.255.255.0
no shutdown
!
!
interface eth 0/2
description Phone VLAN 70
encapsulation 802.1q
no shutdown
!
interface eth 0/2.70
vlan-id 70
no shutdown
ip address 192.168.2.254 255.255.255.0
ip helper-address 192.168.10.254

!
!
!
!
!
!
!
!
!
!
ip route 0.0.0.0 0.0.0.0 192.168.10.1
!
no ip tftp server
no ip tftp server overwrite
ip http server
ip http secure-server
no ip snmp agent
no ip ftp server
ip ftp server default-filesystem flash
no ip scp server
no ip sntp server
!
!
!
!
!
!
!
ip sip
ip sip proxy
!
!
!
line con 0
no login
!
line telnet 0 4
login
password **********
no shutdown
line ssh 0 4
login local-userlist
no shutdown
!
!
end
ProCurveSR7102dl#

---------------------------------------------

Below is the ZyXEL config on the .2 network.


User name: admin

Password: *********
Copyright (c) 1994 - 2007 ZyXEL Communications Corp.
ES-2108# show run
Building configuration...

Current configuration:

vlan 1
name 1
normal ""
fixed 1-8
forbidden ""
untagged 1-8
ip address default-management 192.168.2.1 255.255.255.0
ip address default-gateway 192.168.2.254
exit
vlan 70
name "Phone VLAN 70"
normal ""
fixed 1-8
forbidden ""
untagged ""
exit
interface port-channel 1
vlan-trunking
qos priority 6
exit
interface port-channel 2
vlan-trunking
qos priority 6
exit
interface port-channel 3
vlan-trunking
qos priority 6
exit
interface port-channel 4
vlan-trunking
qos priority 6
exit
interface port-channel 5
vlan-trunking
qos priority 6
exit
interface port-channel 6
vlan-trunking
qos priority 6
exit
interface port-channel 7
vlan-trunking
qos priority 6
exit
interface port-channel 8
vlan-trunking
qos priority 6
exit
ES-2108#

---------------------------------------------




Thank you everyone for taking the time to review my problem. I greatly appreciate it!

Best Regards,
Antonio Hernandez
Tijl van der Steeg
Valued Contributor

Re: HP ProCurveSR7102dl & Unable to Ping VLANS

Shouldn't the ports on the zyxel be set to "normal" instead of fixed, since the phone's are VLAN-aware?

TJ Antonio Hernandez
Occasional Visitor

Re: HP ProCurveSR7102dl & Unable to Ping VLANS

UPDATE!

I was able to try the following config last night, but I am still not able to get my phones to "jump" onto VLAN 70.

On the ZyXEL switches I configured all the ports as VLAN Trunking, & "Normal", "Untagged". The only port I tagged was port 27 on SW1 which connects to the HP "int eth 0/1".

On the HP I did the following...


int eth 0/1
description Connects to Data Network
encapsulation 802.1q
no shutdown

int eth 0/1.70
vlan-id 70
no shutdown
ip address 192.168.10.254 255.255.255.0

interface eth 0/2
description Connects to Phone Network
encapsulation 802.1q
no shutdown

interface eth 0/2.70
vlan-id 70
no shutdown
ip address 192.168.2.254 255.255.255.0
ip helper-address 192.168.10.254




What the heck am I doing wrong? Is the HP capable of tagging ports as well? I'm going to download the cli guide and double check if I can tag ports on the HP router... But the whole tagged untagged is not making sense to me.

Here is my understanding of it. When a port is tagged, it adds data to the frame when transmitting on that port that contains, vlan id, priority etc.. So any device connected to that port is able to be a "member" of that vlan.

Can someone please take a close look at the diagram I am attaching, maybe a visual aspect of my network will help find a resolution.

Thank you so much all the contributors of the site. You guys are amazing!

~TJ