Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

HP Procurve 2524M Switching off Ports

TimDunton
Advisor

HP Procurve 2524M Switching off Ports

I've noticed in the error log on that a port has gone off line.

I 08/12/06 17:01:27 ports: port 1 is now off-line

I check the port status and it was set to disabled. No other users were connected. Any ideas what might cause this?
23 REPLIES
Mohieddin Kharnoub
Honored Contributor

Re: HP Procurve 2524M Switching off Ports

Hi

Usually this message caused by LACP, have you enabled Trunking on this port ? or do you have Spanning-Tree running ?

Run the following commands:
25240# config
2524(config)# no interface all lacp
2524(config)# write mem
2524(config)# show lacp

Check this:
http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=1047224

Don;t forget to assing points.
Good Luck !!!



Science for Everyone
Matt Hobbs
Honored Contributor

Re: HP Procurve 2524M Switching off Ports

If a port was disabled, then most likely either someone disabled it, or you had port security set to disable the port on a security violation.
TimDunton
Advisor

Re: HP Procurve 2524M Switching off Ports

Thanks guys. How do I check port security?
Mohieddin Kharnoub
Honored Contributor

Re: HP Procurve 2524M Switching off Ports

Hi

use the commands:

2524# show port-security

If you have the Port Security enabled, then:
under the Action, see if you have Disable Port, then check whats the learn mode.

Good Luck !!!
Science for Everyone
TimDunton
Advisor

Re: HP Procurve 2524M Switching off Ports

Thanks mate, I checked that. Looks like it's off to me.

Does anyone else know what would randomly turn a port off? No other users were connected at the time.

HP ProCurve Switch 2524# show port-security

Port Security

Port Learn Mode | Action
---- -------------------- + ------------------------
1 Continuous | None
2 Continuous | None
3 Continuous | None
4 Continuous | None
5 Continuous | None
Mohieddin Kharnoub
Honored Contributor

Re: HP Procurve 2524M Switching off Ports

Hi

You have not clarify if this port connects to a Client, Switch or Hub.

Anyway,

In the CLI, type menu, then from the Main Menu, select:
1. Status and Counters . . .3. Port Status

Read the Intrusion Log field, and other port configuration and try to figure out if something wrong.

Good Luck !!!
Science for Everyone
TimDunton
Advisor

Re: HP Procurve 2524M Switching off Ports

Hi All,

Are you sure this is isn't a known problem? I've just had it happen again on another 2524M.

I 08/20/06 11:26:48 ports: port 1 is now off-line

Tim
TimDunton
Advisor

Re: HP Procurve 2524M Switching off Ports

Nothing in the intrusion logs by the way. All I can find is that port info.
Mohieddin Kharnoub
Honored Contributor

Re: HP Procurve 2524M Switching off Ports

Hi

It sounds a weird issue you have there.
use HP2512> show logging,
to list all recorded log messages since last reboot.
If you can also attach the configuration of the switch, with little info about the network map.

Good Luck !!!
Science for Everyone
TimDunton
Advisor

Re: HP Procurve 2524M Switching off Ports

Thanks, can you confirm how to extract the config?
Mohieddin Kharnoub
Honored Contributor

Re: HP Procurve 2524M Switching off Ports

Hi
If you can access the Web interface for the switch, then:
Switch Diagnostics > Configuration report,
copy the contents to a text file.

Don;t forget to assign points to posts helped you :)

Good Luck !!!
Science for Everyone
TimDunton
Advisor

Re: HP Procurve 2524M Switching off Ports

Thanks guys. I've attached the config.
Mohieddin Kharnoub
Honored Contributor

Re: HP Procurve 2524M Switching off Ports

Hi

Why you keep interfaces on 10-auto, any reason?

Try to make it auto:

2524(config)#interface 1 speed-duplex auto.

and if it worked, then:

2524(config)#interface 1-24 speed-duplex auto.

Good Luck !!!
Science for Everyone
TimDunton
Advisor

Re: HP Procurve 2524M Switching off Ports

Hello,

Yes, I keep them at 10Mb so that no one server can flood our network. Our net connection is just 10Mb anyway so there should be no loss of traffic.

Tim
Mohieddin Kharnoub
Honored Contributor

Re: HP Procurve 2524M Switching off Ports

Have you tried the Auto option ???
Science for Everyone
TimDunton
Advisor

Re: HP Procurve 2524M Switching off Ports

Which auto option? Auto-100?
Mohieddin Kharnoub
Honored Contributor

Re: HP Procurve 2524M Switching off Ports

Its just Auto

(config)#inter 1 speed-duplex auto
Science for Everyone
TimDunton
Advisor

Re: HP Procurve 2524M Switching off Ports

I would prefer to keep the network at 10Mb Auto so that no connections can go over the 10Mb threshold. Unless you think that's causing the problem.
Mohieddin Kharnoub
Honored Contributor

Re: HP Procurve 2524M Switching off Ports

Would you try it ?
Science for Everyone
Steffen Koepf
Occasional Visitor

Re: HP Procurve 2524M Switching off Ports

I have the same problem with several procurve 2524. It hits always port 1, never another one.
"write terminal" shows - amon other things -

interface 1
disable
exit

One can reenable it, and it works again after this. A firmware-update to the latest version has not solved this problem as it seems.
Matt Hobbs
Honored Contributor

Re: HP Procurve 2524M Switching off Ports

Are you running any network management applications? (ProCurve Manager)?

Are you using the default SNMP community names which allows read/write on public? If yes, I would recommend changing this as something may be disabling this port via SNMP.
TimDunton
Advisor

Re: HP Procurve 2524M Switching off Ports

Yep, it's always port 1 for me too I think, well most commonly port 1. It's very odd, I think it might be a bug.
Steffen Koepf
Occasional Visitor

Re: HP Procurve 2524M Switching off Ports

No, there is no network management application running. And no Procurve Manager.

I have to admit that the SNMP config was on its defaults. I never thought that the defaults are that insane.
I restricted things a bit:
snmp-server community public operator restricted
ip authorized-managers 217.10.0.0 255.255.240.0

Thank you for your hints. Let's have a look if this problem disappears.