Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

HP Procurve 2610 Problem with DHCP

PCC_Support
Occasional Contributor

HP Procurve 2610 Problem with DHCP

I am adding a new switch for a new office. The WAN is a Switched Time Warner Metronet. One port on each switch plugs into the WAN network. It is NOT routed.

The existing network is layed out like this:

The DHCP server is: 192.168.1.4. It has three scopes defined. 192.168.1.x, 192.168.3.x and 192.168.4.x. 3.x and 4.x are identically configured.

192.168.1.0/24: the hub of the network served by a Procurve 3400cl

192.168.3.0/24: a remote office served by a Procurve 2626 (this network works perfectly)

192.168.4.0/24: remote office served by a Procurve 2610. Routing is fine. Only DHCP doesn't work right. DHCP addresses returned by PCs on this switch are 192.168.1.x (but should be 192.168.4.x). This switch is configured identically to the 2626.

I have confirme that the incorrect addresses are being returned from the correct DHCP server. There are no rogue DHCP devices interfearing.

Configs for all three switches attached.

HP Tier1 support couldn't help. What am I missing?
7 REPLIES
Mohammed Faiz
Honored Contributor

Re: HP Procurve 2610 Problem with DHCP

Hi,

"192.168.4.0/24: remote office served by a Procurve 2610" -> where's the gateway for this network?
PCC_Support
Occasional Contributor

Re: HP Procurve 2610 Problem with DHCP

Please see the attached document for the configs of all three devices in the network, including gateway configs...
Pieter 't Hart
Honored Contributor

Re: HP Procurve 2610 Problem with DHCP

>>> The DHCP server is: 192.168.1.4.<<<
+
>>>
vlan 1
name "LAN"
untagged 1-25
ip address 192.168.3.1 255.255.255.0
ip helper-address 192.168.1.10
ip helper-address 192.168.1.4
ip helper-address 192.168.1.2
<<<

what do the other ip-helper adresses do?

NB!

The second and third of the attached configs look identical (have the same adresses)!
is this real or a copy/paste-error?
PCC_Support
Occasional Contributor

Re: HP Procurve 2610 Problem with DHCP

The third config was a copy/paste error. The correct config follows. The IP helper entries are obsolete. I don't know why they are there. The only DHCP server on the network is 192.168.1.4 (an SBS server). By the way DHCP relay is configured on all the switches because it was the only way we could find to get a bunch of Linksys wireless routers to provide DCHP addresses from the scopes.

; J4905A Configuration Editor; Created on release #M.10.06

hostname "ProCurve Switch 3400cl-24G"
interface 22
speed-duplex 100-full
exit
ip default-gateway 192.168.1.2
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "LAN"
untagged 1-21,23-24
ip address 192.168.1.3 255.255.255.0
ip helper-address 192.168.1.4
ip helper-address 192.168.1.2
tagged 22
exit
vlan 2
name "WAN"
untagged 22
ip address 10.0.0.1 255.255.255.0
exit
dhcp-relay option 82 keep
ip route 192.168.3.0 255.255.255.0 10.0.0.3
ip route 0.0.0.0 0.0.0.0 192.168.1.2
ip route 192.168.4.0 255.255.255.0 10.0.0.4
primary-vlan 2
Pieter 't Hart
Honored Contributor

Re: HP Procurve 2610 Problem with DHCP

The unused ip-helpers should be removed, I imagine for every dhcp-request the switch tries them in specified order, It keeps no track of wich server is available.
So many requests will vannish when being adressed to non-existing dhcp-servers.

The 2620,s receive their dhcp-requests on vlan-1 (LAN)
and must route the requests using the DHCP-helper address (192.168.1.4).
in your config they can only do this using to the default-route to (10.0.0.1).

this arrives via the WAN vlan at the 3400.
this has the subnet directly connected (vlan-1). the ip-helper-adresses here have no function and should be removed.
the dhcp-server should have the 3400 (192.168.1.3) as it default-gateway address
or have static routes for the reverse routes.

PCC_Support
Occasional Contributor

Re: HP Procurve 2610 Problem with DHCP

"The unused ip-helpers should be removed, I imagine for every dhcp-request the switch tries them in specified order, It keeps no track of wich server is available.
So many requests will vannish when being adressed to non-existing dhcp-servers."

Yes. I intende to do this.

The 2620,s receive their dhcp-requests on vlan-1 (LAN)
and must route the requests using the DHCP-helper address (192.168.1.4).
in your config they can only do this using to the default-route to (10.0.0.1).

Yes, I understand this.

this arrives via the WAN vlan at the 3400.
this has the subnet directly connected (vlan-1). the ip-helper-adresses here have no function and should be removed.

I need the DHCP helper here for use with Wireless Linksys routers...

the dhcp-server should have the 3400 (192.168.1.3) as it default-gateway address
or have static routes for the reverse routes.

Not completely clear on what you mean here... currently the default-gateway for DHCP scope 192.168.3.0 is 192.168.3.1 (and is working). The default-gateway for 192.168.4.0 is 192.168.4.1 (not working). If I understand you, the default gateway for both of these should actually be 192.168.1.3 (the 3400). Also, the 3400 has staic route for 192.168.4.1 (10.0.0.4) and 192.168.3.1 (10.0.0.3). Since the 3.x VLAN and scope work, I'm confused as to why the 4.x one does not. Thank you so much for your help.
Pieter 't Hart
Honored Contributor

Re: HP Procurve 2610 Problem with DHCP

>>>
the dhcp-server should have the 3400 (192.168.1.3) as it default-gateway address
or have static routes for the reverse routes.
-
Not completely clear on what you mean here..
<<<

What's the default-gateway configured on the DHCP-server?
For the DHCP-server to send DHCP-offers back to the requesting station, it must know the path back to this subnets.

If it's set to the 3400 (ip address 192.168.1.3 255.255.255.0 ) then this is OK.
If it's set to the external router (ip route 0.0.0.0 0.0.0.0 192.168.1.2) then this router must have static routes back using the 3400.
ip route 192.168.3.0 255.255.255.0 192.168.1.3
ip route 192.168.4.0 255.255.255.0 192.168.1.3

>>>
I need the DHCP helper here for use with Wireless Linksys routers...
<<<
Then here also the default-gateway setting must be checked (3400 or external router).
A dhcp-helper is needed to convert DHCP-broadcasts to unicasts that can be routed to another subnet.
The DHC_server (192.168.1.4) is local to the 192.168.1.0 subnet, so there's no need to configure a dhcp-helper address on this subnet, as it doesn't need to be routed.