Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

HP Procurve 7102dl

SOLVED
Go to solution
John French
Occasional Visitor

HP Procurve 7102dl

I just purchased a Procurve 7102dl router. No one in our office knows much about them. It came with no modules just the two input port. All I am looking to do is connect our office to the internet. We are using 3M fiber provider. Which module if any do I need. When we purchased it they recomended HP J4858A as well. We are using a older HP Procurve switch. I am looking to conntect the router to my switch. I know how to remote into it and configure the ports. Any help would be great. thanks
6 REPLIES
Olaf Borowski
Respected Contributor
Solution

Re: HP Procurve 7102dl

Hi John,

The HP J4858A is a HP ProCurve Gigabit-SX-LC Mini-GBIC transceiver and will "NOT" fit in a 7102dl router. The router doesn't have any SFP slots that could house such transceiver. The router comes with 2 built-in 10/100Mbit Copper Ethernet interfaces. The two open slots are for traditional WAN modules like T1, Serial, etc.
If your provider is dropping of an Ethernet connection (copper), just plug that into one Ethernet port of the router (example Eth0/1). The other Ethernet port (Eth0/2)should go to your switch. I assume you are going to use the Firewall/NAT features of the router and if you need multiple security zones on the router, you need a switch that supports VLAN tagging. Via the CLI, configure an IP address on the interface pointing to the switch, configure a username and password and then you can WEB into the switch and use the firewall wizard to guide you through the rest of the configuration.

Good luck.

Olaf

John French
Occasional Visitor

Re: HP Procurve 7102dl

Thanks for the feedback, I do have just a few more questions seeing this is the first time I am programing a rout. I have managed to program eth 0/1 with my my network info and have activated the Gui. I am having and issue getting my Internet to work. I plugged in all the ip information provided by my ISP but with not luck. Do know of any good resources I could use to configure the wan side. We have a static IP, You are give the the option of DHCP , static or non. I did switch to DHCP and it picked up ISP info but still could not access internet from network. Any suggestions. Thanks
Olaf Borowski
Respected Contributor

Re: HP Procurve 7102dl

John,
Static IP address configuration will work.
Example:
WAN
Interface eth0/1 connects to your provider.
IP: 15.1.1.1 255.255.255.248
Default gateway: 15.1.1.2
DNS: some IP with your provider.

LAN:
Interface Eth0/2 connects to your internal network (switch)
IP: 192.168.1.254 255.255.255.0

Because you only have one external address available (15.1.1.1) and multiple clients on you LAN want to get to the Internet, you have to do Network Address Translation (in your case "PAT". Every internal address (192.168.1.x) will be translated to the external address (15.1.1.1).
From the LAN side, WEB to the box and use the Firewall wizard to configure the firewall (NAT). Also take a look at:
http://ftp.hp.com/pub/networking/software/SR7000dl-Adv-C06-NAT-Nov2006.pdf

Also in the example above, you need to configure all the clients on the LAN side to have their default gateway set to 192.168.1.254. Or, use the 7102 as your DHCP server and the default gateway address will automatically be set for the clients.

Hope this helps,

Olaf

John French
Occasional Visitor

Re: HP Procurve 7102dl

I am almost there I think just have a few issues, the firewall wizard keeps giving me a 503 earror and will not run at all. I tried one one the samples from the documentation you sent still am having no luck so I have pasted a copy of my config file to look at and see if you have any ideas.

!
hostname "1stoprouter"
enable password 1stop_security
!
clock timezone +7-Bangkok
!
ip subnet-zero
ip classless
ip name-server 66.60.130.2 66.60.130.6
ip default-gateway 69.62.150.1
ip routing
!
event-history on
no logging forwarding
no logging email
logging email priority-level info
!
no service password-encryption
!
username "manager" password "1stop_Admin09"
!
!
ip firewall
no ip firewall alg h323
!
!

no autosynch-mode
no safe-mode
!

interface eth 0/1
ip address 192.168.1.2 255.255.255.0
access-policy TRUSTED
no shutdown
!
interface eth 0/2
description Wan
ip address 69.62.150.5 255.255.255.192
no shutdown

ip access-list standard Belami
permit any
!
ip policy-class TRUSTED
allow list Belami
!
ip policy-class UNTRUSTED
discard list Belami
!
!
!
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
no ip tftp server
ip http server
no ip http secure-server
no ip snmp agent
no ip ftp agent
!
!
ip sip
ip sip proxy
!
line con 0
login
!
line telnet 0 4
login
password 1stoprouter09
no shutdown
line ssh 0 4
login local-userlist
no shutdown
!
!
end


Olaf Borowski
Respected Contributor

Re: HP Procurve 7102dl

Hi John,

This should work....

1stoprouter#sh run
Building configuration...
!
!
! ProCurve Secure Router 7102dl SROS version J08.03
! Boot ROM version J06.06
! Platform: ProCurve Secure Router 7102dl, part number J8752A
! Serial number US446TR001
! Flash: 33554432 bytes DRAM: 134217727 bytes
! Date/Time: Tue Sep 02 2008, 09:47:24 GMT+07:00
!
!
hostname "1stoprouter"
enable password 1stop_security
!
clock timezone +7-Bangkok
!
ip subnet-zero
ip classless
ip routing
!
!
ip name-server 66.60.130.2 66.60.130.6
!
!
event-history on
no logging forwarding
no logging email
!
no service password-encryption
!
username "manager" password "1stop_Admin09"
!
!
ip firewall
no ip firewall alg msn
no ip firewall alg mszone
no ip firewall alg h323
!
!
no autosynch-mode
no safe-mode
!
!
interface eth 0/1
ip address 192.168.1.2 255.255.255.0
access-policy Private
no shutdown
!
!
interface eth 0/2
description Wan
ip address 69.62.150.5 255.255.255.192
access-policy Public
no shutdown
!
!
ip access-list standard wizard-ics
remark Internet Connection Sharing
permit any
!
!
ip access-list extended self
remark Traffic to ProCurve SR
permit ip any any log
!
!
ip policy-class Private
allow list self self
nat source list wizard-ics interface eth 0/2 overload
!
ip policy-class Public
! Implicit discard
!
!
!
ip route 0.0.0.0 0.0.0.0 69.62.150.1
!
no ip tftp server
no ip tftp server overwrite
ip http server
no ip http secure-server
no ip snmp agent
no ip ftp server
ip ftp server default-filesystem flash
no ip scp server
no ip sntp server
!
!
!
!
no snmp-server enable traps
!
!
!
ip sip
no ip sip proxy transparent
!
!
!
!
line con 0
no login
!
line telnet 0 4
login
no shutdown
line ssh 0 4
login local-userlist
no shutdown
!
end

You had a few issue:
Don't use IP default gateway. This is used for Bridging. Use: ip route 0.0.0.0 /0 x.x.x.x to set your default route. It's a router, not a switch.
Access policies also had issues but this one should work.
Next time, don't post your real IP addresses and passwords. Hackers are just waiting for information like this...

Good luck,

Olaf
John French
Occasional Visitor

Re: HP Procurve 7102dl

We I am still not have any luck even with the configuration you gave me. I was able update the firmware which was help full but still not connecting to the internet. For a short while instant messenger was working but no web and know nothing. I went online a followed the firewall wizard samples and they too did not work.

Any other suggestions or references. Never had such a hard time getting online fore this is getting crazy.