Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

HP Procurve VLAN Conf Not Working - URGENT

abousame
Occasional Visitor

HP Procurve VLAN Conf Not Working - URGENT

Dear,

I have HP 5406 zl -2 and 3500 yl -5 Switches...
Working scenarios:

192.168.115.0/24 (Default and DATA VLAN) and 192.168.116.0/24 (Voice VLAN).

Now we need to setup these VALNs different categories instead of 115 segment and 116 will remain same for Voice.

115 should splitted in to 114 (Application servers)
115 for NW devices and other servers like AD,FS
117 for users - with MS DHCP Server
118 for executive users - with MS DHCP Server
119 for printers.

Once I configured VALN as per our new scenario... First core switch only working fine! but, other switches are not working...

Please provide a best practice and configurations (we have around 60 users only)

I'll be thankful for your quick reply.
3 REPLIES
Jeff Carrell
Honored Contributor

Re: HP Procurve VLAN Conf Not Working - URGENT

If you have a single cable connecting from core to each other switch, you need to "tag" the interface so it will pass multiple VLANs.

5406-a1---1-sw2
||a2----1-sw3
|a3-----1-sw4

etc

5406 config looks something like:

5406(config)# vlan 115 tag a1-a3
5406(config)# vlan 117 tag a1-a3
5406(config)# vlan 118 tag a1-a3
5406(config)# vlan 119 tag a1-a3


other switches:

sw2(config)# vlan 115 tag 1
sw2(config)# vlan 117 tag 1
sw2(config)# vlan 118 tag 1
sw2(config)# vlan 119 tag 1

repeat for each switch.


then assign client ports into VLANs:

sw(config)# vlan 115 untagged

hth...Jeff
abousame
Occasional Visitor

Re: HP Procurve VLAN Conf Not Working - URGENT

Thanks Cheif... I'll try now...

abousame
Occasional Visitor

Re: HP Procurve VLAN Conf Not Working - URGENT

Hi Jiff,

I try with the following confg; please verify..
------------------
Core switch:-
------------------
ip default-gateway 192.169.115.1
ip routing

vlan 1
untagged A1-A20
ip address 192.169.115.254 255.255.255.0
tagged B19-B24
no untagged A13-A24,B1-B18
exit

vlan 26
ip address 192.169.116.254 255.255.255.0
tagged A1-A24,B1-B24
voice
exit

vlan 27
untagged A21-A24,B1-B6
ip helper-address 192.169.115.199
ip address 192.169.117.254 255.255.255.0
exit

vlan 28
untagged B7-B15
ip helper-address 192.169.115.200
ip address 192.169.118.254 255.255.255.0
exit

vlan 29
untagged B16-B18
ip address 192.169.119.254 255.255.255.0
exit

ip route 0.0.0.0 0.0.0.0 192.169.115.1
spanning-tree
----------------------------
Edge Switch Confg:-
----------------------------
ip default-gateway 192.169.115.1
ip routing

vlan 1
name "DATA_VLAN"
ip address 192.169.115.252 255.255.255.0
tagged 1-24
exit

vlan 26
tagged 1-24
voice
ip address 192.169.116.252 255.255.255.0
exit

vlan 27
untagged 1-16
ip helper-address 192.169.115.199
ip address 192.169.117.252 255.255.255.0
exit

vlan 28
untagged 17-20
ip helper-address 192.169.115.200
ip address 192.169.118.252 255.255.255.0
exit

vlan 29
untagged 21-23
ip address 192.168.119.252 255.255.255.0
exit

spanning-tree

---------------

and i try to connect single cable
CoreSW b19 --> Edge switch 1 port 24
CoreSW b20 --> edge switch 2 Port 24
CoreSW b21 --> edge switch 3 port 24
and so on...

Please advice!

Thanks.