Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

HP2650 VLAN routing

SOLVED
Go to solution
Harold Parker
Occasional Advisor

HP2650 VLAN routing

I am wondering if someone can help. I think this should be an easy fix but I am just overlooking something simple.

I have a couple of VLANS and I want to route between them. My ISP router is 192.168.1.1

From the switch CLI I can ping everywhere. From the 192.168.100.0/24 network I can only ping the VLAN100 IP 192.168.100.1 and the Default Vlan IP 192.168.1.104. From the Default VLAN I can ping nodes on the 192.168.100.1/24 network.

What do I need to do to get the node on the 192.168.100.0/24 to talk to the other VLAN and get out to the internet?

**********************************************
hostname "ProCurve Switch 2650"
ip default-gateway 192.168.1.1
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-16,21-50
ip address 192.168.1.104 255.255.255.0
no untagged 17-20
exit
vlan 100
name "VLAN100"
untagged 17-20
ip address 192.168.100.1 255.255.255.0
exit
ip route 0.0.0.0 0.0.0.0 192.168.1.1
14 REPLIES
EckerA
Respected Contributor

Re: HP2650 VLAN routing

Hi,
the Clients in the 192.168.100.0/24 subnet needs the 192.168.100.1 to be their gateway and clients in 192.168.1.0/24 the 192.168.1.104.
then you need a static route at the device with the ip 192.168.1.1. Something like this
ip route 192.168.100.0/24 192.168.1.104
hope this helps
alex
cenk sasmaztin
Honored Contributor
Solution

Re: HP2650 VLAN routing

hostname "ProCurve Switch 2650"
ip default-gateway 192.168.1.1****!!!!!no need!!!
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-16,21-50
ip address 192.168.1.104 255.255.255.0
no untagged 17-20
exit
vlan 100
name "VLAN100"
untagged 17-20
ip address 192.168.100.1 255.255.255.0
exit
ip route 0.0.0.0 0.0.0.0 192.168.1.1



your switch conf true but no need ip default gateway

you make must be write static route on internet router
and check pc ip config
**************************
internet router config
****************************************************

192.168.100.0 255.255.255.0 192.168.1.104
and this router connect vlan 1 untag port
(internet router lan ip address must be 192.168.1.1)

*****************************************************

*************************
pc config
*****************************************************
vlan 1 member pc
for example
ip address :192.168.1.10
subnet mask:255.255.255.0
default gateway:192.168.1.104
and connect vlan 1 untag port

vlan 100 member pc
for example
ip address:192.168.100.10
subnet mask:255.255.255.0
default gateway:192.168.100.1
and connect vlan 100 untag port
cenk

cenk sasmaztin
Honored Contributor

Re: HP2650 VLAN routing

finally

you can write ip route command on internet router

[ip route 192.168.100.0 255.255.255.0 192.168.1.104]

and check pc ip config
cenk

Harold Parker
Occasional Advisor

Re: HP2650 VLAN routing

Thanks for your help. I have made progress but I have another problem.

I removed the "ip default-gateway 192.168.1.1" as suggested and I was missing the route to the 192.168.100.0/24 on my ISP router. Now I can ping back and forth between nodes on both sub nets. I am seeing one other issue - DNS does not seem to work for the client on VLAN100. When I try to do an nslookup I get

DNS request timed out.
timeout was 2 seconds.
*** Can't find server name for address 68.87.71.226: Timed out
DNS request timed out.
timeout was 2 seconds.
*** Can't find server name for address 68.87.73.242: Timed out
*** Default servers are not available
Default Server: UnKnown
Address: 68.87.71.226


DNS server 68.87.71.226 & 68.87.73.242 are valid for my ISP and works for clients on the DEFAULT_VLAN

Seems like DNS request fails from VLAN100

Do I need to do something to have the switch forward DNS requests similar to DHCP helper?
cenk sasmaztin
Honored Contributor

Re: HP2650 VLAN routing

please send me sh run print
cenk

cenk sasmaztin
Honored Contributor

Re: HP2650 VLAN routing

unable switch dns request like ip helper very different aplication

if you can not reachable dns server
you have routing problem on switch or internet router

please send me sh run print switch
cenk

Harold Parker
Occasional Advisor

Re: HP2650 VLAN routing

here is the show run, thanks

hostname "HRC_CORE_1"
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 1-16,21-50
ip address 192.168.1.104 255.255.255.0
no untagged 17-20
exit
vlan 100
name "VLAN100"
untagged 17-20
ip address 192.168.100.1 255.255.255.0
exit
ip route 0.0.0.0 0.0.0.0 192.168.1.1
cenk sasmaztin
Honored Contributor

Re: HP2650 VLAN routing

please you take me routing command on internet router
cenk

Harold Parker
Occasional Advisor

Re: HP2650 VLAN routing

this shows static routes on my isp router

Destination LAN IP Subnet Mask Gateway Hop Count Interface
192.168.100.0 255.255.255.0 192.168.1.104 0 LAN & Wireless
192.168.1.0 255.255.255.0 0.0.0.0 0 LAN & Wireless
192.168.30.0 255.255.255.0 192.168.1.104 0 LAN & Wireless
192.168.200.0 255.255.255.0 192.168.1.104 0 LAN & Wireless
98.229.32.0 255.255.240.0 0.0.0.0 0 WAN (Internet)
0.0.0.0 0.0.0.0 98.229.32.1 0 WAN (Internet)
Harold Parker
Occasional Advisor

Re: HP2650 VLAN routing

I did some more troubleshooting last night. It is not only DNS that does not work from VLAN 100. I can ping an IP on the internet from the Default VLAN but not from VLAN 100. Looks like I cant get out to the internet from VLAN 100. I can only get as far as my ISP gateway 192.168.1.1 from VLAN 100.
cenk sasmaztin
Honored Contributor

Re: HP2650 VLAN routing

please check vlan 100 member pc must be default gateway address 192.168.100.1
cenk

Harold Parker
Occasional Advisor

Re: HP2650 VLAN routing

Yes, vlan 100 member does have default gateway address 192.168.100.1

VLAN 100 member can ping ISP gateway 192.168.1.1 but that is as far as I can get.

I am using a Linksys WRT54G v4 as my ISP router. Dont know if that matters - should just route packets right? I have a static route to get back to VLAN 100
cenk sasmaztin
Honored Contributor

Re: HP2650 VLAN routing

no need any routing check access control list on router or firewall
cenk

cenk sasmaztin
Honored Contributor

Re: HP2650 VLAN routing

vlan 100 routing overlap other routing command on isp router


Destination LAN IP Subnet Mask Gateway Hop Count Interface
***192.168.100.0 255.255.255.0 192.168.1.104 0 LAN & Wireless
192.168.1.0 255.255.255.0 0.0.0.0 0 LAN & Wireless
***192.168.30.0 255.255.255.0 192.168.1.104 0 LAN & Wireless
***192.168.200.0 255.255.255.0 192.168.1.104 0 LAN & Wireless
98.229.32.0 255.255.240.0 0.0.0.0 0 WAN (Internet)
0.0.0.0 0.0.0.0 98.229.32.1 0 WAN (Internet)





I don't understand some routing commad

this routing command make any ip ,any subnet go to 98.229.32.1
what for necessary this routing on router ?

0.0.0.0 0.0.0.0 98.229.32.1 0 WAN (Internet)(what for ?)


this routing commad make 98.229.32.0 network go to any ip address
what for necessary this routing on router ?
98.229.32.0 255.255.240.0 0.0.0.0 0 WAN (Internet)


192.168.1.0 255.255.255.0 0.0.0.0 0 LAN & Wireless (what for)



and for full routing performance must be associate some routing commad (***)

associate same command all (star)

192.168.0.0 255.255.0.0 192.168.1.104


my advice clear all routing command your isp router

and write one command and test

one commad

192.168.0.0 255.255.0.0 192.168.1.104


cenk