Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Help configuring a Vlan, new to procurve hardware

Madadmin
Occasional Visitor

Help configuring a Vlan, new to procurve hardware

Thanks in advance for the help everyone. I have a HP procurve 2410g switch. I configured a new vlan with 192.168.0.1 255.255.255.0; default vlan is 192.168.168.1 address. I untagged the ports 14 and 16 from the default vlan and tagged them with the new vlan i just created. From a desktop i can ping 192.168.0.1 but cant ping any of the machines that are plugged into those two ports. Please tell me a step im missing so i can get this vlan up and running and able to communicate with other vlans on the same switch.

Thanks!
5 REPLIES
Pieter 't Hart
Honored Contributor

Re: Help configuring a Vlan, new to procurve hardware

tagged means a vlan-tag is added to the network packet.
Most host NIC drivers are not "vlan aware"
and cannot handle packets WITH vlan-tag.
=> you must untag the member ports of the new vlan if connected to a PC.

only one vlan can be configured untagged. -> when you configure them untagged for the new vlan they are removed as untagged for the default vlan.

second,
To communicate between subnets/vlans you must add a router with an interface in each vlan.
else the vlan's remain speparate networks not able to exchange data.

check if the 2410 can do this, else you need an external router.
Madadmin
Occasional Visitor

Re: Help configuring a Vlan, new to procurve hardware

Could you please give me an example of how i would accomplish routing with the two subnets that i've provide via the CLI.
Pieter 't Hart
Honored Contributor

Re: Help configuring a Vlan, new to procurve hardware

i've still not check if this model switch suports routing.

but the commands would be:
1) give each vlan an ip address and put ports untagged in the vlan
vlan 1
name "DEFAULT_VLAN"
untagged A1-A4
ip address 192.168.168.1 255.255.255.0
vlan 2
name "NEW_VLAN"
untagged A5-A9
ip address 192.168.0.1 255.255.255.0
exit

2) then enable routing
ip routing

3) if an external router is present add a default route
(eg internet router on default vlan with adress ".2")
ip route 0.0.0.0 0.0.0.0 192.168.168.2

4)
this router must also "know" the subnet behind the switch (a route back)
ip route 192.168.0.0 0.0.0.255 192.168.168.1

5)
hosts in default vlan must have 192.168.168.1 as default gateway
hosts in vlan-2 vlan must have 192.168.0.1 as default gateway
Madadmin
Occasional Visitor

Re: Help configuring a Vlan, new to procurve hardware

I dont believe this model is capable of routing because the command isnt listed in the command table. I assume the rest of this will be accomplished on my cisco router?
Usaia Tawakevou
Frequent Advisor

Re: Help configuring a Vlan, new to procurve hardware

Yes, your router has to do that. If Cisco, this might help you to start off. Say your switch connected to FastEthernet0/0 of Cisco then your Cisco config might look like this:

interface FastEthernet0/0
description DEFAULT_VLAN
ip address 192.168.168.1 255.255.255.0
!
interface FastEthernet0/0.1
description NEW_VLAN
encapsulation dot1Q 2
ip address 192.168.0.1 255.255.255.0

On your HP 2410g your config will be something like this if your Cisco is connected to port 24 of your HP:
vlan 1
name "DEFAULT_VLAN"
untagged 24
ip address 192.168.168.2 255.255.255.0
exit
vlan 2
name "NEW_VLAN"
no ip address
tagged 24
exit

You can then untagged the ports that you want to assign to a particular VLAN

Hope this helps