Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

How do you turn off LACP on Procurve 5304xl ???

SOLVED
Go to solution
Gary_121
Occasional Visitor

How do you turn off LACP on Procurve 5304xl ???

Hi I need to turn off LACP on the Procurve
it's causing problems on Macintosh machines and Appletalk broadcasts.

I have no idea what the command lines are to do this can any wonderfull person help out.

Desperate to sort this one asap.

P.S In dunces language if you please .

Thanks in advance.
9 REPLIES
Ron Kinner
Honored Contributor

Re: How do you turn off LACP on Procurve 5304xl ???

Looking at the manual it appears there are two things you might need to do. If a port is already in a trunk you have to take it out of the trunk first. Then you set LACP to passive.

To remove a range of ports C1-C4 from a trunk you go into config mode then say:

no int e C1-C4 lacp

then

int e C1-C4 lacp passive

you can use the non-config mode command
show lacp
to see if it worked. You probably don't need to remove ports from a trunk first unless they have gotten confused but I put it in there because the example in the book shows it. You may want to look at chapter 9 in the HP ProCurve Series 5300XL Switches Management and Configuration Guide (Edition 7, April 2003)

at

http://www.hp.com/rnd/support/manuals/5300xl.htm


Ron
Gary_121
Occasional Visitor

Re: How do you turn off LACP on Procurve 5304xl ???

Hi looking at show LACP all ports are in passive mode, No ports are trunked, however in the log I am seeing constant ports diabled by LACP.
In show LACP the status of LACP is active I am sure there must be a way to make it disabled as even in passive mode the ports are being blocked.

Attached two screen shots shows passive on all ports and log of blocked by LACP.
Gary
Gary_121
Occasional Visitor

Re: How do you turn off LACP on Procurve 5304xl ???

This is the second image
Shane_33
Frequent Advisor
Solution

Re: How do you turn off LACP on Procurve 5304xl ???


You need to telnet into the switch, and issue the following commands at the prompts:

HP ProCurve Switch 5304xl# conf t
HP ProCurve Switch 5304xl(config)# int all
HP ProCurve Switch 5304xl(eth-x-x)# no lacp
HP ProCurve Switch 5304xl(eth-x-x)# wr mem

just type in the bits that follow the "#" sign, and make sure the prompts before it look the same (or similar).

Where it says (eth-x-x), the x's will be the beginning and end ports selected (which is dependant on how many ports you have installed).

BTW - this will disable LACP on ALL PORTS IN THE SWITCH.

Regards,
Shane.
Shane_33
Frequent Advisor

Re: How do you turn off LACP on Procurve 5304xl ???

BTW - the above is only needed in an Appletalk environment. The benefits of having LACP enabled in Passive Mode (which is the default setting on HP switches with LACP support) far outweigh the negatives in a PC only environment.

This is actually an Apple issue, based on the way the Appletalk protocol works (which BTW has similar issues with Spanning Tree Protocol).

See here for more info:
http://docs.info.apple.com/article.html?artnum=30922

Regards,
Shane.
Markku Leinio
Valued Contributor

Re: How do you turn off LACP on Procurve 5304xl ???

I don't see any problems in the screenshots you provided. Seems normal:

I 08/15/03 11:26:15 ports: port B12 is now off-line
I 08/15/03 11:26:20 ports: port B12 is Blocked by LACP
I 08/15/03 11:26:23 ports: port B12 is now on-line

LACP momentarily blocks the port, but the on-line condition returns after a few seconds.
Markku Leinio
Valued Contributor

Re: How do you turn off LACP on Procurve 5304xl ???

(Ok, I just saw the Appletalk-related messages; I can't tell any experiences about Appletalk workstations so my posting may be inaccurate.)
Gary_121
Occasional Visitor

Re: How do you turn off LACP on Procurve 5304xl ???

Shane many thanks great to hear it is that that's causing the problem and thank you for telling me how to turn this off, You are a Star.

Kind Regards

Gary
Gary_121
Occasional Visitor

Re: How do you turn off LACP on Procurve 5304xl ???

Closed