Switches, Hubs, and Modems

Hp Procurve 2620 Vlan Trunking Port

 
AliElHusseiny
Occasional Contributor

Hp Procurve 2620 Vlan Trunking Port

Hello , We recently bought hp switch to our environment and i was tasked by my manager to configure 2 vlans with one trunking port to allow the multiple vlans.

As I am coming form cisco world , i found the commands i know dont suite the hp CLI...

Can someone help me with the configuration please?

I created 2 vlans :

vlan 10

name Vlan10

untagged 8-10

vlan 20

name Vlan20

untagged 12-14

then the question is here i want port 24 to allow the 2 vlans to pass.

Thanks Alot.

 

9 REPLIES 9
akg7
HPE Pro

Re: Hp Procurve 2620 Vlan Trunking Port

Hello,

In procurve:

Tagged: Trunk Port

Untagged: Access Port

Support vlan 2 and vlan 3 you want to pass from port 24:

vlan 2 tagged eth 24

vlan 3 tagged eth 24

Or can take your example:

vlan 10

name Vlan10

untagged 8-10

tagged 24 

vlan 20

name Vlan20

untagged 12-14

tagged 24

Thanks!

I am an HPE Employee

Accept or Kudo

AliElHusseiny
Occasional Contributor

Re: Hp Procurve 2620 Vlan Trunking Port

So basically like this configuration will allow a laptop with static ip 10.0.0.2 connected to port 24 to ping the vlan (10.0.0.1)?

ip default-gateway 192.168.13.1
snmp-server community "public" unrestricted
vlan 1
name "VLAN1"
no untagged 8-10,12-14
untagged 1-7,11,15-28
ip address dhcp-bootp
exit
vlan 10
name "vlan10"
untagged 8-10
tagged 24
ip address 10.0.0.1 255.255.255.0
exit
vlan 20
name "vlan20"
untagged 12-14
tagged 24
ip address 20.0.0.1 255.255.255.0
exit

akg7
HPE Pro

Re: Hp Procurve 2620 Vlan Trunking Port

Hello,

If port 24 is directly connected with Laptop then this port should be a access(untagged) port and allowed VLAN would be 10.

It will be like that:

vlan 10
name "vlan10"
untagged 8-10
untagged 24
ip address 10.0.0.1 255.255.255.0
exit

 

Thanks!

I am an HPE Employee

Accept or Kudo

AliElHusseiny
Occasional Contributor

Re: Hp Procurve 2620 Vlan Trunking Port

What if i need to allow port 24 to access the 2 vlans?

it seems i cant untagged 2 vlans at the same interface.

akg7
HPE Pro

Re: Hp Procurve 2620 Vlan Trunking Port

Hello,

You can not untagged (access)same interface for two vlans. 

Thanks!

I am an HPE Employee

Accept or Kudo

AliElHusseiny
Occasional Contributor

Re: Hp Procurve 2620 Vlan Trunking Port

So, how i can let these 2 vlans (vlan 10 and vlan 20) passby or access port 24 ??

akg7
HPE Pro

Re: Hp Procurve 2620 Vlan Trunking Port

Hello,

Only one vlan on access port.

Thanks!

I am an HPE Employee

Accept or Kudo

AliElHusseiny
Occasional Contributor

Re: Hp Procurve 2620 Vlan Trunking Port

Ok... last question please , how i can add dhcp for vlan 10 for example i want it to dhcp 10.0.0.0 network

thanks alot

akg7
HPE Pro

Re: Hp Procurve 2620 Vlan Trunking Port

Hello,

It depends on your requirement.

What is you requirement for DHCP configuration?

Thanks!

I am an HPE Employee

Accept or Kudo