Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

I can't getting access to several SWs by serial port

LuisMLG
Occasional Contributor

I can't getting access to several SWs by serial port

Hi all!

I have a infrastructure based in Procurve Switches (6x2626, 5x2824 and core 5400zl). Since 1 month We have suffered connections problems which resolved restarting all switches. Unfortunately, the problem persist and now another problem has started. Now, some SW loss the administrative access. They are inaccessible by telnet, web and serial port!! Its really incredible serial port doesn´t work! Well, It's not fully true, I can access to prompt and get in to enable mode but when I type sh spanning tree or sh system... o whatever show me 3 lines of information and bock itself. I can retry 2 times more, and the administrative access die. No prompt, no login, nothing anymore. To get back the administrative access I have to restart de SW. After to restart (between 1-6 hours) the SW comes back to be inaccessible.

I don't know why this happens. But This problem dont affect all SW just 6 (3x2626 and 3x2824) and when this happen all are affect at same time.

Any ideas? It's really rare, isn't it?

Many thanks in advanced!
7 REPLIES
Gerhard Roets
Esteemed Contributor

Re: I can't getting access to several SWs by serial port

Hi LuisMLG

What software verions are the respective switches running
5400 -- ?
2626 -- ?
2824 -- ?

KR
Gerhard
LuisMLG
Occasional Contributor

Re: I can't getting access to several SWs by serial port

the versions are:

2626:
Firmware revision : H.08.98
Firmware revision : H.08.54

2824:
Firmware revision : I.08.98

5406zl:
Software revision : K.14.34

I know that this are old versions and I have to upgrade them, but it will resolve my problem?
Another information, when I try to access to administrator console (telnet, serial, anyway) when show me several lines to info, the screen is bloked and the session is keeping active... so whe i try 3 times to get into the administrativa access is impossible.

I hope that you can help me. And I'm sorry about my broken English.
John Gelten
Regular Advisor

Re: I can't getting access to several SWs by serial port

Since not all 2626 and 2824 are affected, I would think there must be something 'different' about the ones that are affected.
Any redundant connections that might be causing a STP-loop in that area of your network for whatever reason ?
Or something like that; I am guessing the switches are 'hit' by a lot of traffic that causes them to go belly-flat (and stay there ;- )

Can you indicate whether the 6 affected switches are 'different' in any way than the switches that are not connected ?
Gerhard Roets
Esteemed Contributor

Re: I can't getting access to several SWs by serial port

Hi Luis

Hope you are well.
There is this fix in I.10.68 and H.10.69
Management (PR_0000005902) â Management functions may become unresponsive,
resulting in loss of TELNET, Web Management, and console access functionality of the
switch.

Even though only 6 hangs it would be good to rule out the potential known fix.

John has a great point. If something is different about those 6 switches it might point you in the correct direction.

HTH
Gerhard
LuisMLG
Occasional Contributor

Re: I can't getting access to several SWs by serial port

Ok, I have to upgrade the firmware. I have reviewed the configuration and everything is the same in all sw, STP, ports, etc..
First thing that I did when the problems started was disconnect the redundant links. At the beginning the STP is well configured and it is working fine.
Thatâ s possible that one sw which has the problem and when this sw is restarted propagates the problem to the other sw? I say that because yesterday we had 3 sw inaccessible and when switch off them and switch on again, after 30 minutes we came back to have 6 sw inaccessible.
Now I think know which one is the sw that has the problem, in fact, yesterday at last, we restarted 5 sw except one, and right now all sw are accessible except one. I think that is we restart the only one sw that is inaccessible, with a few time we come back to have 6 sw inaccessible again.

All of this, in my opinion is very rare, what about of that? This new information helps you anything?

Thanks a lot.
Gerhard Roets
Esteemed Contributor

Re: I can't getting access to several SWs by serial port

Hi Luis

Would you mind posting the "show logging -a" and "show sys" and "show run" if possible output of the devices that suffer the issue.

Which switch is the one you suspect of being the "bad b boy" ?

I do realise due to security reasons etc it might not be possible.

KR
Gerhard
LuisMLG
Occasional Contributor

Re: I can't getting access to several SWs by serial port

Hi again,

I've attached a file with sh logging's output. I hope to be of help you.

The "bad boy" is inaccessible right now and I can not use CLI commands. We can not restart this SW because it is giving service to many server and other production systems and We need to do a planned stop to restart it.

Thanks you for the attention.