Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

IP Conflict on VLAN

Tom Hardy
Frequent Advisor

IP Conflict on VLAN

hello guys,

Here is my current config on 5406.
vmdCore(vlan-4)# sh conf

Startup configuration:

; J8697A Configuration Editor; Created on release #K.11.11

hostname "vmdCore"
snmp-server location "nocRack"
module 1 type J8702A
module 2 type J8702A
module 3 type J8702A
mirror-port C11
interface A9
power Critical
exit
ip default-gateway 192.168.30.1
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "dataVlan"
untagged A3,A10-A24,B2-B24,C1-C24
qos priority 5
ip helper-address 192.168.30.90
ip address 192.168.30.2 255.255.255.0
no untagged A1-A2,A4-A9,B1
ip proxy-arp
exit
vlan 2
name "voiceVlan"
untagged B1
qos priority 7
ip helper-address 192.168.30.90
ip address 192.168.0.254 255.255.255.0
tagged B2-B23,C1-C24
voice
ip proxy-arp
exit
vlan 4
name "trixbox"
untagged A1-A2,A4-A8
qos priority 7
ip helper-address 192.168.30.90
ip address 192.168.10.1 255.255.255.0
tagged A3,C12
ip proxy-arp
exit
vlan 3
name "Server"
untagged A9
ip helper-address 192.168.30.90
ip address 10.20.20.1 255.255.255.0
tagged A3
ip proxy-arp
exit
interface A24
monitor
exit
qos device-priority 204.x.x.x priority 7
qos type-of-service diff-services
spanning-tree force-version RSTP-operation
ip route 0.0.0.0 0.0.0.0 192.168.30.1
ip route 204.x.x.x 255.255.255.255 192.168.0.1
password manager
password operator


As you can see, I have port A3 untagged on the default vlan1 and tagged on vlan3 and vlan4. When i connect my computer to port A3 and statically assign the following:

ip: 10.20.20.10
sn: 255.255.255.0
dg: 10.20.20.1
dns: 4.2.2.1

i get an error message saying:

"The static IP address that was just configured is already in use on the network. Please reconfigure a different IP address."

This is a new vlan and I dont have any other device connected on this network in that IP range/subnet.

What do you think?

Thanks in advance
10 REPLIES
Tom Hardy
Frequent Advisor

Re: IP Conflict on VLAN

Now if only A3 is untagged it on vlan3 (10.20.20.0/24), and I try to connect with the static ip configuration i am able to connect without a problem. Doesnt that mean that my routing is setup fine? If that is the case what else could be causing the problem?
Tom Hardy
Frequent Advisor

Re: IP Conflict on VLAN

Another update :) Things just get wierder.

So looks like everytime i connect my pc to port A3 which is only untagged on any one vlan, and assign static ip for that vlan, i am able to connect fine. BUT if i tag a vlan on top on port A3, and can still connect on the untagged vlan but cant connect to the tagged vlan using the static ip information for that tagged vlan, & get the message :

"The static IP address that was just configured is already in use on the network. Please reconfigure a different IP address."

Please help.

Chris Stave
Advisor

Re: IP Conflict on VLAN

When you connect your computer to port A3, unless your computer is configured to use 802.1Q tagging (unlikely, unless you have specifically set this up), then your computer is going to be in VLAN 1.

According to the static configuration you are using, VLAN 1 consists of 10.20.20.xxx based on the ip address and subnet mask.

According to the config on the 5406, the switch has an interface on VLAN 1 as well, 192.168.30.2 and the subnet is 192.168.30.xxx according to the vlan 1 configuration. You are trying to use two different subnets for VLAN 1, which can make things unhappy.

It looks like you are trying to put your computer into vlan 3 by changing the ip address. This won't work.

To give your computer that ip address and have it be on VLAN 3, have vlan 3 untagged on the desired port.
Tom Hardy
Frequent Advisor

Re: IP Conflict on VLAN

Thanks for the reply which totally makes sense.

So now i avoided the non 802.1q compatible device (pc) issue and am now using a polycom 501 ip phone which is 802.1q compatible.

I am connecting this phone to port A3(tagged) on VLAN 4 with DHCP server located on VLAN 1 (192.168.30.90). Still not able to get to the internet. I do see it appear in DHCP lease.

(I have already tested by making port A3 untagged on vlan 4 on a computer and am able to get to the internet so that tells me that my routes are setup correctly).

Do you see anything wrong with my config file or do you guys think its a phone config issue?


Evert Goor
Trusted Contributor

Re: IP Conflict on VLAN

Please upgrade to switch to k12.57 firmware.
There are some weird bugs in the early k11 releases. After the upgrade try it again.
Hazrat
Occasional Visitor

Re: IP Conflict on VLAN

"I am connecting this phone to port A3(tagged) on VLAN 4 with DHCP server located on VLAN 1 (192.168.30.90). Still not able to get to the internet. I do see it appear in DHCP lease."

Does A3 only have tagged vlan 4 on it at this point or is there also an untagged vlan as well?

You have to make sure your polycom (even though it supports 802.1q) is configured to use 802.1q and is also configured to transmitt/use VLAN 4.

They polycom needs to know it is transmitting on VLAN 4. It will then modify the frame headers to specify a 802.1q frame on vlan 4. When the switch receives this, it dumps it into vlan 4. If this device isn't configured to do so, the switch will place it in the untagged vlan or drop it.

Your DHCP server may be handing out the IP, but doing so on the untagged vlan, which explains why traffic afterwards doesn't actually work once it gets an IP.

Tom Hardy
Frequent Advisor

Re: IP Conflict on VLAN

Thanks for the reply guys.

Phone is configured for vlan 4. I see it pulling an IP from vlan 4 subnet (192.168.10.x/24). I can ping it from the 5406 switch and my cisco router (192.168.30.1) which is nat'ed to the WAN.

I have also tried making the phone public and i can connect to the phone from the outside (WAN) on port 80. But the phone is not registering with the provider. It need to connect to a ftp server to register.
Tom Hardy
Frequent Advisor

Re: IP Conflict on VLAN

oh and A3 is untagged on vlan1 and tagged on vlan4
Tom Hardy
Frequent Advisor

Re: IP Conflict on VLAN

so another test that i just did was to make A3 UNTAGGED on VLAN 4. When i connect a computer to it it pulls a (192.168.10.x) ip and can connect to the internet fine.

But when i put the same cable in the phone, it does not register with the provider. REALLY WIERD!!!!
Hazrat
Occasional Visitor

Re: IP Conflict on VLAN

So you can connect to the phone from the outside world (on port 80?) SOunds like the networking and IP's are working in that case.

So, it sounds to me the problem is the phone registering with the provider?
It does the registration with FTP? and you are nat'ing?

NAT and FTP have some issues, can you configure the phone to do passive FTP?