Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

IP Routing question between switches

sphar
Advisor

IP Routing question between switches

Hi everyone,

I am migrating from 147.x.y.z to 10.x.y.z subnets

My switches are:
Procurve 2848 core switch
Procurve 2524 access switch on each floor
Running a w2k3 DC DNS/DHCP server 147.x.y.1

I want to migrate the 1st floor, will the following work???

Add 10.x.y.z DHCP scope on DC
Turn on IP routing on 2848
Create VLAN on 2524 ports a1-a8
Add IP address 10.x.y.z
Add IP address-helper being 147.x.y.1
Add PC's to a1-a8

Will the PC's on 2524 ports a1-a8 being able to access the DHCP server and get 10.x.y.z address?

How will the 2524 switch know about 147 subnet if it doesn't support routing???

Thanks!


18 REPLIES
Jeff Carrell
Honored Contributor

Re: IP Routing question between switches

so far so good, you are going in the right direction, mostly :-)

here's some minor changes to your config:

on the 2848:
create vlan 10.x.y.z
add ip addr 10.x.y.1
add ip helper-address 147.x.y.1
add tag

on the 2524:
create vlan 10
add untag 1-8
add tag


the pc's will now be in the vlan 10 on the 2524, their dhcp request will pass up to the 2848, it will "forward" that request to the dhcp srvr - sourcing the request from network 10, the dhcp server will give out a network 10 addr (since you have its scope setup, make sure the scope def g/w is the 2848 ip addr of vlan 10), the reply gets back to the pc, and pc can now communicate in the network...

hth...jeff
sphar
Advisor

Re: IP Routing question between switches

Hi Jeff,

Thanks for the tips.

So my switch configs will be:

On DC
Add second IP to NIC (10.x.y.5)
Add DHCP scope 10.x.y.z

2848
ip routing
default_vlan ... ip 147.x.y.16

Add vlan called vlan10
add ip address 10.x.y.1
add ip helper address 147.x.y.1 (DC)
add tag

2524
add vlan called vlan10
add ip address 10.x.y.16
untagged 1-8
add tag

Results / questions

PC on 2524 requests a dhcp address
The switch port has an IP 10.x.y.z and is tagged to vlan 10
So the dhcp client on PC uses vlan10 on 2848 to receive its dhcp config

How can a business unit span multiple switches if required via a vlan?
Will the PC be able to communicate with clients in 147.x.y.z subnet?

Thanks
Jeff Carrell
Honored Contributor

Re: IP Routing question between switches


1) you do not need to add a 2nd nic in the DC

2) you do not need an ip addr on the 2524, in fact its better to not have but only the single ip addr in vlan 1

3) not sure what you are asking on the question: How can a business unit span multiple switches if required via a vlan?

4) yes, since you have routing on the 2848 and each of its vlans have an ip addr, all devices on all vlans can communicate with each other

hth...jeff
sphar
Advisor

Re: IP Routing question between switches

Hi Jeff,

1) yep, no need to add 2nd nic, but I will need to add second IP (10.x.y.z) to DC

3) If I have 80 devices on a floor and want them to belong to the same vlan across multiple 2524 switches, how is this done on procurve switches?? (on cisco its VTP).

Thanks for the help!
Jeff Carrell
Honored Contributor

Re: IP Routing question between switches

1) yep, no need to add 2nd nic, but I will need to add second IP (10.x.y.z) to DC

why? remember, the switch will do all the work getting the dhcp request from vlan10 to the DC on 147...as long as you have the scope for vlan10, the dhcp server will also work correctly - it does not require an ip addr in vlan10...

3) If I have 80 devices on a floor and want them to belong to the same vlan across multiple 2524 switches, how is this done on procurve switches?? (on cisco its VTP).

ah, you have the same vlan on each switch and tag the switch-to-switch link ports in the new vlan...then have the vlan on the 2848, ip addr for the vlan (for routing), ip helper-address pointing to DC, scope in DC for this vlan...

make sense?
sphar
Advisor

Re: IP Routing question between switches

1) Add second IP (10.x.y.z) to DC

why? remember, the switch will do all the work getting the dhcp request from vlan10 to the DC on 147...as long as you have the scope for vlan10, the dhcp server will also work correctly - it does not require an ip addr in vlan10...

Why? Because wont the 10.x.y.z DHCP scope require a 10.x.y.z address for the DC DNS scope option ie.

10.x.y.z dhcp scope has 10.16.128.80 - 10.16.128.240 as its IP lease range.

Gateway as the 2848 ip addr of vlan 10 (say 10.x.y.254)

DNS address be for the DC will be the second IP address added to the DC NIC (which already has the 147 IP).

Hope that clears things up.
Jeff Carrell
Honored Contributor

Re: IP Routing question between switches

1) Add second IP (10.x.y.z) to DC

why? remember, the switch will do all the work getting the dhcp request from vlan10 to the DC on 147...as long as you have the scope for vlan10, the dhcp server will also work correctly - it does not require an ip addr in vlan10...

Why2? Because wont the 10.x.y.z DHCP scope require a 10.x.y.z address for the DC DNS scope option ie.

10.x.y.z dhcp scope has 10.16.128.80 - 10.16.128.240 as its IP lease range.

Gateway as the 2848 ip addr of vlan 10 (say 10.x.y.254)

DNS address be for the DC will be the second IP address added to the DC NIC (which already has the 147 IP).

Hope that clears things up.

jc - well, you're doing more than you have to...it is a bit more simple...

here's what the dhcp srvr needs:
1) nic with 147 addr (only)
2) dhcp scope for 147
def g/w in 147
dns addr of DC
lease range
3) dhcp scope for 10.x.y.0
def g/w 10.x.y.254
dns addr of DC (this will be dns addr 147.----
4) lease range 10.16.128.80 - 10.16.128.240

again, the switch when sending the dhcp request from the pc from vlan10, will source the request from its vlan10 addr to the dhcp srvr on 147 (its called DHCP option 82), the dhcp srvr knows to give an addr from the vlan10 scope - even tho the dhcp srvr does not have a vlan10 addr...

as long as the switch has the ip helper-addr statement on vlan10, ip routing enabled, ip addr on vlan1 (net 147) and vlan10, this all works...

try it :-)

see the DHCP Relay section of this manual, starting on page 5-123:
http://cdn.procurve.com/training/Manuals/3500-5400-6200-8200-MRG-Jan08-5-IP-Routing.pdf

it has some diagrams of what this looks like...
sphar
Advisor

Re: IP Routing question between switches

Thanks Jeff, I'll put it to the test in the test lab over the next few days.

Steve
sphar
Advisor

Re: IP Routing question between switches

Hi Jeff, hope you or another tech can check the following config as the DC DHCP server is not issue'ing the client with DHCP lease!

My DC is 147.x.y.1
I have a 2824 connected to a 2524 (port 1 on each switch). Port 21 is the DC.
10.16.128.0 is the new subnet!

Hope you can spot the problem.

hostname "hp2824"
ip default-gateway 147.x.y.1
ip routing
no timesync
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 2-20,22-24
ip address 147.x.y.10 255.255.255.0
no untagged 1,21
exit
vlan 10
name "10DOT"
ip address 10.16.128.20 255.255.254.0
ip helper-address 147.x.y.1
tagged 1,21
exit
no stack
spanning-tree protocol-version MSTP
password manager


hostname "hp2524"
time daylight-time-rule None
cdp run
ip default-gateway 10.16.128.20
vlan 1
name "DEFAULT_VLAN"
untagged 7-26
ip address 147.x.y.5 255.255.255.0
no untagged 1-6
exit
vlan 10
name "10DOT"
untagged 2-6
ip address 10.16.128.18 255.255.254.0
tagged 1
exit
no stack
no aaa port-access authenticator active
spanning-tree protocol-version stp
password manager
Jeff Carrell
Honored Contributor

Re: IP Routing question between switches

well, i see a couple of possible issues:

looks like you need to do the following:

1) untag port 21 into vlan1 on the 2824, so the DC can communicate...its in a tagged port currently on vlan10...

2) tag port 1 in vlan1 on the 2824...
(there is no vlan1 link between the switches in the latest config)

3) tag port 1 in vlan1 on the 2524...

4) also, you don't need an ip addr in vlan10 on the 2524...it doesn't hurt, but generally on a layer2 only switch you only need 1 ip addr on it for mgmt...

another comment, your spanning tree configuration is not the same on both switches, 2824 is set for MSTP, and the 2524 is set for STP...if you keep MSTP, you need to read the manual section on spanning tree for how MSTP needs to be configured, there is more to it than simply enabling it...you of course can use STP and the config is much easier...

remember, for all devices, their def g/w is the ip addr of their vlan on the 2824 switch, as its the router for those 2 networks...

hth...let us know...
sphar
Advisor

Re: IP Routing question between switches

Hi Jeff,

Thanks for the tips, on the PC connected to the Procurve 2524 I can now ping the DC!! But only if I don't use DHCP.

Hope you can assist as to why client isn't receiving a DHCP address from DC.

Steve

Static IP for the client is:
10.16.128.101
255.255.254.0
10.16.128.20
DNS 147.x.y.6 (DC)

Procurve 2824 config

ip default-gateway 147.109.24.16
ip routing
vlan1
name "DEFAULT_VLAN"
untagged 2-24
ip address 147.109.24.16 255.255.255.0
tagged 1
exit

vlan10
name "10DOT"
ip address 10.16.128.20 255.255.254.0
ip helper-address 147.109.24.6
tagged 1
exit

Procurve 2524
ip default-gateway 10.16.128.18
vlan1
name "DEFAULT_VLAN"
untagged 7-26
IP address 147.x.y.17 255.255.255.0
tagged 1
no untagged 2-6
exit
vlan10
name "10DOT"
untagged 2-6
ip address 10.16.128.18 255.255.254.0
tagged 1
exit

DC Config
testdc.test.com.au
IP Address 147.x.y.6
Subnet Mask 255.255.255.0
Default Gateway 147.109.24.16
Preferred DNS 147.x.y.6

DHCP Scope 147.x.y.1 - 147.x.y.254
DHCP superscope
10.16.128.80 - 10.16.128.254
10.16.129.80 - 10.16.129.254
DNS 147.x.y.6
Gateway 10.16.128.18
(Default gateway IP of VLAN10 on 2848)
Jeff Carrell
Honored Contributor

Re: IP Routing question between switches

well, i'm not absolutely sure why...

however, i see 2 places where the def g/w settings are not correct:

1) 2524 has 'ip default-gateway 10.16.128.18'...is should be 10.16.128.20 (2824)

2) DC also has 10.16.128.18, and it should be 10.16.128.20....

the def g/w for all devices on these 2 switches is always the ip addr of the routed interfaces - 2824 vlan ip addresses...

see if that helps...
Jeff Carrell
Honored Contributor

Re: IP Routing question between switches

well, i'm not absolutely sure why...

however, i see 2 places where the def g/w settings are not correct:

1) 2524 has 'ip default-gateway 10.16.128.18'...it should be 10.16.128.20 (2824)

2) DC also has 10.16.128.18, and it should be 10.16.128.20....

the def g/w for all devices on these 2 switches is always the ip addr of the routed interfaces - 2824 vlan ip addresses...

see if that helps...
sphar
Advisor

Re: IP Routing question between switches

Hi Jeff,

Thanks for the reply - the 2524 I changed to the 10.16.128.20 gateway.

The DC is on the 147.109.16.0 subnet and the TCP/IP config complains when I add the 10.16.128.20 address as its gateway since its on another subnet.

Steve
Jeff Carrell
Honored Contributor

Re: IP Routing question between switches

on the DC, the def g/w to be changed is in the 10dot scopes...not its own def g/w...
sphar
Advisor

Re: IP Routing question between switches

Hi Jeff,

Almost working! PC can receive a dhcp address when its in the 147.x.y.z vlan on the 2524, but not on the 10.x.y.z vlan on the 2524

Vlan image attached showing config, hope you can have a quick look and check where I'm going wrong.

Thanks.
Jeff Carrell
Honored Contributor

Re: IP Routing question between switches

sorry, i can't open the attachment...

sphar
Advisor

Re: IP Routing question between switches

Hi Jeff,

Config below, think its almost 100% correct so I'll try in the office tomorrow. Thank you for all you're help.

Procurve 2824
ip default-gateway 10.16.128.20
ip routing

vlan1
name "DEFAULT_VLAN"
untagged 2-24
ip address 147.109.24.16 255.255.255.0
tagged 1 {port connecting 2524 via cat5}
exit

vlan10
name "10DOT"
ip address 10.16.128.20 255.255.254.0
ip helper-address 147.109.24.6
tagged 1 {port connecting 2524 via cat5}
exit

Procurve 2524
ip default-gateway 10.16.128.20

vlan1
name "DEFAULT_VLAN"
untagged 7-26
IP address 147.109.24.17 255.255.255.0
tagged 1 {port connecting 2824 via cat5}
no untagged 2-6
exit

vlan10
name "10DOT"
untagged 2-6
ip address 10.16.128.18 255.255.254.0
tagged 1 {port connecting 2824 via cat5}
exit

Static IP for the client is and can ping 147.109.24.6 DC

IP 10.16.128.101
SN 255.255.254.0
GW 10.16.128.20
DNS 147.109.24.6 (DC)

DC/DHCP server is in 2824 default vlan

Scopes 147.109.24.0 and 10.16.128.0
10.16.128.0 scope option gw 10.16.128.20