Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

IP routing on switch 5304xl

IP routing on switch 53
Occasional Advisor

IP routing on switch 5304xl

Ip routing Help:

I have a network configured as the above schematic. My net has 2 Procurve 5304xl switches, the VLAN10 is where domain clients are connected. The VLAN140 is where the internet provider is connected through a Proxy server (kerio Winroute Firewall). Intenet up to now is working without any problem.
I have the necessity to connect a remote Network, through a HDSL Modem to our Lan. I created a new VLAN13 where I connected my modem.
My questions are:
1) Is it possible to create a Ip routing table inside the switch to let the services (Internet and Remote network) available for my clients?
2) If yes, how I can set the table?

I do not need the remote lan clients to share my services.
As soon as I am not so familiar with this kind of configuration I kindly request to be patient with my request.

I am looking forward to hear from you soon.

Fabio Fiacco.
21 REPLIES
RicN
Valued Contributor

Re: IP routing on switch 5304xl


Hello Ip routing on switch 5304xl! :)

Since we do not know how your configuration files look like it is difficult to know if you have done any of the steps, but basicly you would have to do two/three things.

1. Choose one the 5304-switches as the "router". Attach an ip-address on each VLAN if not done.

2. Enable ip routing with the command "ip routing". The routing table will be automaticly created for all directly connected networks.

3. (Possible) If not done, make sure all clients on the VLANs has default gateway to the switch/routers ip address on the different vlans.
IP routing on switch 53
Occasional Advisor

Re: IP routing on switch 5304xl

Thanks rikn for your answer.To be more clear I attached a word file about my configuration.If you can see it and send me more details I appreciate.
RicN
Valued Contributor

Re: IP routing on switch 5304xl


Hello, I saw your document earlier and it was very good. However it would also be very nice to see your running-configuration on your switches to see how they are configured at the moment.

cenk sasmaztin
Honored Contributor

Re: IP routing on switch 5304xl

hi Fabio please send me sh run print both switch
cenk

IP routing on switch 53
Occasional Advisor

Re: IP routing on switch 5304xl

here is the switch configuration.Thanks
RicN
Valued Contributor

Re: IP routing on switch 5304xl


Hello,

could you please also attach the output from the command:

show running-config

from both switches, so that we could see the whole configuration, like ip routing enabled or not, default gateways, ip addresses on vlan interfaces and similar.
IP routing on switch 53
Occasional Advisor

Re: IP routing on switch 5304xl

Running configuration:
; J4850A Configuration Editor; Created on release #E.11.03
hostname "Hangar_8"
time timezone 60
module 2 type J4820A
module 1 type J4878A
module 3 type J4820A
interface B2
no lacp
exit
interface B5
no lacp
exit
interface B6
no lacp
exit
interface B8
no lacp
exit
interface B11
no lacp
-- MORE --, next page: Space, next line: Enter, quit: Control-C
cenk sasmaztin
Honored Contributor

Re: IP routing on switch 5304xl

no Fabio I want see all sh run print config each switch
cenk

IP routing on switch 53
Occasional Advisor

Re: IP routing on switch 5304xl

Sorry again .In the attachment there is the right show running config.FABIO
cenk sasmaztin
Honored Contributor

Re: IP routing on switch 5304xl

fabio please send me both switches sh run print
cenk

IP routing on switch 53
Occasional Advisor

Re: IP routing on switch 5304xl

Hi, I posted my new configuration, I mean I need to configure my Lan as in the new schematic. You will find in the attached that I need to filter my remote LAN through a Proxy Server withw Kerio Winroute firewall.
You will find all running configuratino for both my switches.

Thank you Fabio.
cenk sasmaztin
Honored Contributor

Re: IP routing on switch 5304xl

hostname "Hangar_8" (switch A)
ip routing
vlan 1
name "DEFAULT_VLAN"------[for managemet]
untagged A1-A3
ip address 10.0.0.1 255.255.255.0
no untagged B1-B24,C1-C24
exit
vlan 10
name "VLAN10"------------[for local user]
untagged B1-B22,C1-C24connect ibm server B1 (domain controller-192.168.10.11/24 default gateway 192.168.10.4- all other network users must be same default gateway)
ip address 192.168.10.4 255.255.255.0
tagged A1
exit
vlan 200
name "VLAN200"-----------[for x ]
untagged B23
ip address 192.168.11.4 255.255.255.0
tagged A1
exit
vlan 140-----------------[for internet]
name "VLAN140"
untagged B24 connect firewall for internet firewall lan ip must be 192.168.12.1/24
ip addess 192.168.12.4 255.255.255.0
tagged A1
vlan 160-----------------[for other lan]
name "VLAN160"
untagged A4 connect firewall for other lan firewall lan ip must be 192.168.13.1/24
ip addess 192.168.13.4 255.255.255.0

ip route 0.0.0.0 0.0.0.0 192.168.12.1
ip route 10.24.13.0 255.255.224.0 192.168.13.1

exit

--------------------------------------------------------------
--------------------------------------------------------------
hostname "Com_14" (switch B)

exit


vlan 1
name "DEFAULT_VLAN"---------[for managemet]
untagged A1,A3-A4,B3-B4
ip address 10.0.0.2 255.255.255.0
no untagged A2,B1-B2,C1-C24,D1-D24
exit
vlan 10--------------------[for local user]
name "VLAN10"
untagged B1-B2,C1-C24,D1-D24 connect domain users [in network 192.168.10.0 and default gateway must be 192.168.10.4]
tagged A1
exit
vlan 200--------------------[for x ]
name "VLAN200"
tagged A1
exit
spanning-tree
password manager
password operator
-------------------------------------------------------------
-------------------------------------------------------------
Kerio winroute firewall config (for internet)
connect B24

lan interface ip address 192.168.12.1/24
ip route 192.168.10.0 255.255.255.0 192.168.10.4



Kerio winroute firewall config (for other lan)
connect A4

lan interface ip address 192.168.13.1/24
ip route 192.168.10.0 255.255.255.0 192.168.13.4

cenk

IP routing on switch 53
Occasional Advisor

Re: IP routing on switch 5304xl

Thank you for your help, but I still have a small problem.
I have set the configuration you sent to me but as soon as I set the second command ip route(10.24.13.0 255.255.224.0 192.168.13.1) I got the following error:
"inconsistent address and mask".
Do you have any suggestion for us?

Thank's a lot Fabio.
cenk sasmaztin
Honored Contributor

Re: IP routing on switch 5304xl

ok fabio

you write this routing command

ip route 10.24.13.0 255.0.0.0 192.168.13.1
cenk

IP routing on switch 53
Occasional Advisor

Re: IP routing on switch 5304xl

I got the same error,
"inconsistent address or mask"

Fabio
cenk sasmaztin
Honored Contributor

Re: IP routing on switch 5304xl

please re test

ProCurve Switch 2626(config)# ip route 10.24.13.0 255.255.255.0 192.168.11.3
ProCurve Switch 2626(config)#
cenk

cenk sasmaztin
Honored Contributor

Re: IP routing on switch 5304xl


sory
roCurve Switch 2626(config)# ip route 10.24.13.0 255.255.255.0 192.168.13.1
ProCurve Switch 2626(config)#
cenk

cenk sasmaztin
Honored Contributor

Re: IP routing on switch 5304xl

or you can use

ProCurve Switch 2626(config)# ip route 10.24.0.0 255.255.0.0 192.168.13.1
ProCurve Switch 2626(config)#
cenk

cenk sasmaztin
Honored Contributor

Re: IP routing on switch 5304xl

hi Fabio sory my office this day very busy
below onfig include new route entry


hostname "Hangar_8" (switch A)
ip routing
vlan 1
name "DEFAULT_VLAN"------[for managemet]
untagged A1-A3
ip address 10.0.0.1 255.255.255.0
no untagged B1-B24,C1-C24
exit
vlan 10
name "VLAN10"------------[for local user]
untagged B1-B22,C1-C24connect ibm server B1 (domain controller-192.168.10.11/24 default gateway 192.168.10.4- all other network users must be same default gateway)
ip address 192.168.10.4 255.255.255.0
tagged A1
exit
vlan 200
name "VLAN200"-----------[for x ]
untagged B23
ip address 192.168.11.4 255.255.255.0
tagged A1
exit
vlan 140-----------------[for internet]
name "VLAN140"
untagged B24 connect firewall for internet firewall lan ip must be 192.168.12.1/24
ip addess 192.168.12.4 255.255.255.0
tagged A1
vlan 160-----------------[for other lan]
name "VLAN160"
untagged A4 connect firewall for other lan firewall lan ip must be 192.168.13.1/24
ip addess 192.168.13.4 255.255.255.0

ip route 0.0.0.0 0.0.0.0 192.168.12.1
ip route 10.24.0.0 255.255.0.0 192.168.13.1

exit

--------------------------------------------------------------
--------------------------------------------------------------
hostname "Com_14" (switch B)

exit


vlan 1
name "DEFAULT_VLAN"---------[for managemet]
untagged A1,A3-A4,B3-B4
ip address 10.0.0.2 255.255.255.0
no untagged A2,B1-B2,C1-C24,D1-D24
exit
vlan 10--------------------[for local user]
name "VLAN10"
untagged B1-B2,C1-C24,D1-D24 connect domain users [in network 192.168.10.0 and default gateway must be 192.168.10.4]
tagged A1
exit
vlan 200--------------------[for x ]
name "VLAN200"
tagged A1
exit
spanning-tree
password manager
password operator
-------------------------------------------------------------
-------------------------------------------------------------
Kerio winroute firewall config (for internet)
connect B24

lan interface ip address 192.168.12.1/24
ip route 192.168.10.0 255.255.255.0 192.168.12.4



Kerio winroute firewall config (for other lan)
connect A4

lan interface ip address 192.168.13.1/24
ip route 192.168.10.0 255.255.255.0 192.168.13.4
cenk

IP routing on switch 53
Occasional Advisor

Re: IP routing on switch 5304xl

Thank's again, I don't want to waste your time again but is working fine up to the last ip route configuration:
as soon as I try to set ip route 192.168.10.0 255.255.255.0 192.168.12.4 or 13.4 I get the following error:
192.168.12.4 or 13.4 "can not be switch IP address and route gateway at the same time".

Without this route set if from a client with gateway set at 192.168.10.4 I ping 192.168.13.1 works, but do not go find any client.

Thanks again Fabio
cenk sasmaztin
Honored Contributor

Re: IP routing on switch 5304xl

hi Fabio you must be this ip route command on Kerio winroute firewall device

----------------------------------------------------------------------------
Kerio winroute firewall config (for internet)
connect B24

lan interface ip address 192.168.12.1/24
ip route 192.168.10.0 255.255.255.0 192.168.12.4



Kerio winroute firewall config (for other lan)
connect A4

lan interface ip address 192.168.13.1/24
ip route 192.168.10.0 255.255.255.0 192.168.13.4



you must be this ip route command on switch A
------------------------------------------------------------------------------
ip route 0.0.0.0 0.0.0.0 192.168.12.1
ip route 10.24.0.0 255.255.0.0 192.168.13.1


please you examine carefull my config
cenk