Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Im still having problem re: SNMP Security Access Violation

SOLVED
Go to solution
homer_8
Occasional Advisor

Im still having problem re: SNMP Security Access Violation

Although we could turn off the SNMP warning mesg on the logs we really didnt solve the problem... still the same problem exist our Tivoli server as well as Cisco Works server is still sending this SNMP warning to the switch. We do also have an HP Top Tool PC monitoring our network... but unlike the other 2, HP top tools is not sending any snmp warning (compatibility??? i guess).
I noticed that when i deleted the community name public - HP Top Tools, Cisco works & Tivoli sends this snmp warning, and then after i restored it back only the Cisco & Tivoli are sending this SNMP Warning Msg...

Do u think it has something to do with SNMP version? Ver2c, Ver1 or Ver3...
wherein HP TopTool is Ver2c/1 and that is why when i deleted the public community TopTools also sends a warning?

And even we deleted and restored the public community Tivoli & Cisco Works still sends this SNMP warning?? (Ver3 or higher if there is??)

Weve already updated HP4108 to its latest firmware.

Thanks hope somebody could help us solving this in details...

Many Thanks in advance..


6 REPLIES
homer_8
Occasional Advisor

Re: Im still having problem re: SNMP Security Access Violation

* BUMP *
Anyone???
Mohamed Hamedi
Respected Contributor

Re: Im still having problem re: SNMP Security Access Violation

Well when you remove the public community name you will get the security violation trap, which is a standard and expected behavior.
In the V3 situation, maybe it is worth manually checking that you have the correct V3 authentication (user/passwd) setup to talk to the device, as failing authentication will cause that trap to be sent.
Another reason this might happen is if youâ ve upgraded across major releases, say from G_6â ¦ to G_7â ¦, you will need to reload your configurati
Laurie Gellatly
Honored Contributor
Solution

Re: Im still having problem re: SNMP Security Access Violation

sounds like tivoli and Cisco do not have the
correct snmp community string in them for this
switch. You can check this on tivoli by doing
snmpwalk switchIP system
if it does not respond the community string
needs to be configured.
If you do
snmpwalk -c public switchIP system
it should work.
(switchIP is the IP address of the switch).
If this proves to be the case then the Tivoli
and Cisco admin people need to configure
their software OR you need to add the "right"
community string to the swtich. Either way,
once they all agree on the community string
the problem should disappear.

HTH ...Laurie :{)
If you're not using OverTime, you're doing overtime!
homer_8
Occasional Advisor

Re: Im still having problem re: SNMP Security Access Violation

Thanks for your reply guys... im not that familiar regarding snmpwalk but i did try some programs like GETIF wherein i could identify the management server that is giving this SNMP warning logs, its SNMP parameters (community name) are also set to public thats why i could get the servers data. Thus the server is also set to the public community same as our procurve config default at public.??
Or do i have to use an snmpwalk at the server itself? Do i have to check the servers community string even if i had check it w/ GETIF??

Thanks again hope u could help me
Laurie Gellatly
Honored Contributor

Re: Im still having problem re: SNMP Security Access Violation

Its better to do the snmpwalk from the server
as the community strings setting can be
misleading. By doing the walk you exercise
the server to lookup and use the string it
thinks is correct. If the snmpwalk fails
then the community strings need to be
adjusted in that application.
try:
snmpwalk x.x.x.x system
and then
snmpwalk -c public x.x.x.x system
If the first fails while the second works
you definately have string probelms.


...Laurie :{)
If you're not using OverTime, you're doing overtime!
homer_8
Occasional Advisor

Re: Im still having problem re: SNMP Security Access Violation

Weve already check the server & yes weve found out that the global settings for SNMP community of the server was not set properly. Thanks for ur time and help.
Good day