Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Inter VLAN Routing - Cisco 1841 and HP2510

Usaia Tawakevou
Frequent Advisor

Inter VLAN Routing - Cisco 1841 and HP2510

I'm setting the above with the Cisco 1841 doing the inter VLAN routing. VLAN's has been created on the 2510 and subinterface on the router with encapsulation dot1Q. However it seems like it is not working as I couldnt even ping from the switch to the router or vice versa. Im using fastethernet 0/0 on the router and port 24 on the switch for the connection beetween the route rand the switch.Hope someone will help
Below is my configuration on the switch and the router:

HP2510
------
Running configuration:

; J9019A Configuration Editor; Created on release #Q.11.07

hostname "CEPACT-BLD-2"
snmp-server community "public" Unrestricted
vlan 1
name "MMGNT"
untagged 1-23,26
ip address 192.168.11.3 255.255.255.0
tagged 24-25
exit
vlan 2
name "SRV-PRT-CLNT"
no ip address
tagged 24-25
exit
vlan 3
name "VoIP"
no ip address
tagged 24-25
exit

Cisco 1841
--------------------

Current configuration : 1216 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ciscoCETC
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$eomE$7R.KO87o.hwjCOSrDWHGZ/
enable password spc
!
no aaa new-model
ip cef

!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3

!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
no mop enabled
!
interface FastEthernet0/0.1
description MMGNT
encapsulation dot1Q 1 native
ip address 192.168.11.1 255.255.255.0
!
interface FastEthernet0/0.2
description SRV-PRT-CLNT
encapsulation dot1Q 2
ip address 192.168.10.253 255.255.255.0
!
interface FastEthernet0/0.3
description VoIP
encapsulation dot1Q 3
ip address 192.168.62.1 255.255.255.0
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
description LINK TO NABUA - 168350
ip address 192.168.1.6 255.255.255.252
clock rate 2000000
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
snmp-server community public RO
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
password spc
login
!
scheduler allocate 20000 1000
end

4 REPLIES
Shadow13
Respected Contributor

Re: Inter VLAN Routing - Cisco 1841 and HP2510

You don't need to tag the ports in the native vlan which is vlan 1

untag the ports (24,25) in vlan 1 and see if that works.

Regards
Usaia Tawakevou
Frequent Advisor

Re: Inter VLAN Routing - Cisco 1841 and HP2510

Thank you I manage to figure it out. Here is what I did it:

Router
-------
interface FastEthernet0/0
description MMGNT
ip address 192.168.11.1 255.255.255.0
ip helper-address 192.168.10.3
ip nbar protocol-discovery
ip route-cache flow
duplex auto
speed auto
!
interface FastEthernet0/0.1
description SRV-PRT-CLNT
encapsulation dot1Q 2
ip address 192.168.10.253 255.255.255.0
ip helper-address 192.168.10.3
!
interface FastEthernet0/0.2
description VoIP
encapsulation dot1Q 3
ip address 192.168.62.1 255.255.255.0
ip helper-address 192.168.10.3

Switch
------
Running configuration:

; J9019A Configuration Editor; Created on release #Q.11.07

hostname "CETC-OFFICE"
interface 25
speed-duplex 1000-full
exit
ip default-gateway 192.168.11.1
snmp-server community "public" Unrestricted
vlan 1
name "MMGNT"
untagged 24
ip address 192.168.11.3 255.255.255.0
tagged 25-26
no untagged 1-23
exit
vlan 2
name "SRV-PRT-CLNT"
untagged 1-23
no ip address
tagged 24-26
exit
vlan 3
name "VoIP"
no ip address
tagged 24-26
voice
exit
management-vlan 1
--------------------------------------------
Can someone explained why I have to untagged port 24 on VLAN 1 and tagged it on the other 2 VLAn's ? Port 24 is where the router fastethernet is connected to

Thanks


Shadow13
Respected Contributor

Re: Inter VLAN Routing - Cisco 1841 and HP2510

the Natice VLAN (vlan 1) is always passed without 802.1Q tag in any trunk port(uplink port) between 2 devices.

Regards
Usaia Tawakevou
Frequent Advisor

Re: Inter VLAN Routing - Cisco 1841 and HP2510

Thanks for the reply. All sorted

Once again thank you