Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Inter Vlan with 2 ports in a trunk

Fullsuporte RR
Occasional Contributor

Inter Vlan with 2 ports in a trunk

Hi.
I'm with a problem with a trunk (2 ports group) between a HP 5406zl and a Cisco 2950.
The trunk is OK, but i don't know ou to inter connect two different Vlans in this trunk.
I know that if i didn't had a trunk, in 5400 i just would need a sub-int but don't know how to do it if i have a trunk with more than 1 port interconnecting two switch's.

Cisco Config:
version 12.1
...
!
interface Port-channel1
switchport mode trunk
!
...
!
interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode on
!
interface GigabitEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode on
!
interface Vlan1
ip address 192.168.99.201 255.255.255.0
ip helper-address 192.168.1.100
no ip route-cache
!
...
!
ip default-gateway 192.168.99.254
!

HP 5406zl (Core Switch) Config:
module 1 type J8705A
module 2 type J8705A
module 3 type J8705A
trunk A21-A22 Trk1 LACP
...
ip routing
timesync sntp
sntp unicast
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged Trk1-Trk8
ip helper-address 192.168.1.100
ip address 192.168.99.254 255.255.255.0
no untagged A1-A16,A18,A20,B1-B16,B18,B20,C1-C20
exit
...
spanning-tree
spanning-tree Trk1 priority 4
...

Can anybody give me some light? Thank you.
1 REPLY
Ian Vaughan
HPE Blogger

Re: Inter Vlan with 2 ports in a trunk

Howdy,
On the procurve you need to create your second VLAN, if you haven't already, and put TRK1 onto it as a "tagged" port. So on Procurve you put interfaces onto VLANs as either tagged or untagged.

On the Cisco end it kinda works the opposite way around as you put vlans onto interfaces. You don't currently have any restriction with a VLAN "allowed" list ( # sw mo trunk allowed vlan X, Y, Z ) on your interfaces so by default all VLANs will try and speak across the link. If your second VLAN doesn't already exist you will need to create it.
You can nail your aggregated link to LACP by setting the (channel-protocol lacp)and use mode active (channel-group 1 mode active).

Whenever I am combining Cisco & HP I standardise on MSTP for my spanning tree and make sure that I set STP priorities so that I know where the root and secondary bridges are going to be in my topology. It's just too painful otherwise, I have had customers whose root bridge has been a tiny cheap switch used for printers on the edge of their network because they assumed "it would just work".

There are loads of docs available:
http://h10147.www1.hp.com/docs/security/Migrating_from_Cisco_to_ProCurve_Apr_08_AM_Eng_Ltr.pdf
and some WBT on the HP site if you look hard enough.

Cheers
Ian
Hope that helps - please click "Thumbs up" for Kudos if it does
## ---------------------------------------------------------------------------##
Which is the only cheese that is made backwards?
Edam!
Tweets: @2techie4me