Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Interconnecting Vlan on HP procurve 4204vl using static route

SOLVED
Go to solution
jamalator
Occasional Advisor

Interconnecting Vlan on HP procurve 4204vl using static route

Hi

Iam having a little problem connecting my vlans to a single vlan. The thing is i have vlan3(192.168.3.0) that is connected to the internet and i have 3 other Vlan on my switch
vlan4(192.168.4.0),
vlan5(192.168.5.0),
vlan6(192.168.6.0).
I want to use static route to interconnect vlan4,5,6===>vlan3; so vlan4,5,6 can connect to internet.
An other thing i have a single DHCP who distribute ip addresses to all my vlans.
i have on my L3 4204vl(192.168.1.1)
route 0.0.0.0 0.0.0.0 192.168.1.254
on my dhcp(192.168.1.254) a router that have static routes like this:
route 192.168.4.0 255.255.255.0 192.168.1.1
route 192.168.5.0 255.255.255.0 192.168.1.1
route 192.168.6.0 255.255.255.0 192.168.1.1

My vlan3 is connected to internet using his gatway 192.168.3.254. How can i use static route to get internet vlan4,5,6===>vlan3 ???

Thank you in advance

8 REPLIES
cenk sasmaztin
Honored Contributor
Solution

Re: Interconnecting Vlan on HP procurve 4204vl using static route

hi
I want to use static route to interconnect vlan4,5,6===>vlan3; so vlan4,5,6 can connect to internet.
*******************************************
no need static route for inter vlan routing

must be enable ip route on switch
with <(config)#ip routing >comand
in this way routing between vlan

for all vlan connect to internet you can must be write static route command on switch and internet router

for example
your internet router ip address 192.168.3.254

you write ip route command on switch to internet router
0.0.0.0 0.0.0.0 192.168.3.254 and connect vlan 3 untag port

and you write ip route command on internet router to your LAN
192.168.0.0 255.255.0.0 192.168.3.1 (3.1 vlan 3 ip address)
in this way all vlan between routing and reach internet

An other thing i have a single DHCP who distribute ip addresses to all my vlans.
*****************************************
yes it is possible

create in vlan 3 dhcp server
connect vlan 3 untag port this server

for example microsfot 2003 server and assign ip address 192.168.3.10 dhcp server ip address
dhcp server subnet mask 255.255.255.0,default gateway address 192.168.3.1
create scobes on server

scobe vlan 3
ip range 192.168.3.20----192.168.3.200
subnet mask 255.255.255.0
default route 192.168.3.1 (vlan 3 ip address)

scobe vlan 4
ip range 192.168.4.20----192.168.4.200
subnet mask 255.255.255.0
default route 192.168.4.1 (vlan 4 ip address)

scobe vlan 5
ip range 192.168.5.20----192.168.5.200
subnet mask 255.255.255.0
default route 192.168.5.1 (vlan 5 ip address

scobe vlan 6
ip range 192.168.6.20----192.168.6.200
subnet mask 255.255.255.0
default route 192.168.6.1 (vlan 6 ip address

and asign each vlan ip helper address command for dhcp frame

in vlan 4
ip-helper address 192.168.3.10
in vlan 5
ip-helper address 192.168.3.10
in vlan 6
ip-helper address 192.168.3.10

**************************************
static client ip address config

vlan 3 member client ip address config
ip address 192.168.3.21
subnet mask 255.255.255.0
default gateway 192.168.3.1

vlan 4 member client ip address config
ip address 192.168.4.21
subnet mask 255.255.255.0
default gateway 192.168.4.1

each vlan member client default gateway address must be vlan ip address

may it be easy



cenk

jamalator
Occasional Advisor

Re: Interconnecting Vlan on HP procurve 4204vl using static route

Hi and thank you for your quick response. My internet is not on 192.168.1.254 but on vlan 3 look at the attach jpeg architecture for more details. I already have the dhcp working well, i just want to get throw form VLAN 2 and 4 to VLAN 3 (INTERNET)

Thanks Again for your help :)
cenk sasmaztin
Honored Contributor

Re: Interconnecting Vlan on HP procurve 4204vl using static route

please be carefully read my advice

you write ip route command on switch to internet router
0.0.0.0 0.0.0.0 192.168.3.254*** and connect vlan 3 untag port

and you write ip route command on internet router to your LAN
192.168.0.0 255.255.0.0 192.168.3.1 (3.1 vlan 3 ip address)
in this way all vlan between routing and reach internet
cenk

cenk sasmaztin
Honored Contributor

Re: Interconnecting Vlan on HP procurve 4204vl using static route

please see attach
cenk

cenk sasmaztin
Honored Contributor

Re: Interconnecting Vlan on HP procurve 4204vl using static route

please send me sh run print your switch
cenk

jamalator
Occasional Advisor

Re: Interconnecting Vlan on HP procurve 4204vl using static route

This is my configuration, the thing is this configuration works for all my vlan getting dhcp request

===========================================
ProCurve Switch 4204vl# show running-config

Running configuration:

; J8770A Configuration Editor; Created on release #L.10.23

hostname "ProCurve Switch 4204vl"
max-vlans 25
module 1 type J8768A
module 2 type J9033A
ip default-gateway 192.168.1.253
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "services"
untagged A2-A24,B3-B17,B19-B24
ip address 192.168.1.1 255.255.255.0
no untagged A1,B1-B2,B18
exit
vlan 2
name "atlas"
untagged B1-B2
ip address 192.168.2.1 255.255.255.0
ip helper-address 192.168.1.254
tagged A1
exit
vlan 3
name "adarr"
untagged B3-B4
ip address 172.16.3.1 255.255.255.0
ip helper-address 192.168.1.254
tagged A1
exit
vlan 4
name "badr"
untagged B4-B6
ip address 172.16.4.1 255.255.255.0
ip helper-address 192.168.1.254
tagged A1
exit
ip route 0.0.0.0 0.0.0.0 192.168.1.254
dhcp-snooping
dhcp-snooping authorized-server 192.168.1.254
dhcp-snooping vlan 1-121
interface B16
dhcp-snooping trust
exit
password manager
password operator
====================================

Thanks a lot
jamalator
Occasional Advisor

Re: Interconnecting Vlan on HP procurve 4204vl using static route

Hi cenk,

I corrected the route you gave me. the dhcp is still working. I forgot to mention on my illustration that all all my vlan have ip helper adress 192.168.1.254.
The route are::
ip route 192.168.0.0 255.255.0.0 192.168.3.2
192.168.3.1 refused to set, it says that can not be a gatway and a switch ip.
and ip route 0.0.0.0 0.0.0.0 192.168.3.254
intead of
ip route 0.0.0.0 0.0.0.0 192.168.1.254.
And form the vlan 4 (192.168.4.1/24 gat 192.168.4.254) i tried to ping VLAN 3 and NOTHING


cenk sasmaztin
Honored Contributor

Re: Interconnecting Vlan on HP procurve 4204vl using static route

please read be carefully

static client ip address config

vlan 3 member client ip address config
ip address 192.168.3.21
subnet mask 255.255.255.0
default gateway 192.168.3.1***************

vlan 4 member client ip address config
ip address 192.168.4.21
subnet mask 255.255.255.0
default gateway 192.168.4.1***************

each vlan member client default gateway address must be vlan ip address

may it be easy
cenk