Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Issues with 2 x HP GbE2c and integration into a Cisco 3750

Selman Haxhijaha
Occasional Advisor

Issues with 2 x HP GbE2c and integration into a Cisco 3750

Recently we purchased GbE2c L2/L3 Ethernet Blade Switch for HP c-Class BladeSystem (2Pcs), and as for now Iâ m trying to put in network the first blade. Iâ m referring to Straight-Trough topology 3 from White paper document, with few changes, I did disable interconnecting port 17 and 18 to prevent loops between switches and I have more than 1 Vlan created. Both switches are connected with 2 Cisco Catalyst 3750 aggregate switches. The first trunk between SwA and Cisco 3750 works fine, it carries all the Vlans , but when Iâ m trying to put in place the Switch B of the blade and interconnect it with the other Cisco 3750, it does not activate the port at all. I tried to disable the STG but same issue appears. Any help provided will be appreciated.

Here is the config from Cisco also and you will find attached config from GbE2c_SW_A and GbE2c_SW_B.

interface GigabitEthernet1/0/2
description Uplink to HP_SW_A
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
end
interface GigabitEthernet1/0/2
description Uplink to HP_SW_B
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
end
This is the scenario which will take place in our infrastructure. As for now we are connecting only 1 blade.
Thank you,
14 REPLIES
Sudain
Advisor

Re: Issues with 2 x HP GbE2c and integration into a Cisco 3750

I'm not the best with the blades Gbe2c blades but let's see what we can do. :)

My first suggestion would be to disable STP for now. You can work on getting that up later.

2. Doublecheck the vlans on each end of the cable for b - sounds silly but that's bitten me many times before.

3. To set vlans on Gbe2c switches you have to set the PVID(untagged) on the port to something. Then from there in the interface enable tagging on that port. Then any further vlans you add on that port will be tagged.

If that doesn't work let me know.
Selman Haxhijaha
Occasional Advisor

Re: Issues with 2 x HP GbE2c and integration into a Cisco 3750

Thanks for the quick reply. To clarify beter what is going on, let me send you dump configs from both switches. Do you think the version 2.0.0 may be the issue?
Thank you,
Pieter 't Hart
Honored Contributor

Re: Issues with 2 x HP GbE2c and integration into a Cisco 3750

did you check the cables?
is it straight or crossed?
should prefferably be crossed, but auto-mdi/mdix may correct this.

if you cross connections between GbE2c's and 3750's , does the problem stay with the same switch or move to the other switch ?
do this at the GbE2 side and at the 3750 side.
Selman Haxhijaha
Occasional Advisor

Re: Issues with 2 x HP GbE2c and integration into a Cisco 3750

I tried with cross cable and issue remains the same.
Also I tried on different port in GbE2c and Cisco 3750 and issue remains the same.
Last test was I did the upper steps on the second blade that we have and still having the issue.
On first switch port activating, but the issue is with the second switch on both blades.
Any suggestions?
Thank you
Pieter 't Hart
Honored Contributor

Re: Issues with 2 x HP GbE2c and integration into a Cisco 3750

"Last test was I did the upper steps on the second blade that we have and still having the issue"

maybe I did not understand the question correctly.
- do you have problem with the connection from the blade to the second GbE2 switch?
- or from the second GbE2 switch to the second 3750?

In the first case, you may have teaming configured so that only one port is active?

In the second case adding a blade does not change the communication between the GbE2 switch and the 3750!
link state should be up even without blades connected!
In this case whats the output of "show interface status" and "show interface Gig1/0/2" on the 3750?
Selman Haxhijaha
Occasional Advisor

Re: Issues with 2 x HP GbE2c and integration into a Cisco 3750

I'm having problems with connection from the second GbE2c to second 3750. The port is not turning up at all. Attached is the output from 3750.
Thank you,
Pieter 't Hart
Honored Contributor

Re: Issues with 2 x HP GbE2c and integration into a Cisco 3750

I see you are using a multispeed copper SFP module.
Gi1/0/2 Uplink to HP_SW_B notconnect unassigned auto auto 10/100/1000BaseTX SFP.
(check SFP's are same type)

there is a small difference in the port 21 configs
> /c/port 21/gig
> fctl both

>/c/port 21/gig
> fctl none

This adresses flow-control, but maybe the handshake with the SFP fails because of this.

Your crossed cables are 8-wire?
Selman Haxhijaha
Occasional Advisor

Re: Issues with 2 x HP GbE2c and integration into a Cisco 3750

SFP's are same type, the same type works fine between GbE2c_SWA with 3750.
I also turn off the fctl to none, but the iport does not turn up.
Cross cables are 8 wires, in interconnection between GbE2c_SWA and 3750 I use straigh thru cable and it works fine. The same config is on GbE2c_SW_B and 3750.
Pieter 't Hart
Honored Contributor

Re: Issues with 2 x HP GbE2c and integration into a Cisco 3750

I'm still a bit uncertain about your configuration.

when I match your statement
"I did the upper steps on the second blade that we have"
with the picture in the first post, I think you mean here a second blade-enclosure with two GbE switches?
Not just a second blade (-server)?

If so
- connect one blade-chassis SW_B to the second 3750 only=> whats behaviour?
- connect the same blade-chassis SW_B to the first 3750 only (where normally SW_A should be connected) => whats behaviour?

can you post full configs of 3750's
Selman Haxhijaha
Occasional Advisor

Re: Issues with 2 x HP GbE2c and integration into a Cisco 3750

I have 2 blade-enclosures with two Gbe switches. But for now I'm trying to put in place only 1 blade-enclosure, like in the picture.
I already did before the steps mantionet from you:
- connect one blade-chassis SW_B to the second 3750 only=> whats behaviour?
- connect the same blade-chassis SW_B to the first 3750 only (where normally SW_A should be connected) => whats behaviour?
It still does not activate the port.
I also tried to reconfigure another port just to see if the porti is bad, but no changes.
Configs from two catalyst 3750 are same. I have no doubt on Catalyst 3750 configuration.
Pieter 't Hart
Honored Contributor

Re: Issues with 2 x HP GbE2c and integration into a Cisco 3750

so from the combinations
SW_A -> 3750-1 == OK
SW_B -> 3750-2 == notOK
SW_B -> 3750-1 == notOK
SW_A -> 3750-2 == ?? (no info in your posts)

focus lies on SW_B

in risk of asking something obvious,
- after making changes on the second GbE2 did you "apply" the changes?
- you are sure you've disabled the interconnecting ports 17 en 18?
on both switches?

If you
- erase the config of SW_B
"/maint/debug -> clrcfg"
- load SW_A config in SW_B
- disconnect SW_A (you may go as far as to remove from chassis)
- connect SW_B in place of SW_A
if still no good SW_B maybe defekt (config error not likely)
Pieter 't Hart
Honored Contributor

Re: Issues with 2 x HP GbE2c and integration into a Cisco 3750

one other think, do you count the ports correctly?
port-21 is for both switches top right, it's not a symetrical setup.
see attached.

As for my suggestion to swap the switches physically, you could also try to swap only the interconnect modules first.
Selman Haxhijaha
Occasional Advisor

Re: Issues with 2 x HP GbE2c and integration into a Cisco 3750

After many days spent on this issue, finally I found out something interesting. SirWin was right, firmware is old and may be a bug. When i go via CLI to enable the port, it will remain as disabled. I went thru Onboard Administrator and via BBI to enable the port, the changes took effect immediately. I did this several times and got same results.
Thanks everybody on a help provided.
Selman Haxhijaha
Occasional Advisor

Re: Issues with 2 x HP GbE2c and integration into a Cisco 3750

If the port does not turn on via CLI, use BBI to enable it, I gues it is a bug of firmware version 2.0.0.