Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

LACP will not enable

Mike Waterhouse
Occasional Visitor

LACP will not enable

We are trying to setup an LACP trunk (active) between four ports (0/19-22) on a cisco catalyst 3650 switch and four ports (21-24) on a HP GbE2c Blade switch.

We have placed the following config on the cisco,


--------------------------SNIP------------------------
!
port-channel load-balance src-dst-ip
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface Port-channel15
switchport access vlan 10
switchport trunk encapsulation dot1q
switchport mode access
!
interface GigabitEthernet0/1
switchport access vlan 10
switchport mode access
!

--------------------------SNIP------------------------
!
interface GigabitEthernet0/18
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet0/19
switchport access vlan 10
switchport trunk encapsulation dot1q
switchport mode access
channel-group 15 mode active
!
interface GigabitEthernet0/20
switchport access vlan 10
switchport trunk encapsulation dot1q
switchport mode access
channel-group 15 mode active
!
interface GigabitEthernet0/21
switchport access vlan 10
switchport trunk encapsulation dot1q
switchport mode access
channel-group 15 mode active
!
interface GigabitEthernet0/22
switchport access vlan 10
switchport trunk encapsulation dot1q
switchport mode access
channel-group 15 mode active
!
interface GigabitEthernet0/23
switchport access vlan 10
switchport mode access
!

--------------------------SNIP------------------------

Where VLAN 10 is our production network

On the HP I have simply gone into the web interface and enabled LACP Active via. Config->Layer2->LACP on ports 21-24.

I plugged in the four ethernet cables and the cisco shows port 19 active but the others (20, 21 and 22) disabled (presumaby error disabled)

Anyone any ideas what Im doing wrong?

Thanks very much in advance for any replies!
4 REPLIES
Evert Goor
Trusted Contributor

Re: LACP will not enable

can you put the output of the cli command

"/info/l2/lacp/dump"

on the forum.
Mike Waterhouse
Occasional Visitor

Re: LACP will not enable

Hi,

Thanks v much for taking the time to reply,




port lacp adminkey operkey selected prio attached trunk
aggr
----------------------------------------------------------------------
1 active 1 1 n 32768 -- --
2 active 2 2 n 32768 -- --
3 active 3 3 n 32768 -- --
4 active 4 4 n 32768 -- --
5 active 5 5 n 32768 -- --
6 active 6 6 n 32768 -- --
7 active 7 7 n 32768 -- --
8 active 8 8 n 32768 -- --
9 active 9 9 n 32768 -- --
10 active 10 10 n 32768 -- --
11 active 11 11 n 32768 -- --
12 active 12 12 n 32768 -- --
13 active 13 13 n 32768 -- --
14 active 14 14 n 32768 -- --
15 active 15 15 n 32768 -- --
16 active 16 16 n 32768 -- --
17 active 17 17 n 32768 -- --
18 active 18 18 n 32768 -- --
19 off 19 19 n 32768 -- --
20 active 20 20 n 32768 -- --
21 active 21 21 y 32768 21 16
22 active 22 22 y 32768 22 14
23 active 23 23 y 32768 23 15
24 active 24 24 y 32768 24 13

>> LACP#

Cheers,
Evert Goor
Trusted Contributor

Re: LACP will not enable

the admin key is not equal.

From the nice manual :)

Configuring LACP
Use the following procedure to configure LACP for port 20 and port 21 to participate in link aggregation.
1. Set the LACP mode on port 20.
>> # /cfg/l2/lacp/port 20 (Select port 20)
>> LACP port 20# mode active (Set port 20 to LACP active mode)
2. Define the admin key on port 20. Only ports with the same admin key can form a LACP trunk group.
>> LACP port 20# adminkey 100 (Set port 20 adminkey to 100)
Current LACP port adminkey: 17
New pending LACP port adminkey: 100
3. Set the LACP mode on port 21.
>> # /cfg/l2/lacp/port 21 (Select port 21)
>> LACP port 21# mode active (Set port 21 to LACP active mode)
4. Define the admin key on port 21.
>> LACP port 21# adminkey 100 (Set port 21 adminkey to 100)
Current LACP port adminkey: 18
New pending LACP port adminkey: 100
5. Apply and verify the configuration.
>> LACP port 21# apply (Make your changes active)
>> LACP port 21# cur (View current trunking configuration)
6. Save your new configuration changes.
>> LACP port 21# save (Save for restore after reboot)

http://h20000.www2.hp.com/bc/docs/support/SupportManual/c00701973/c00701973.pdf

go to -> ports and trunking -> lacp -> Configuring LACP

Good luck
Mike Waterhouse
Occasional Visitor

Re: LACP will not enable

Thanks sooooo much for your reply... You hit the nail on the head. Sorry for wasting your time, I should have read the manual more thoroughly!