Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

LLDP strangeness

 
Occasional Visitor

LLDP strangeness

I have a network management help program (https://github.com/csikfer/lanview2). The program has a discovery feature that discovers switches (and other devices that support LLDP) and their connection based on LLDP. It also works with more or less success. But there is a phenomenon with which I do not know what to do. I mainly have HPE switches, and 19x0 models usually have the phenomenon that not only this switch is visible on the corresponding port of the neighbor, but also the HP APs connected to it, e.g.
HP 5406: F9 <-> 21: HPE 1920s: 1 <-> AP1
Then the HP 5406 switch F9 port will display the neighboring port of the HPE 1920s switch 21, but also the AP1 connected to port 1 of the HPE 1920s switch, or if more than one AP is connected, all of them. (Most APs are type MSM430).
Is this a feature or rather a bug? There may be some setting I don't know and disables this extra "feature".
Sorry for the poor wording, but I use Google Translate for lack of language skills.

3 REPLIES 3
HPE Pro

Re: LLDP strangeness

Hello, 

The 1920s switch supports LLDP. By default it should be enabled on all ports in receive and transmit mode. With this configuration the switch should consume an LLDP message and not flood it like a normal multicast. You can check in the GUI under LLDP ->Configuration if you have the default LLDP settings for all ports. If receive is disabled on the AP port the 1920S will not consume the frame but flood it instead

As far as I remember the MSM APs support CDP. However 1920S doesnt support CDP. It is not mentioned in the manual at all. That means that 1920S will probably handle CDP packets as unknown broadcast and flood it to the 5406.

The 5406 supports both LLDP and CDP. CDP is supported in rx mode only. You can test what happens if you disable CDP on the port which connects with you 1920S.

HP-Switch-5406Rzl2(config)# no cdp enable F9

DO you still see all the APs connected to the 1920S or only the switch itself?

I am an HPE employee

Accept or Kudo


Occasional Visitor

Re: LLDP strangeness

If I issue the "no cdp enable F9" command, the answer is "Module not present for port or invalid port: F9". And there is an F9 port. However, you accept the "no cdp enable all" command (version: K.16.02.0026).
Ports that are members of a trunk are still allowed by CDP. Not enabled on trunk ports. F9 is also a member of a trunk. I thought it was irrelevant, I didn’t want to complicate the description.
By the time I wrote the answer, the non-there items had disappeared from the LLDP list.
Thank you, this is the solution.

HPE Pro

Re: LLDP strangeness

Hello

Thanks for the response!

This confirms that the APs are sending CDP.

An alternate solution could be to disable CDP on the MSM APs. However it looks this is not possible when the APs are manager by a MSM7xx series controller. Controlled APs always send CDP information.

If the APs are standalone or a.k.a autonomous you can disable CDP in the webUI by going to Network ->Discovery Protocols.

Please mark the question as resolved if you dont have more questions!

 
I am an HPE employee

Accept or Kudo