Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Layer 3 between two 2510 and one 2910

SOLVED
Go to solution

Layer 3 between two 2510 and one 2910

I have one 2910 CSTEL configured as follow :

ProCurve 2910al-24G Switch#
exit

router rip
exit
interface loopback 0
ip address 192.168.2.105
exit
snmp-server community "public" unrestricted
vlan 100
ip rip 192.168.2.1
ip rip 192.168.2.1 receive v1-or-v2
ip rip 192.168.2.1 send v1-compatible-v2
exit
vlan 200
ip rip 192.168.3.1
ip rip 192.168.3.1 receive v1-or-v2
ip rip 192.168.3.1 send v1-compatible-v2
exit


And empty config on the 2510 .

What I had to configure on the 2510 to propagate the 2 different subnet and the VLAN ?

I guess there is no VTP service on HP

thanks
15 REPLIES
Natasha Samoylenko
Trusted Contributor

Re: Layer 3 between two 2510 and one 2910

On HP switches to propagate VLANs you can use GVRP protocol. GVRP functions is similar to VTP, but GVRP is a standards-based protocol.

GVRP can automatically assign switch-to-switch links to VLAN, but you need to assign edge (access) ports administratively to appropriate VLAN.

I don't exactly understand what you mean "to propagate the 2 different subnet"?

2510 is the layer 2 switch. So you can't use static or dynamic routing.

Re: Layer 3 between two 2510 and one 2910

Hi

thanks for the answer . As understood I came from Cisco world ...

How to configure the EDGE ( Access ) port ?
How to make comunication from the 2510 to the 2 different subnets ?

192.168.2.X /24
192.168.3.X /24

Can be both reacheable from 2510 ?
And how ?

Re: Layer 3 between two 2510 and one 2910

Hi

thanks for the answer . As understood I came from Cisco world ...

How to configure the EDGE ( Access ) port ?
How to make comunication from the 2510 to the 2 different subnets ( VLAN interface ) in the 2910 ?

192.168.2.X /24
192.168.3.X /24

Can be both reacheable from 2510 ?
And how ?
Natasha Samoylenko
Trusted Contributor

Re: Layer 3 between two 2510 and one 2910

On 2510 both subnets can be reacheable if you configure appropriate access ports on that subnets and switch-to-switch link as tagged in both VLANs.

On HP switches to configure access port you need to go to appropriate VLAN and add port.
For example, if port 5 need to be in VLAN 200 (in 192.168.3.0/24 subnet from your configuration):
(config)# vlan 200 untagged 5

To assign switch-to-switch link (for example, port 10) to both VLANs (like trunk on cisco switches):
(config)# vlan 200 tagged 10
(config)# vlan 100 tagged 10
Natasha Samoylenko
Trusted Contributor

Re: Layer 3 between two 2510 and one 2910

On procurve swithes there is no "interface vlan" object. Ip address configuration you can apply (like you did) in vlan.

If you need to route between vlan 100 and 200, you need:
1. ip routing enable,
2. ip addresses in vlan,
3. default gateway on hosts in 200 vlan -- ip address of vlan 200, on hosts in 100 vlan -- ip address of vlan 100.

Why you use rip v1-or-v2 and v1-compatible-v2? You really need this?

Re: Layer 3 between two 2510 and one 2910

Thanks Natasha

Will try and let you know .

Alberto

Re: Layer 3 between two 2510 and one 2910

Just answer tou your point :

If you need to route between vlan 100 and 200, you need:
( You mean on the 2910 ?? )

1. ip routing enable,

I have done

2. ip addresses in vlan,

I have put it

3. default gateway on hosts in 200 vlan -- ip address of vlan 200, on hosts in 100 vlan -- ip address of vlan 100.

Where I have to write the DG ? In the 2510 that point to 2910 ?


Thanks
Natasha Samoylenko
Trusted Contributor

Re: Layer 3 between two 2510 and one 2910

If you need to route between vlan 100 and 200, you need:
( You mean on the 2910 ?? )
--- Yes, on the 2910

3. default gateway on hosts in 200 vlan -- ip address of vlan 200, on hosts in 100 vlan -- ip address of vlan 100.

Where I have to write the DG ? In the 2510 that point to 2910 ?
--- You need to write DG in hosts.

For example, if host A is on 192.168.3.0/24 subnet:
ip address of host A: 192.168.3.100/24
DG of host A: 192.168.3.1 (ip address of vlan 200)
If host A is connected to 2510 port 5, you also need:
vlan 200 untagged 5

Re: Layer 3 between two 2510 and one 2910

Where I have to write the DG ? In the 2510 that point to 2910 ?
--- You need to write DG in hosts

Means I have to write in the IP CONFIG of the NIC CARD every DG ?

regard the helper address its the same like in CISCO ?
1. Choose the port where connect my DHCP SERVER and the write his ip helper address ?

GEAT THANKS
Natasha Samoylenko
Trusted Contributor
Solution

Re: Layer 3 between two 2510 and one 2910

Example of configuration (topology in attachement):
switch 2510 configuration:

vlan 100
untagged 3,4
tagged 21

vlan 200
untagged 1,2
tagged 21

switch 2910 configuration:
ip routing

vlan 100
ip address 192.168.2.1/24
tagged 22
ip helper-address 192.168.5.10

vlan 200
ip address 192.168.3.1/24
tagged 22
ip helper-address 192.168.5.10

vlan 500
name DHCP_server
ip address 192.168.5.1/24
untagged 10

======

Means I have to write in the IP CONFIG of the NIC CARD every DG ?

regard the helper address its the same like in CISCO ?
1. Choose the port where connect my DHCP SERVER and the write his ip helper address ?

--- If you use DHCP server to configure IP addresses on your hosts, you can configgure DG in DHCP pool.
It wiil assign DG to host automatically.
ip helper-address is the same as in cisco.
You need to configure ip helper-address in VLANs there your hosts resides to let switch catch their broadcast DHCP messages and relay them to DHCP server. An address in ip helper-address command must be the DHCP server ip address.

I think that example will help

Re: Layer 3 between two 2510 and one 2910

Hi Natasha

have at the end configure my uplink GIGABIT from 2910 to the 2510 . Have to use the Trunk mode LACP or is enough the TAG :

2910(config)# trunk ethernet 21-24 trk1 lacp
vlan 2
name "Server_Network"
untagged 1-20
ip address 192.168.2.252 255.255.255.0
tagged 21-24
exit

thanks for clarify
Natasha Samoylenko
Trusted Contributor

Re: Layer 3 between two 2510 and one 2910

If you need to connect two switches with parallel links, you should use trunk.
Otherwise you create a loop.

So, if you connect switches 21-24 ports, then on both side of trunk (on both switches) you need to create trunk with command:
2910(config)# trunk 21-24 trk1 trunk
OR (they do the same thing)
2910(config)# trunk 21-24 trk1 lacp

But after that you can not assign ports 21-24 to VLAN.
By default, after command "trunk 21-24 trk1" trk1 will be assigned to VLAN 1 as untagged.
You need to assign trk1 as tagged or untagged to necessary VLANs.

So, you need to go, for example, in VLAN 2:
vlan 2
name "Server_Network"
tagged trk1

Re: Layer 3 between two 2510 and one 2910

Yes is clear this

I need only to transport the TAGGED vlan in my TRUNK port as Cisco ( have 6 certification )

I need the equivalent command in HP :

Int Gig1/1
switchport trunk encapsulation dot1q
switchport trunk native vlan 2
switchport trunk allowed vlan 2-4


thanks
Natasha Samoylenko
Trusted Contributor

Re: Layer 3 between two 2510 and one 2910

If you need to configure only one port between switches, then you don't need a trunk command.

I need the equivalent command in HP :
Int Gig1/1
switchport trunk encapsulation dot1q
switchport trunk native vlan 2
switchport trunk allowed vlan 2-4

On HP for port 10:
vlan 2
untagged 10

vlan 3
tagged 10

vlan 4
tagged 10

Terminology:

Cisco trunk ---- HP tagged
Cisco access ---- HP untagged
Cisco EtherChannel or Aggregation --- HP trunk or Link Aggregation

Re: Layer 3 between two 2510 and one 2910

100 % clear !

Thanks a lot
Alberto