Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Limit Port via CLI

 
SOLVED
Go to solution
Occasional Visitor

Limit Port via CLI

Hello,
I have an Aruba 2530 switch and want to limit port 45 to 10 MBit via the "CLI".
The command "int 45 speed-duplex auto-10-10" causes the error message "Invalid input: int".
Can someone give me the correct syntax?

3 REPLIES 3
HPE Pro
Solution

Re: Limit Port via CLI

Hi @Benjamin89 !

configure
interface 45 speed-duplex auto-10

OR

configure
interface 45
 speed-duplex auto-10
exit

 

I am an HPE employee

Accept or Kudo

HPE Pro

Re: Limit Port via CLI

Hello

You are probably not in the global configuration context. You need to enter configure terminal or shortened config before you can change any config settings.

Here is what happens when I enter directly int 34 speed-duplex

HP-2530-48#
HP-2530-48# int 45 speed-duplex

Invalid input: int

Here I first enter conf, the promt changes and after that I can enter interface 45 speed-duplex. You can see all the options for your reference


HP-2530-48# conf
HP-2530-48(config)# int 45 speed-duplex ?
10-half 10 Mbps only, half duplex.
100-half 100 Mbps only, half duplex.
10-full 10 Mbps only, full duplex.
100-full 100 Mbps only, full duplex.
1000-full 1000 Mbps only, full duplex.
auto Auto-negotiate link parameters.
auto-10 10 Mbps only, auto-negotiate link parameters.
auto-100 100 Mbps only, auto-negotiate link parameters.
auto-2500 2500 Mbps only, auto-negotiate link parameters.
auto-5000 5000 Mbps only, auto-negotiate link parameters.
auto-2500-5000 2500 or 5000 Mbps only, auto-negotiate link parameters.
auto-1000 1000 Mbps only, auto-negotiate link parameters.
auto-10-100 10 or 100 Mbps only, auto-negotiate link parameters.
auto-1000-2500 1000 or 2500 Mbps only, auto-negotiate link parameters.
auto-1000-2500-5000 1000, 2500, or 5000 Mbps only, auto-negotiate link
parameters.
auto-10g 10 Gbps only, auto-negotiate link parameters.
HP-2530-48(config)# int 45 speed-duplex

I think auto-10-10 is also not a valid option. You need to determine if the end device supports autenogotiation or only fixed settings, if it supports full or only half duplex.

I am an HPE employee

Accept or Kudo


Occasional Visitor

Re: Limit Port via CLI

Thank you very much!

It works