Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Link between HP2848 and Cisco 3750G

Karsten Aarhus
Occasional Visitor

Link between HP2848 and Cisco 3750G

I am trying to connect a HP 2848 and Cisco 3750G. But I don't seem to get it right. I have follow the thread from Mar 5,2007 "Vlan trunking between Procurve 2848 and Cisco 3750G" but it still do not work.
My setup is as follow:
I have Cisco 3750G in my server room and I have just buyed HP 2848. I have connected the 3750G and HP with fiber cable and the following is showing when I type show running-config on my cisco:
interface GigabitEthernet2/0/50
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 5
switchport mode trunk
switchport nonegotiate
speed nonegotiate
flowcontrol receive on
no cdp enable
!

on my hp the following is showing when I run show running-config:
Running configuration:

; J4904A Configuration Editor; Created on release #I.10.32

hostname "ProCurve Switch 2848"
time timezone 1
fastboot
console baud-rate 115200
interface 45
flow-control
speed-duplex 1000-full
no lacp
exit
trunk 45 Trk1 Trunk
ip default-gateway 192.168.2.3
ip routing
ip timep manual 192.168.2.208 interval 5
vlan 1
name "DEFAULT_VLAN"
untagged 9-15,17-33,35-36,38-44,46-48,Trk1
ip address 192.168.2.20 255.255.255.0
no untagged 1-8,16,34,37
exit
vlan 5
name "Vlan5"
untagged 1-8,16,37
no ip address
tagged 33-34
exit
no stack
interface 45
link-keepalive vlan 5
exit
spanning-tree
spanning-tree 45 bpdu-filter
spanning-tree Trk1 priority 4.

I cannot get any data from my HP to my Cisco.

I hope any one have a clue.

Thanks
3 REPLIES
Joel Belizario
Trusted Contributor

Re: Link between HP2848 and Cisco 3750G

Have you tried with spanning tree disabled on the switch? Just thinking that some port blocking may be occuring.
Karsten Aarhus
Occasional Visitor

Re: Link between HP2848 and Cisco 3750G

I disable the following commando in cisco switch.
switchport nonegotiate
speed nonegotiate
flowcontrol receive on
then i reset my hp to facotory default and configured this way:
Running configuration:

; J4904A Configuration Editor; Created on release #I.10.32

hostname "ProCurve Switch 2848"
interface 25
no lacp
exit
interface 45
no lacp
exit
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
ip address dhcp-bootp
no untagged 1-48
exit
vlan 5
name "vlan 5"
untagged 1-44
ip address 192.168.2.20 255.255.255.0
tagged 45-48
exit
primary-vlan 5
And it finaly did work.
So maybe it help to disabled the spanning-tree.
Thanks for your time and help
/Karsten
Karsten Aarhus
Occasional Visitor

Re: Link between HP2848 and Cisco 3750G

see my reply