Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

MSTP question

chris99099
Occasional Contributor

MSTP question

I have configured a network with two core-switches and some edge-switches. I configured MSTP like so:

spanning-tree
spanning-tree config-name "XXXXX"
spanning-tree config-revision 1
spanning-tree instance 1 vlan 1 2 4 10 12 20 30 50
spanning-tree instance 1 priority 1
spanning-tree instance 2 vlan 6-9 11 13 21 31 51
spanning-tree instance 2 priority 2

on the edge switches I configured like so:
spanning-tree
spanning-tree config-name "XXXXX"
spanning-tree config-revision 1
spanning-tree instance 1 vlan 1 2 4 10 12 20 30 50
spanning-tree instance 2 vlan 6-9 11 13 21 31 51

But when I do a show spanning-tree on the edge-switches I get this:

XXXXXS1# sh spanning-tree mst-config

MST Configuration Identifier Information

MST Configuration Name : XXXXX
MST Configuration Revision : 1
MST Configuration Digest : 0x4A7DD153CAAAB5585B49E9078CB3DC15

IST Mapped VLANs :
Instance ID Mapped VLANs
----------- ---------------------------------------------------------
1
2

Is that normal, because I would have expected to see the vlan's somewhere...
3 REPLIES
Mohieddin Kharnoub
Honored Contributor

Re: MSTP question

Hi

If you configured Core1 with priority 1 for instance 1 and priority 2 for instance 2

Then make sure that Core2 has priority 2 for instance 1 and priority 1 for instance 2.

Then check the following on both core switches

Core1(config)#show spanning-tree instance 1
and you should get (this switch is the root)

Core2(config)#show spanning-tree instance 2
and you should get (this switch is the root)

Then check:

Edge(config)#show spanning-tree instance 1
and you should get the MAC address of Core1 as the root.

Edge(config)#show spanning-tree instance 2
and you should get the MAC address of Core2 as the root.

Good Luck !!!

Science for Everyone
Matt Hobbs
Honored Contributor

Re: MSTP question

That looks to be a display bug I'd say. I can't remember off the top of my head, but does it show the mapped VLANs with a 'show span instance 1' etc?

Matt Hobbs
Honored Contributor

Re: MSTP question

What are your edge switches and what firmware are you running? I've quickly tested this on a few and it's showing up fine.

Make sure you're running the latest firmware if you haven't done so already.