Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Mode 4 LACP trunks and RHEL / Centos / Fedora ethernet bonding

Max Eaves
Occasional Contributor

Mode 4 LACP trunks and RHEL / Centos / Fedora ethernet bonding

Chaps,

My first posting here, as HP Procurve technical support were not able to help. We have a number of Procurve switches (2900), and in this case, I am trying to setup an LACP / 802.3ad trunk on my Fedora / RHEL servers, and I am not having much luck.

I have used the following websites to build my server ethernet bonds: http://landofthefreeish.com/linux/howto-setup-network-bonding/ and I have also referenced http://www.mjmwired.net/kernel/Documentation/networking/bonding.txt for some more information on linux bonding.

On the switch, I have setup two PASSIVE LACP trunks. Its seems that just settings up LACP dynamic links doesn't really work.

I have cat'd /proc/net/bonding/bond0 and it shows that the mii link is up and running. Still unable to ping any of our servers.

I suppose before I start dumping huge amounts of logs on here whether anybody with RHEL5 or Centos or Fedora has had success in port trunking or LACP trunking at all. If they have, would they be kind enough to copy their ifcfg and modprobe.conf files showing their configuration...and how they configured the switch to play nicely with the server.

Thanks


Max
2 REPLIES
Max Eaves
Occasional Contributor

Re: Mode 4 LACP trunks and RHEL / Centos / Fedora ethernet bonding

You know, about 5 minutes after I wrote this, I fixed the problem. This catches me out everytime. When you enable a trunk of any kind, you have to make sure that you re-enable the VLAN that it is connected to. Doh....

Thanks for your time.
Max Eaves
Occasional Contributor

Re: Mode 4 LACP trunks and RHEL / Centos / Fedora ethernet bonding

Both ports should be set as LACP passive, and the trunk should then be dropped into the VLAN. Mode 4 should be setup in /etc/modprobe.conf.