Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Multicast over GRE tunnel

Luisi
Occasional Advisor

Multicast over GRE tunnel


Hi guys,

I've got the following scenario (please find attached the network diagram):

I've got 2 routers (7203dl and 7102dl) connected to each other through a switch. The environment is totally isolated as is only for
testing purposes.

* The 7203dl router has 3 interfaces:

- 172.16.32.16/24, which is connected to the switch

- 192.168.1.1/24, which is the LAN where there is a host (192.168.1.40) multicasting on 239.1.0.1:2000
(it is a video stream).

- 10.0.0.1/24, which is the GRE tunnel IP interface

* The 7102dl router has 3 interfaces:

- 172.16.32.17/24, which is connected to the switch

- 192.168.2.1/24, which is the LAN

- 10.0.0.2/24, which is the GRE tunnel IP interface


There's a GRE tunnel between both routers.

What I would like to accomplish here is to get the multicast through the GRE tunnel and be able to play that
video stream from a VLC player located in a host on 192.168.2.0/24 network.

At the moment I've some traffic going through the GRE tunnel but no multicast at all.

Any help would be appreciate it!

Many thanks.



7203dl CONFIG
--------------

Building configuration...
!
!
hostname "ProCurveSR7203dl"
enable password admin
!
!
ip subnet-zero
ip classless
ip routing
ip multicast-routing
!
event-history on
no logging forwarding
no logging email
logging email priority-level info
!
no service password-encryption
!
username "admin" password "admin"
!
!
no ip firewall alg h323
!
!
!
!
!
no autosynch-mode
no safe-mode
!
!
!
!
!
!
!
!
interface eth 0/1
ip address 192.168.1.1 255.255.255.0
no shutdown
!
!
interface eth 0/2
ip address 172.16.32.16 255.255.255.0
no shutdown
!
!
!
!
interface tunnel 1
description TunnelTo7102
ip address 10.0.0.1 255.255.255.0
ip pim sparse-mode
tunnel mode gre
tunnel source 172.16.32.16
tunnel destination 172.16.32.17
mtu 1400
bandwidth 100000
no shutdown
!
!
!
!
!
!
router pim-sparse
!
!
!
ip route 192.168.2.0 255.255.255.0 10.0.0.2
!
no ip tftp server
ip http server
no ip http secure-server
no ip snmp agent
no ip ftp agent
!
!
!
!
!
!
!
ip sip
ip sip proxy
!
line con 0
login
!
line telnet 0 4
login
password admin
no shutdown
line ssh 0 4
login local-userlist
no shutdown
!
!
end




7102dl CONFIG
--------------

Building configuration...
!
!
hostname "ProCurveSR7102dl"
enable password admin
!
clock timezone +9:30-Adelaide
clock no-auto-correct-DST
!
ip subnet-zero
ip classless
ip routing
ip multicast-routing
!
event-history on
no logging forwarding
no logging email
logging email priority-level info
!
no service password-encryption
!
username "admin" password "admin"
!
!
no ip firewall alg h323
!
!
!
!
!
no autosynch-mode
no safe-mode
!
!
!
!
!
!
!
!
interface eth 0/1
ip address 192.168.2.1 255.255.255.0
no shutdown
!
!
interface eth 0/2
ip address 172.16.32.17 255.255.255.0
no shutdown
!
!
!
!
interface tunnel 1
description TunnelTo7203
ip address 10.0.0.2 255.255.255.0
ip pim sparse-mode
tunnel mode gre
tunnel source 172.16.32.17
tunnel destination 172.16.32.16
mtu 1400
bandwidth 100000
no shutdown
!
!
!
!
!
!
router pim-sparse
!
!
!
ip route 192.168.1.0 255.255.255.0 10.0.0.1
!
no ip tftp server
ip http server
no ip http secure-server
no ip snmp agent
no ip ftp agent
!
!
!
!
!
!
!
ip sip
ip sip proxy
!
line con 0
login
!
line telnet 0 4
login
password admin
no shutdown
line ssh 0 4
login local-userlist
no shutdown
!
!
end







1 REPLY
Olaf Borowski
Respected Contributor

Re: Multicast over GRE tunnel