Switches, Hubs, and Modems
cancel
Showing results for 
Search instead for 
Did you mean: 

Multicast pb

SOLVED
Go to solution
DamianS
Advisor

Multicast pb

Hello To all:
I have a configuration for a DECT system and it requires to do this configuration on my Procurve 2910al switches.
below is what is needed as config on the switch

1. Spanning Tree: disable Spanning Tree on port used by DAP
2. IP Multicast: enable and set to “Fast Forward” Mode
3. IGMP Snooping & IGMP Query Mode: disable

How can I configure this on the Procurve since these options exist on 3COM.

Thanks in advanced
26 REPLIES
DamianS
Advisor

Re: Multicast pb

Note that there is no fast forward on Procurve. i found only forward mode.
and i have MSTP enabled already on all my switches so how can i disable spanning tree on some ports on the switch?
i searched a lot without finding a hint about disabling IGMP query or snooping.
note that to enable multicat, i had to enable IGMP that was disabled by default/
thanks a lot for your help
Shadow13
Respected Contributor
Solution

Re: Multicast pb

for the ports connected to the DAP issue the following
#no spanning-tree admin-edge-port
#no spanning-tree auto-edge-port

For IGMP Query it's disabled by default when you enable IGMP, it will be enabled if you configured an IP address under the vlan where you have enabled IGMP on the switch.
If you have IP address under the vlan then issue the command
#no ip igmp querier.

For "Fast Forward" i'm not sure but check the below:

high-priority-forward

â   [no] vlan VLAN-ID ip igmp high-priority-forward
Usage: [no] ip igmp high-priority-forward
Description: Enable/disable the high priority forwarding of traffic for
subscribed IP Multicast groups. This feature is configured on
a per-VLAN basis.
DamianS
Advisor

Re: Multicast pb

Thanks a lot for replying thast fast.
I will try these commands now.
I have an IP an that VLAN only on my core switch, however on the edges the vlan is without IP addresses. you mean i should run this command to disable igmp query only where i have an IP on the specific vlan?
what abt igmp snooping?
the high priority is for the vlan and not for the ports right?
thanks dude for your help
Shadow13
Respected Contributor

Re: Multicast pb

Yes as per the desc. it per VLAN,

For Query:

â   [no] interface vlan VLAN-ID ip igmp querier
Usage: [no] ip igmp querier [interval ]
Description: Specify querier/non-querier capability for the VLAN. IGMP
queries are not sent when the mode is disabled. When
enabled, the device cannot become Querier for the subnet
unless the VLAN has an IP Address (use the 'show ip' command
to determine this). Each subnet must have at least one IGMP
Querier-capable device in order for IGMP to function
properly. The querier interval setting modifies the time (in
seconds) between IGMP queries.


For Snooping am not sure, but you can check the CLI guide for the 5400 switches, the commands are almost the same for all ProCurve switches, it's availabe on with the other manuals. check the link below
http://cdn.procurve.com/training/Manuals/3500-5400-6200-8200-CLI-K_14_09.pdf
DamianS
Advisor

Re: Multicast pb

Thx again dude but unfortunately i am still having the same multicast error on the DAP system.
it's giving me errors in the log:
- port high collision or drop rate
- excessive crc/alignement errors
- duplex mismatch. reconfig port to auto
although the DAP requirements is 100-full duplex for the port where it is connected.
do you think spanning tree is causing this? because it's mentioned to disable spanning tree for the ports where DAP is connected.
disabling IGMP query and snooping
enabling multicast on fast forward.
any ideas?
thanks a lot
Shadow13
Respected Contributor

Re: Multicast pb

- port high collision or drop rate
This might mean duplex mismatch

- excessive crc/alignement errors
Bad cablings

So i would recommend 1st check the cables, check the speed-duplex on both ends and since you are sure that the DAP run on 100-full duplex then configure the switch to 100-auto and on the DAP also the same and you have to make sure that this is done.
Shadow13
Respected Contributor

Re: Multicast pb

one more thing. configure the port connected to the DAP with BPDU filtering :
BPDU filtering allows control of spanning-tree participation on a per-port basis. When enabled on a port, it excludes
this port from any spanning-tree participation: the port will ignore spanning-tree BPDUs and stay locked in â forwardingâ
state.

#spanning-tree bpdu-filter
DamianS
Advisor

Re: Multicast pb

Thx a lot for your time spent helping me.
I tried the bpdu filter on the ports where the DAP is connected, however. i am still getting the multicast error.
and what i did is i've tested the cabling using the Fluke cable anlayzer and i got a pass results.
does disabling spanning tree on some ports
affect the switch performance? is it safe to do it? because MSTP is a must in my configuration and I configured it all along with vrrp and it's working fine.
thanks again dude
Shadow13
Respected Contributor

Re: Multicast pb

actually there is no command to disable spanning tree per port :)

Have you checked the speed-duplex settings on both ends ? make sure both are set to 100-auto not AUTO
DamianS
Advisor

Re: Multicast pb

how come no command for disabling spanning tree per port and what about the commands that you gave me up:
#no spanning tree port list admin-edge-port
#no spanning tree port list auto-edge-port
what does those command stands for? what are their role? wcoz when I ran them both on the desired port, i got in the show run config only auto edge port appeared.

the duplex problem is solved thanks :)
Shadow13
Respected Contributor

Re: Multicast pb

the commands mentioned earlier are similar to disabling the spanning tree, for the normal behavior the spanning tree waits 3 secs to listen to BPDU from the ports, by enabling admin edge port the port will go to forward directly instead of waiting 3 secs.

so enable admin edge port on that specific port :)

Sorry i'm trying to give you all the options that can help i don't have a direct solution, i'm trying to fix the symtomps that you are mentioning.
DamianS
Advisor

Re: Multicast pb

I really appreciate your help buddy. and your instructions helped me a lot.
Thx for your explanation and your time.
but this problem is causing me lot of pressures.
your help is really needed and appreciated.
Shadow13
Respected Contributor

Re: Multicast pb

to save you the time, and since you have tried almost everything i would recommened contacting ProCurve support team, but 1st can you tell me in which country are you in ?
DamianS
Advisor

Re: Multicast pb

thx Buddy for everything.
I'll proceed with procurve team.
I'm from Canada
thanks
Shadow13
Respected Contributor

Re: Multicast pb

am not sure about either u enabled this command or not but try it also
bpdu-filter
â   [no] spanning-tree [ETHERNET] PORT-LIST bpdu-filter
Stop a specific port or ports from transmitting BPDUs, receiving BPDUs, and assume a
continuous fowarding state.

enable it on the port connected to the DAP,
also can you explain more about the DAP device :D ?
Shadow13
Respected Contributor

Re: Multicast pb

BPDU filtering allows control of Spanning Tree participation on a per-port basis. It can be used to exclude specific ports from becoming part of Spanning Tree operations. A port with the BPDU filter enabled will ignore incoming BPDU packets and stay locked in the Spanning Tree forwarding state. All other ports will maintain their role.

This is what you want to do to disable spanning tree on that port :D
sorry i did not notice this command before, so i should thank you for making me know better about this command, hope it helps ;)
DamianS
Advisor

Re: Multicast pb

Heyy, Thanks for your useful informations.
DAP is the system of Voice calls using poe access points to transmitt voice traffic using LAN. what is mentioned by the requirements given by NEC are these points of disabling IGMP snooping, and query. disabling spanning tree, assgin 100 full duplex to the ports and enabling multicast.
i've noticed something on the ports activity where DAP are connected is that even disabling spanning tree auto-edge-port, I am still getting in the log file that the port where DAP are connected port is offline, port is blocked by STP the port is online.
shouldn't I stop receiving these 3 messages when disabling spanning tree for a specific port?
the DAP is generating a multicast errors that's why i am liniking the problem to these configuration given by NEC.
Thanks
Shadow13
Respected Contributor

Re: Multicast pb

Nice system,

then enable BPDU filter on these ports and check, u should not get any blocks on these ports after that.
DamianS
Advisor

Re: Multicast pb

thanks again for your time.
you mean that you want me to enable the command:# no spanning-tree 1 bpdu-filter
or: spanning-tree 1 bpdu-filter

Although, this command:
#spanning-tree bpdu-filter admin-edge-port
is not making anything
but the command:
#spanning-tree bpdu-filter auto-edge-port
is appearing in my show run
do u have any explanation for that?

thx
Shadow13
Respected Contributor

Re: Multicast pb

configure bpdu-filter
#spanning-tree bpdu-filter
also configure
#spanning-tree admin-edge-port
for MSTP and for RSTP
#spannig-tree edge-port

the commands will show under show spanning-tree

Auto-edge will let the switch decide which port to be admin and which wont be by the traffic it receives.
DamianS
Advisor

Re: Multicast pb

ok buddy
thanks a lot for your information
Shadow13
Respected Contributor

Re: Multicast pb

U r welcome, thanks alot for the points :D
I hope anything from that will help
Shadow13
Respected Contributor

Re: Multicast pb

[no] interface vlan VLAN-ID ip igmp querier
Usage: [no] ip igmp querier [interval ]
Description: Specify querier/non-querier capability for the VLAN. IGMP
queries are not sent when the mode is disabled. When
enabled, the device cannot become Querier for the subnet
unless the VLAN has an IP Address (use the 'show ip' command
to determine this). Each subnet must have at least one IGMP
Querier-capable device in order for IGMP to function
properly. The querier interval setting modifies the time (in
seconds) between IGMP queries.


So if the vlan that you are using has IP Address and you want to disable igmp querier then issue the below command under the vlan;
#no ip igmp querier


also i have found this command for the 2910al switches:

ProCurve(config)# vlan 1 ip igmp forward

forward:Forward all multicast traffic through this port.
DamianS
Advisor

Re: Multicast pb

- #no igmp querier command is running on the PABX vlan, and on the primary vlan where all the uplinks to the edge switches are untagged in this primary vlan.
when i do a show command i can see it under those 2 vlans that no igmp querier
- #ip igmp forward is enabled as well for the ports where DAP is connected to the PABX vlan, and i did it as well to the uplinks ports in the primary vlan where the fiber uplinks are untagged in the primary vlan.
I've enabled High-Priority-forward for the vlan as well.
i ran #spannning-tree bpdu filter
and #spanning-tree admin-edge-port to the ports where DAP are connected
and i can see them all configured when i do a show run.
but i am still getting the multicast problem that preventing the system to function properly.
many thanks to you effort and time spent with me to figure out what could be the problem.
I really appreciate your support and help.
it's been a headache for me now since the administration started on pushing on me to solve this matter :(